8

As we all know, the Twitter v1 API is being shut down, so any plugins not using the new API will stop working in the near future.

Which ExpressionEngine Twitter plugins have already been updated, and which will stop working soon?

Further reading:

Note: I'm marking this as community wiki so that anyone with useful information can contribute.

12

This answer is partly based on ExpressionEngine Twitter API v1.1 add-ons. It is a "community wiki" answer, so please feel free to edit it with any extra information available (state sources where possible).

Already Updated for API v1.1

Permanently Deprecated / Will Not Be Updated

Unknown Status

  • Tweetline (Free) by David Dexter / Codesly (last updated June 2012 so unlikely)
3

NSM Twitter has been updated and we are currently preparing an updated release at the moment.

If you want to update in the meantime you can change line 21 of twitteroauth.php to the new Twitter API endpoint - https://api.twitter.com/1.1/

  • Might be time update the version on the NSM site with the updated line too. ;) – Adam Christianson Jun 17 '13 at 16:58
  • I agree with Adam! – Jon Horton Jun 25 '13 at 1:23
1

This is a non-EE answer but is another option -- We've been relying on a JS solution for our EE projects, that loads the tweets in the page within the browser. The jQuery plugin we've been using is:

http://tweet.seaofclouds.com/

Concerned that the v1.1 update would break that jQuery plugin, yesterday we found and tested this wrapper:

https://github.com/StanScates/Tweet.js-Mod

It's working fine where we've implemented it, and is updated to support v1.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.