5

I'm running into an issue where Assets doesn't upload a file over ~10MB. I've used EE's file manager and that could upload two different files, one ~18MB and one ~23MB.

I have this in .htaccess (which is what was needed to get EE's file manager to upload the larger files):

php_value upload_max_filesize 32M
php_value post_max_size 32M

When trying to use Assets' File Manager, the progress bar loads up, then fades away, but the file never shows up anywhere. There is no error given, not even in the console.

I'm running EE 2.5.5 and Assets 2.0.5.

Edit: I have also changed php.ini on the server to match the above PHP values in .htaccess just in case. Still no go.

Any ideas?

  • What about your server error logs? I'd have a look at those as well. – Lisa Mar 6 '13 at 17:57
  • Are those php_value's matching up when you check PHP info? You can see if your htaccess or php.ini settings are being overridden by other server settings by checking Tools > Utilities > PHP Info from your control panel. – Alex Roper Mar 6 '13 at 22:38
  • @Lisa: I checked the server error logs and nothing related to that stands out. – Angie Herrera Mar 7 '13 at 4:59
  • @Alex: Yep, PHP info matches up (made sure of that before posting). – Angie Herrera Mar 7 '13 at 5:00
  • Angie - is this a local source or S3? – Lisa Mar 7 '13 at 17:33
1

It's possible you need to adjust additional php settings to get the large files to upload. These are the suggested settings to adjust for large file uploads.

upload_max_filesize
max_input_time
memory_limit
max_execution_time
post_max_size
| improve this answer | |
  • All of that has already been tried. – Angie Herrera Apr 11 '13 at 20:40
1

Apache: Keep-Alive Timeout should be more than 5 and turned on (2GB files is around 100)

PHP: check open_base

Server: your /tmp partition needs to be more than the to uploading file. Most /tmp partitions are 512M if your file is larger it won't work. If your /tmp is almost full you get the same problem. (uploads will be uploaded to the /tmp first before moved to your folder)

I guess that your problem lies -> /tmp

| improve this answer | |
-1

Any update on this issue? We started experiencing the same problem for any files > 2M (using a macMini with MAMP Pro 2.1.1, any version of PHP, w/ or w/o cache). Apache returns the following error: [notice] child pid 31439 exit signal Segmentation fault (11)

Same symptom, the progress bar appears briefly then disappears immediately…And the image is not uploaded

| improve this answer | |
  • Hey user1404 - have you made the same changes in upping memory and time allotments for big uploads? And are you seeing any JS errors in your browser's dev console? – Lisa Apr 29 '13 at 18:53
  • Please avoid posting new questions in the "Answer" section. Best to ask a new question with all the details of your problem, and link back to this one. – Adrian Macneil May 3 '13 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.