3

this problem only occurs in my local MAMP PRO 2 environment.

Assets acts like it's working (I see the progress bar till the end) but then no files!

NOTE THAT On my staging/production environment it's working!

my local settings : Assets 1.2.2 EE 2.5.3 PHP 5.3.20

in the logs when I try to upload I get this error (in apache logs)

[Wed Mar 06 19:26:41 2013] [notice] child pid 1425 exit signal Segmentation fault (11)

  • Hey Francesco - does EE's file manager let you upload those files? Also, I'd recommend upgrading to Assets 2.0.5 before further troubleshooting. :) – Lisa Mar 6 '13 at 20:31
  • Howdy Francesco, – dgrebb Mar 6 '13 at 22:28
  • Hi Lisa, Yes I can upload using EE file manager! – Francesco Pensabene Mar 6 '13 at 23:24
  • Updated to Assets 2.0.2 but the problem persists – Francesco Pensabene Mar 7 '13 at 11:28
3

See here: https://stackoverflow.com/a/6135485/462702

You need to increase PHP's maximum upload size. This is nothing to do with Assets (otherwise it would be broken in your development environment too).

You need to change TWO settings (PHP will use the lowest). You can either change them in php.ini (preferable, if you have access to it), or your .htaccess (changing the values in your .htaccess won't always be allowed by your host). If neither option is available to you, you need to contact your web host.

Either set these in php.ini:

post_max_size=20M
upload_max_filesize=20M

Or add these to your .htaccess:

php_value post_max_size 20M
php_value upload_max_filesize 20M

You can check the current values by going to the EE CP Tools > Utilities > PHP Info and searching for the settings. I'd bet that one of them is currently set to 2mb :)

| improve this answer | |
  • Actually This is the first thing I have changed in php.ini, the Two values are 128M in my localhost! – Francesco Pensabene Mar 9 '13 at 0:05
  • Are they definitely still set to that value when you look at PHP Info through EE? It may be overridden somewhere. – Adrian Macneil Mar 10 '13 at 4:46
2

Try adding the following to your .htaccess file:

php_value memory_limit 128M
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.