2

Since Wygwam 2.3.1 it's supposed to have "Set the forcePasteAsPlainText CKEditor config setting to 'Yes' by default" (pasted from release notes). But I'm still getting a lot of junk code (inline styles, Word markup, the whole shebang).

Is this happening for other people as well? I've even tried adding it manually as a config setting, but that didn't make any difference.

Any help would be greatly appreciated, as this is making my client's life miserable.

2
  • Do you have Wygwam 2.7 installed? – Anna_MediaGirl Mar 8 '13 at 18:10
  • Is the markup getting through in all browsers (and operating systems) or just one? – Timo Häkkinen Mar 29 '13 at 6:11
1

Wygwam sucks at removing formatting. I have exhausted all resources in trying to find an adequate solution. Luckily I have found 2 simple plugins that will take care of this for you, depending on what you're trying to do.

Two Scenarious

  1. You're using WYGWAM to show an H1 and want to keep the Spell Checker in place but want to lose the <p> tag it outputs. Use PtoBR: http://devot-ee.com/add-ons/paragraph-to-br

  2. You're using WYGWAM to output a "summary" on a blog listing and want everything remove but a few things, then I'd use Super Geekery Tag Stripper: http://devot-ee.com/add-ons/supergeekery-tag-stripper

Both are quite useful depending on your needs. There are other strippers out there like Hacksaw, but those are two that I absolutely recommend.

One last thing you can do:

Use the "paste from word" functionality button? I use that ALL the time and saves a lot of headaches. Works with getting rid of embedded styles in just about anything too, not just Microsoft Word related issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.