3

I’ve got something here that is absolutely not critical, but it's bugging me and I’ve been encouraged to post it here to see if anyone can help out.

I am trying to change the skin of WYGWAM to one I found for CKEditor that I really enjoy (Moono, which I believe is the default now), but when I try to do that, the WYGWAM field will no longer load. I found what I thought was the appropriate place to change the skin in third_party/wygwam/helper.php. And I uploaded the skin to themes/third_party/wygwam/lib/ckeditor/skins. But no joy. Any idea what I'm doing wrong?

Here is what I’m changing in helper.php:

public static function base_config()
{
    return array_merge(array(
        'skin'               => 'wygwam2',
        'toolbarCanCollapse' => 'n',
        'dialog_backgroundCoverOpacity' => 0,
        'entities_processNumerical' => 'y',
        'forcePasteAsPlainText' => 'y'
    ), self::default_config_settings());
}

Obviously, I’m changing 'wygmwa2' to 'moono'.

Here is what the field looks like before trying to change the skin: before

And here is what it looks like when I change the skin in helper.php: after

Additionally, after playing around with helper.php, I realized I could change skins on a per configuration basis in the advanced settings and I tried that, but experienced the same problem.

The field is obviously failing to initialize. Any ideas, anyone have any experience with this?

3

I think this may be somewhat more simple. Can you go to your Wygwam editor configuration, under Advanced Settings, in the drop-down, choose Skin and follow those instructions. Let's see if that helps?

If that doesn't work, please check your dev console for any JS errors and report them here. Thank you!

Edit to add: this is quite an old post, but you might try what's in here if the above doesn't work: https://getsatisfaction.com/pixelandtonic/topics/use_office2003_skin_in_wygwam

| improve this answer | |
  • I agree with Lisa here. Have you checked your debugger for any JS errors? It will likely give you some clues. Most likely there are some JS or CSS path issues or something like that. – Adam Christianson Mar 13 '13 at 16:34
  • Hi Lisa, I didn’t explain it very well, but I did try the drop down configuration. I tried again and got the same thing. I tried with just the skin name, I tried with the path to the skin, I tried with skin name with path after comma (both with and without trailing slash), and I tried skin name with hard server path after comma. I can’t find anything called dev console in the CP. I checked the developer log and got no results found. I also enabled output profiler, and as far as I can tell there’s nothing weird going on. – TJ Draper Mar 13 '13 at 21:09
  • Your dev console is a browser feature. In Chrome, for instance, right click and choose "Inspect Element" - then click Console. Then load the publish page and see if there are any errors there. :) – Lisa Mar 13 '13 at 21:12
  • "slaps head" doh BRB... – TJ Draper Mar 13 '13 at 21:17
  • Here is what I’m getting: buzzingpixelcreative.com/web-stuff/eese/2013-03-13/… – TJ Draper Mar 13 '13 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.