1

Hoping someone can help ... I have installed the latest Multi-site manager for EE2+, set up a site and updated admin.php & index.php files as stated in the instructions.

However, when I go to visit http://site2.com.au I get instantly redirected to http://site1.com.au and I can't work out why?

Full details of install are outlined below:

Installed MSN, uploaded files (3) to appropriate folders in site1. Activated/turned on MSN.

Changed sites from site1 to site2 via top right site drop-down. Updated root url to site2.com.au and created default template with temporary text in design>templates etc.

After adding site2 as a stand alone site (reseller hosting account) without success & speaking in detail with my host e2, they had this to say:

"It seems that domain2 account cannot access the other account's path since they are separate cpanel accounts. I would suggest you to try creating domain2 as addon domain under the domain1 for creating multisite"

So I deleted the stand alone hosted account for site2 and added it as an 'Add on domain' via site1 cPanel.

This created the following folder structure:

/home/
> short_name/
>> public_html/
--- system
--- themes
--- admin.php
--- index.php
>>> site2.com.au
---- admin.php
---- index.php

By adding site2 as an add on domain it created a folder in the root directory of site1.

I copied index.php & admin.php from site1 root and edited them with the following info:

index.php (full server path)

$system_path = '/home/short_name/public_html/system/';

Also tried (relative?)

$system_path = '../system/';

And

$assign_to_config['site_name']  = 'site_2';
$assign_to_config['cp_url'] = 'http://site2.com.au/admin.php';
$assign_to_config['site_url'] = 'http://site2.com.au';

admin.php is pretty much the same apart from the site_url is not there.

However, when trying to access http://site2.com.au & /admin.php I get instantly redirected to http://site1.com.au & /admin.php

A very odd thing is if I visit http://site1.com.au/site2.com.au I can see the temporary text I added for site2 default template so it would appear that MSM is working but not redirecting/displaying the URL correctly?

I completed all the steps till the end of "Setup Domains and Sub-domains" but didn't go any further than a quick read over as the rest of the steps seemed to refer to shared channels & files etc.

I am hoping it is a smile fix & appreciate any help anyone can offer.

Thanks, Dan

2

It seems to me the issue is more to do with the DNS you have set up for the second subdomain. You have proved the path you have issued http://site1.com.au/site2.com.au works as site 2 should, i would also imagine http://site2.com.au/site2.com.au would also show you the required site2... If so then your DNS for http://site2.com.au is pointing at the standard public_html folder and not the new sub domain sub folder... i would go back to your host as it looks like your EE MSM set up is working

The reason it wont work in shared hosting is the openbase_dir is disabled otherwise you would be able to access other websites (not your own) on the same server

Hope that helps

| improve this answer | |
  • Hi @Jamesaa, thanks for your response. If I visit site2.com.au/site2.com.au it redirects to site1.com.au/site2.com.au I had the host remove openbase_dir for our reseller account - should it be? – Dan Mar 13 '13 at 7:42
  • Hmmm sounds like you cannot get anything show at site2.com.au - does your host have a domain forward up rather than have site2.com.au pointing at the required nameservers? – Jamesaa Mar 13 '13 at 12:06
  • On the openbase_dir, you need it activated but is security risk on shared servers, so doubt your host will enable, if they will i would move hosts! That said i believe it is possible to get it specified as access from individual locations only. This will not help your current issue though, this will enable you to uses MSM with 2 entirely separate sites (but still on same server). – Jamesaa Mar 13 '13 at 12:17
0

Do you have .htaccess file on site2 domain? I suspect there's some rule there that redirects all requests to site1.

| improve this answer | |
  • Hi @Yuri - no, I don't have an .htaccess file in the site2 domain. However, I do have a .htaccess file in the root of site1 that is removing index.php & removing www. - could this be causing an issue? – Dan Mar 13 '13 at 7:40
  • 1
    Then it should not cause any problems (you can temporary disable it however just to make sure). Here's another suggestion: place a html file in site2.com.au root directory and try to view it in browser. If you still get redirected, then it's clearly server setup and not EE issue, and you should talk to your hosting provider. – Yuri Salimovskiy Mar 13 '13 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.