3

Is there a content limit/length for channels? If so, can the limit be removed?

Reason I ask:

When posting a large amount of content (approx 12,700 characters) in a channel (blog) as soon as I submit I get served a 403 Forbidden screen: http://screencast.com/t/9vPuJo4hup6

However, if I post a small amount of content (a couple of paragraphs) and submit there are no problems.

I tested this further by posting the large amount of content paragraph by paragraph and submitting after each one (paragraph). This process was successful up until I reached a certain amount of content and then I was served the 403 again.

It appears that there is some sort of content limit in channels?

Any help would be appreciated.

Thanks, Dan

6
  • 1
  • 2
    Might also be a mod_security thing. Ask your host whether that's enabled and if they can either disable it or add an exception.
    – Low
    Mar 13 '13 at 8:21
  • @Low, is there any good reason not to ask the host to disable mod_security for my account? (just wondering). Thanks for both of your feedback.
    – Dan
    Mar 14 '13 at 1:00
  • @Low, Have just heard back from our host saying it was indeed the mod_security that was preventing us from posting large amount of content (blog posts). They have disabled mod_security and all seems to be working fine now (thanks!). One last question though - by disabling mod_security does that make our site vulnerable to hackers/attacks? Thanks again.
    – Dan
    Mar 14 '13 at 4:39
  • I'm not entirely versed in mod_security, but from my experience, it's more of a nuisance than a benefit. I don't really know the ramifications, if there are any. I think it doesn't matter all that much. I'll also add a proper answer to your Q so you can mark it as accepted. :)
    – Low
    Mar 14 '13 at 7:41
3

From my experience, getting 404 or 403 errors after submitting a form is because of a mod_security setting in Apache on the server. This isn't something EE can influence or circumvent, really.

You can try to add this to your .htaccess file:

<IfModule mod_security.c>
  SecFilterEngine Off
</IfModule>

However, this could result in an error 500 (Internal Server Error) if you're not allowed to turn the SecFilterEngine off. If that's the case, ask your host if mod_security is enabled and if they could disable it. They could also add one or more exceptions to the mod_security settings for your site instead of disabling it completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.