2

I am trying to get my info to set up PayPal express with Store.

When I login to my PayPal account I am not seeing what they are asking:

From Store Docs:

PayPal Express Checkout requires an API Username, Password, and Signature. These are different from your PayPal account details. You can obtain your API details by logging in to your PayPal account, and clicking Profile > My Selling Tools > API Access > Request/View API Credentials > Request API Signature.

When I click Profile I do not see My selling tools.

I do find on my profiel page: Request API credentials, but when I click that I see: Setting up API permissions and credentials Choose one of the following options to integrate your PayPal payment solution with your online store or shopping cart.

Grant API permission

Then I see: Add New Third Party Permissions Manage permission given to a third-party application to access specific information in your account and take actions on your behalf.

For more information about the permissions you are granting, see Third Party Permissions.

Third Party Permission Username

If I click View API Certificate I get API Username name_api1.gmail.com

API Password ••••••••••••

Request Date

but no signature??????

Any advice?

1

Here is what my PayPal profile page looks like, not sure why you can't see My Selling Tools:

enter image description here

It sounds like you have set up an API Certificate rather than a signature (probably for a different shopping cart). You probably need to go into the View API Certificate, then click Remove.

After that, you should be able to request a new API Signature instead. It sounds like you can't have both a signature and certificate set up at once. I don't want to remove my signature to find out for sure though!

| improve this answer | |
  • I removed the existing certificate, now when I try and generate a new one I get this error:Bad Request Your browser sent a request that this server could not understand. Size of a request header field exceeds server limit. Cookie /n – Peter Eastwood Mar 13 '13 at 14:18
  • used another browser and was finally able to generate – Peter Eastwood Mar 13 '13 at 14:23
  • Oh yeah, that is a paypal bug, happens to me every now and then too (I think from being logged into PayPal developer site as well as live site at the same time). Clearing your cookies fixes it. – Adrian Macneil Mar 13 '13 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.