0

When I install Channel Images, all of my Wygwam text fields disappear on the publish entry pages. I can still see the channel field title for the Wygwam field, but the wysiwyg is gone. Has anyone else run into this issue? If so, how did you fix it?

EE version 2.5.5. Wygwam version 2.7. Channel Images version 5.4.2.

  • Hey Kelly - this shouldn't be a problem. Are you seeing any JS errors in the dev console? – Lisa Mar 13 '13 at 19:07
  • CHANNEL_IMAGES: We can use HTML5 File Upload! channel_images_pbf.js:1317 Resource interpreted as Script but transferred with MIME type text/html: "/themes/third_party/wygwam/lib/ckeditor/plugins/channelimages/plugin.js?t=D09H5XK". ckeditor.js:16 Uncaught SyntaxError: Unexpected identifier plugin.js:1 Uncaught TypeError: Cannot read property 'onLoad' of null ckeditor.js:24 – Kelly Cook Mar 13 '13 at 19:11
  • It sounds like there is a potential JS error in their Wygwam plugin. Have you emailed them directly and asked them to look at this thread? – Lisa Mar 13 '13 at 20:41
  • @LisaWess I have not; I will do that today. Thanks! – Kelly Cook Mar 14 '13 at 13:36
2

I was able to figure out the issue. I used Updater to install Channel Images, and it did not automatically perform the Wygwam integration as outlined in the Channel Images installation steps: http://www.devdemon.com/channel_images/#product_install

Once I added the channelimages folder to the ckeditor plugins folder, it is working properly. Fail on my part for not reading the installation instructions and assuming Updater would handle everything for me.

| improve this answer | |
  • Is this still a current procedure for using CI with Wygwam? Im getting thi problem and cannot get the icon to show up in the publishing Wygwam field. Im using current versions of EE and both add ons.Any help appreciated! – Boshy Dec 1 '14 at 10:01
0

First of all upgrade both add-ons to their latest versions or make sure they are at their most current versions. Of course it would be nice if Exp Eng were at its most current version also. :-)

I don't recall the details of this issue, best to ask the developers, but one solution is to try the settings in Wygwam for "Defer loading". In the settings for Wygwam you can set a preference that displays the Wygwam editor or defers it until you click on the field. In one instance I set this to NOT defer loading. The Edit page loads more slowly, especially if you have multiple Wygwam fields, but this may solve your issue.

Also, are you using any custom CKEditor settings or a custom CSS file for the Wygwam field settings?

  • Bob
| improve this answer | |
  • Both add-ons and EE are current. I submitted a support ticket about this, but wanted to reach out to the community as well to see if anyone else had run into this problem. I tried the defer loading, and that didn't work. I tried both the Basic and Full editor configs and it happens for both. – Kelly Cook Mar 13 '13 at 19:21
  • In one case I was using a custom CSS file for the editor that was also an Exp Eng template. I moved that CSS file to a static location on the server, instead of being loaded as an Exp Eng template. That solved the problem in that case. That's why I was asking about custom CSS files or CKEditor settings. – Bob Foster Mar 13 '13 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.