3

I've sent an email to Exp-resso's support but didn't get an answer. I'm trying to setup the iDAEL payment gateway. Got all the certificates in place. On the final step where you choose you payment iDeal and your Payment Issuer. I'm getting an XML error on the Payment Issuer list.

I did al lot of checking and testing with no result. My question was and is: "on what version of iDAEL is the payment gateway based?" The old version 2 or the new version 3 which was released in April 2012. If based on version 2 then my question is when can we expect an update based on version 3.

When looking at merchant_ideal.php and the change log on iDEAL v3 then it must be based on version 2.

See: http://www.ideal.nl/download/iDEAL_Merchant_Integration_Guide_Summary_of_Changes_v3.3.1_ENG.pdf

If it's already based on version 3 then could someone help my fix this problem?

Running EE 2.5.5. Store 1.6.3 on a windows IIS 6 (<= Yes I know, it sucks but running)

Thanks, Martijn

  • Please check your email, we replied 2 days ago :) – Adrian Macneil Mar 15 '13 at 11:35
  • Did you get this issue resolved in the end? If Adrian's answer helped then don't forget to mark it as accepted. – Ian Apr 14 '13 at 15:02
1

From what I can tell, Store uses iDEAL v2. We simply implemented the version that was specified in documents sent to us when the gateway development was originally sponsored - your email was the first time I heard about an iDEAL v3.

If your bank can support iDEAL v2 then that is the best option for you. Otherwise, it may require us to develop a new gateway if a lot has changed in the API (it sounds like it). You can follow up with us via email if you want to discuss developing a new gateway.

|improve this answer|||||
  • Tnx, Strange that they gave you only iDeal v2 documentation. The European Union is making changes on payments in the EU. It's called SEPA. iDeal's standards aren't compatible with these changes and so a version 3 has been developed. On the first of August 2013 everybody must use version 3. You can read about it here: ideal.nl/?s=idealupdate&lang=eng-GB I'l send you an email about the new gateway but first I've got to finish setting up the site. – Sharkbyte Mar 18 '13 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.