2

When I attempt to Index an Amazon S3 folder, I was getting no response. I get the bar, but no progress.

Everything works fine when I'm indexing a local folder.

So I tried doing it with the Console on while in Firefox and got the following error:

SyntaxError: missing ) in parenthetical @ 
{my site name}/themes/third_party/assets/scripts/assets.min.js?2.0.5:11

Safari gives a similar error:

SyntaxError: Expected token ')'

I'm using Assets 2.0.5 on EE 2.5.5

If you need other details to diagnose, let me know...

Edited to add:

Ran it in the Firebug console - Syntax Error appears to be related to a memory problem:

Fatal error: Allowed memory size of 67108864 bytes exhausted (trie

assets.js?2.0.5 (line 5618, col 6)
2
  • I'm having the same SyntaxError: Expected token ')' issue with EE 2.7.1 and Assets 2.1.4. I tried using the config['assets_use_uncompressed_js'] = TRUE; flag and still got the same error. Safari console says "SyntaxError: Expected token ')' on assets.js:5725". I downloaded a fresh copy of Assets from Devot-ee thinking my copy of the JS file was corrupted, but I get the same result even after replacing all Assets resources. Commented Oct 5, 2013 at 20:27
  • To be clear, this is happening when I go to update my indexes. Commented Oct 5, 2013 at 20:29

2 Answers 2

2

OK. I found the answer to my own problem. I was storing three years worth of Logs in my Amazon S3 folder which made an insane number of files for Assets to index, causing the memory error.

So if you turn on Logging for Amazon S3, don't keep the logs in the same bucket that you keep your... ahem... assets. Keep the logs in a separate log-only bucket that you don't hook up with Assets.

0
1

that's really odd.

You can either try re-uploading that file (because it kind of seems that it wasn't uploaded correctly), or you can try adding this line to your ExpressionEngine config: $config['assets_use_uncompressed_js'] = TRUE;

Cheers, Andris

3
  • Andris - unfortunately, neither has worked for me... reuploaded the entire folder and got the error. And then when I switched the config to use the "Uncompressed" version, I get the same error but for assets.js Commented Mar 20, 2013 at 16:10
  • Todd, can you go ahead and send us SuperAdmin and FTP details via [email protected]? That is a bit odd and I suspect it'd be faster if we login to troubleshoot. Please link to this thread when you email!
    – Lisa
    Commented Mar 20, 2013 at 17:52
  • Sent. Also have more details that I've added to the main post... Commented Mar 20, 2013 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.