I'm importing a feed (of evens) with Datagrab, and using it to list them on my site. I have the event-date connected to the entry-date, "and all was well with the world". Right, so now DST-switch is coming up, and all events that are before the switch are appearing fine, but all events after (for example one on April 6th 00:00) is now appearing as April 6th 23:00. Now this particular example isn't really a problem, but you can imagine this becoming a problem with times near 01:00AM (which would switch to the day before). Is there any way to stop this behavior?


  • Steven
  • 2
    Can you email me at [email protected] and I'll try and take a look. It would be great if you could send me an example feed and details of how your channel is set up. Mar 27, 2013 at 11:47

2 Answers 2


I believe you can turn Daylight Savings Time off, under the General Administration -> Localization preferences. If you set to 'no' no DST magic will happen. But I do believe this is a manual option, meaning when you need DST, you'll need to turn it back on.


The data in the feed is fixed so you can'r adjust it. One thought would be to try the http://devot-ee.com/add-ons/eevent-helper addon which lets you use a custom field for the event date(s), you could map the entry date to that field which should give you the "correct" time to play with.

It would mean adjusting your templates to use the addons date instead of the entry date, also new imports entry dates would be set to the time of the import.

Might be doable that way.

  • Thanks for taking the time to write that out. The thing is that the time in the feed is the right time. When importing ExpressionEngine's DST "magic" is being applied to it, changing the actual date... is there no way at all to stop this behavior?
    – Steven
    Mar 21, 2013 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.