After upgrading from Matrix 2.4.3 to 2.5.3 on EE 2.5.5, P&T Dropdowns (1.0.3) used within Matrix fields are no longer parsing in templates. They simply return nothing.

Nothing looks out of place in the CP following the upgrade and I'm not receiving any errors. I haven't touched my template code.

I've tried removing a matrix row from one of my Channel Entries, saving it empty and then re-inputing the value with no luck.

Any thoughts?


After further debugging the issue actually doesn't have anything to do with P&T Dropdown, but rather the use of a var_prefix name in a template that was identical to the Matrix field short name.

In Matrix 2.4.3 this didn't appear to be a problem (although I have now come to question why I had originally used a var_prefix as it was unnecessary). In 2.5.3 this causes the template to stop processing when it encounters the Matrix field and doesn't report any errors.

Example of what NOT to do:

{matrix var_prefix="matrix"}

I'd try upgrading to the latest version of P&T Field Pack on github (version 1.1). I tried it out and this version of P&T Dropdowns works on EE 2.5.5 for me. If that still doesn't work on your install, please post your field settings and template code.

  • Thanks for the heads up on version 1.1. My issue was actually the result of a var_prefix name identical to the matrix fields short name. Nonetheless I have update P&T Field Pack.
    – crh
    Mar 22 '13 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.