2

I've just installed assets 205 on EE 255 and am having a strange issue. the regular file manager works fine but the assets view shows blank boxes for all of the images. It has file names, sizes, and dimensions, but no other attributes and no previews. File manager and uploads work fine without Assets, and assets is uploading images but only displaying blank boxes. when I switch back to the regular file manager, the images are fine. any ideas?

7
  • I am having this issue as well. Using Assets 2.0.5 and EE 2.5.5. This was actually not an issue on the development server, but has become one on the production server. Assets creates a numbered directory in system/expressionengine/cache/assets/thumbs/ for the new file, but does not write an image to it. Sizing information about the image and its path in the file directory are both accurate and everything displays as expected on the front end. /cache/, /assets/, /thumbs/ and the numbered sub directories all have 777 permissions. No discernible issues with the server paths in the File Upload Pre
    – user1278
    Apr 3 '13 at 16:45
  • I've responded to you via email, Will. Thank you!
    – Lisa
    Apr 3 '13 at 20:00
  • What was the solution to this problem - I'm running into the exact same issue here with a fresh upgrade to EE 2.6.1 and Assets 2.1.3... May 21 '13 at 22:32
  • I have the exact same issue. All folders are set to 777 cache, assets, thumbs. Everytime when i removed the folder started indexing again, it creates the folders, but no thumbs inside. I'm running ee on my local machine. Added also the config setting to my config.php $config['assets_site_url'] = '/index.php'; but also no luck. Did anyone find a solution for this? Best Peter
    – Peter
    Aug 28 '13 at 9:02
  • Ok through another post i had the idea to switch to the newest php version and how should it be ... it works!!! At the moment i use on my development machine 5.4.10. I switched that php version to 5.2.17 because an older plugin doesn't work quite well with it, so i forgot to switch back and my problem began :-) Can anyone tell me how i can see any error message that a special plugin doesn't work because php methods aren't availabel or something else??? Thx Peter
    – Peter
    Aug 28 '13 at 20:44
1

Ah I've had this before also! Could be a difference in your ControlPanel URL in General Configuration and the URL you are actually logged in with (ie www.site.com/system/ or site.com/system). Doesnt Assets 2 use the EE native thumbnail-creation? Are you uploading in subfolders with Assets?

5
  • i removed the index.php and had to turn on force query strings on this server. I am using channel images to upload but the problem exists when uploading from assets as well. Mar 26 '13 at 16:24
  • <IfModule mod_rewrite.c> # Enable Rewrite Engine # ------------------------------ RewriteEngine On RewriteBase / # Redirect index.php Requests # ------------------------------ RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC] RewriteCond %{THE_REQUEST} !/eesys/.* RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,L] # Standard ExpressionEngine Rewrite # ------------------------------ RewriteCond $1 !\.(css|js|gif|jpe?g|png) [NC] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /index.php?/$1 [L] </IfModule> Mar 26 '13 at 16:31
  • can't figur out how to make this pretty Mar 26 '13 at 16:31
  • Assets 2 doesn't use that anymore, now, since our thumbnail size is different now. Seth, could you send CP and FTP access to support@pixelandtonic.com referencing this so I could take a look? Mar 26 '13 at 17:31
  • I just sent it. Mar 26 '13 at 19:29
1

I've just had a similar issue which, given the necessary permissions, Andris solved for me by adding an assets_site_url config variable to config.php to point at my EE web root index.php. (Thanks, Andris!)

I'm guessing this was necessary because my system is renamed and above web root (don't think it was a permissions issue).

Andris, feel free to add to this :)

Post edit: seems my issue was to do with the lack of a DirectoryIndex directive coupled with the rewrite rule for removing index.php in my .htaccess, and the consequent failure of Assets ajax. In other words, a properly configured DirectoryIndex directive negates the need for the config variable.

Hope this may help someone.

0

this sounds like your system/expressionengine/cache folder is not writable - Assets uses that folder for the thumbnails, as that gives us a chance of creating whatever sizes we need.

Let me know if that was it!

Cheers, Andris

1
  • Thats what I though too but it's all set to 777 (subfolders too) Mar 26 '13 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.