3

I got a weird one here, so I don't expect an exact answer, but more of a pointer in the right direction:

I'm working on a site and everything works as expected on my local server, but when I move it to staging server, images in a file Matrix column don't "stick" so to speak. When I create the entry, everything is normal, it actually seems to populate the DB since the entry appears on the site just fine, including the images, but when I go back and try to edit that same entry, the images are gone from the Matrix field (and not from plain old file fields). If I save the entry again, the images don't show up anymore on the site so it's not a problem of thumbnails not showing up on the publish page… Matrix seems to not be able to tell that images are in that field and they show up as empty on the publish page even though the images show up on the site.

The only difference I can think of is the server's setup. My local MAMP which works fine runs PHP 5.3.14. The server where Matrix doesn't work runs PHP 5.4.8.

The site runs on EE v2.3.1 + Matrix 2.2.2.1

As I mentioned before, any pointer in the right direction would be more than enough. I just don't even know where to start to troubleshoot… Thanks!

  • Yann: Did you ever get the solution to this? We have the exact same problem...even down to the EE and Matrix versions that you are running. Thanks, Kevin – user1564 May 28 '13 at 20:24
  • Kevin, is upgrading an option? That usually fixes this particular issue, in my experience. – Lisa May 28 '13 at 21:04
  • Kevin: Please don't use the answer box to comment or ask further questions. I've converted your post to a comment for now. – Adrian Macneil May 29 '13 at 9:42
3

It seems this problem can now be fixed by updating to the latest version of Matrix (2.5.10) per the change log found here: http://docs.pixelandtonic.com/matrix/changelog.html

Matrix 2.5.10
Released on November 4th, 2013
Fixed a PHP error that would prevent File cells from saving properly.

I havn't confirmed this yet, but it's in the change log. I'll be going down this path tomorrow, so I'll post my findings once I confirm that this does indeed fix the problem.

| improve this answer | |
  • We just ran into this issue with a client and upgrading to 2.5.10 fixed it for us. – Angie Herrera Jul 1 '14 at 19:12
  • Opps! I forgot about this post, but YES, upgrading Maxtrix to 2.5.10 did indeed fix the image problem. – Adam Culpepper Aug 21 '14 at 17:45
1

First, updating EE and Matrix is the first step

Are you seeing those entries in the exp_matrix tables? Before and after?

And lastly, do you see any JS errors in your browser dev console?

| improve this answer | |
  • I knew you'd say that about updating ;) But it's not really an option at this point… I see the images in the DB, ie. "{filedir_4}1957-Mitchell-Paints-a-Picture.jpg" but on the publish page I get an empty field with "+ Add File". No JS errors in Console… – Yann Mar 29 '13 at 21:56
  • Hi, Yann - I just spent a week troubleshooting a very similar issue with another customer: in the end, the upgrade was the fix. One thing to check - do all member groups have access to all of the file upload preferences in play? What kind of column are you using to store these images? – Lisa Mar 30 '13 at 2:58
  • Sorry for not getting back to you earlier, but as I mentioned, it was a time sensitive issue so I had to eliminate the problem instead of solving it… I used another hosting for the staging server and the problem's gone. Thanks for all your help! – Yann Apr 9 '13 at 15:44
  • Had the same problem (no images showing in the matrix field but on the site). Just confirming that the update from 2.5.4 to 2.5.5 worked for me! Thanks. – Nol Franklin Jun 14 '13 at 14:02
0

Have you doubled-checked that in the Fields for your channel that you have File selected as the fieldtype for Matrix and have set which directory it's allowed to access and which file type (image/all) are allowed to be posted?

Failing that I'd try and synchronise your image upload directories in File Manager > File Upload Preferences. Also ensure that paths and permissions are correct.

What does that yield?

| improve this answer | |
  • Thanks. But that's not the kind of issue I'm running into here. The file do upload just fine, in the right directory, and are even showing up on the site after publishing. The problem arises when I try to edit the entry… The Matrix field says it's empty, yet the DB says otherwise. A bit of a mystery. – Yann Mar 29 '13 at 22:01
0

Do all the files disappear, or just some? Do the file names contain any foreign/weird characters? Have you tried deleting and re-uploading the files to the server?

I had an issue where a single file kept disappearing from Publish page AND from the site. Every time I modified the entry I added the file, every time I saved it the file was gone. My quick troubleshoot lead me to rename and re-upload the file in question. It was a dwg file with ä and ö characters in its name. After changing those to a and o the problem went away. I never had the time to double check that those characters were really the issue, but Matrix nor Assets upgraded didn't help, renaming and re-uploading did.

| improve this answer | |
  • That's a good idea. Didn't think about checking file names, and that's something that could be linked to server's setup. Unfortunately, that not the problem. All the files a named-like-that.jpg – Yann Mar 29 '13 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.