3

I am running ExpressionEngine 2.5.2, was working on my site last night, tested everything, and all seemed to be running just fine. However, today when I try to navigate around the site, my pages are loading extremely slow. On a couple of the pages, I am receiving this error:

Fatal error: Maximum execution time of 90 seconds exceeded in /var/www/vhosts/cutandpaste.com/system167/codeigniter/system/core/Loader.php on line 846

This is what is on line 846 in Loader.php:

// Does the file exist?  No?  Bummer...
if ( ! file_exists($filepath))
{
   continue;
}

This error came up out-of-the-blue, and I have no idea where to start with fixing it.

3

There is some processing going on somewhere in your system which is taking a long time and or is pretty intensive. What addons are you using and are you doing any large image/video processing at all?

That message is just saying that the process was timed out. You can try upping your execution times in your PHP config. Trying increasing max_execution_time in your php.ini file to see if this helps.

Failing that on line 96 of system/codeigniter/system/core/codeigniter.php there is a timeout override which is set to 300 by default. You can also try increasing this.

It could be beneficial to determine what exactly is taking the time to process however so I'd probably try disabling all addons first and testing again. It will just be a case of trial and error to try and find the culprit.

| improve this answer | |
  • Hi Ian - I checked my addons and turns out the error was due to a Matrix update. I'm assuming that the update was clashing with something else that is not completely updated at this point. I reverted to an older version of Matrix, and will upgrade again once I have time to upgrade my version of EE and any other plugins that are out-of-date. – jennetcetera Apr 5 '13 at 15:53
1

Your question is impossible to answer without have direct access to your install so all I can provide are troubleshooting steps I would take.

I'd start by contacting your web host to see if they are having issues on their servers or have changed anything on the server. A change/issue on their end would explain the sudden sluggishness if nothing in the actual install changed. The error is happening because the script can't execute within the set 90 seconds. You can increase the value in your php setting but I doubt that will fix your sluggishness. The error is a result of the sluggishness, not the cause.

I'd also take a look at your PHP error logs to see if anything obvious is showing up.

Another thing to check is the speed of you EE control panel... in the footer you will see the execution time for the page... eg: Script executed in 0.4833 seconds. If the CP is speedy but the front-end is slow, you should start looking at things that affect the front-end only. If the CP is also slow, the cause is most likely not anything related to EE and your web host is the person to call.

Also check the Network tab in your browser's dev tools to see exactly what is slow? Is it the initial GET request? downloading of external JS?

What does running a tracert show? Any network issues between you and the server?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.