5

I have a live site that I used to be able to login to without any issue. I hadn't tried logging in for a month or so and when I tried to login again, it just redirects me to the homepage of the website. I'm using EE 2.2.2 with some 3rd party addons including structure and some others. I've checked their support forums and can't seem to find anything similar to the issue I am having.

Trying to figure out if its an EE issue or an add-on issue...

  • Benjamin, did one of the answers below solve your issue? if so please click the checkbox next to the answer to mark it as the correct answer. – CreateSean Dec 11 '12 at 22:08
  • Did any of the answers help you? If yes, please mark the answer correct by clicking on the checkmark to the left of the answer. – Anna_MediaGirl Dec 22 '12 at 6:25
5

My first suggestion is to clear browser Cookies and Cache.

The second step is to add the following into your config.php file:

$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "";
$config['admin_session_type'] = "s";
$config['user_session_type'] = "c";
$config['require_ip_for_login'] = "n";
$config['require_ip_for_posting'] = "n"; 
$config['secure_forms'] = "n";  
| improve this answer | |
4

If you have your cookie domain set to something other than the actual domain of the site in your config then this can happen, and some security settings can also cause this too.

You could try adding the following lines to config.php file in order to get into the control panel and then debug further from there:

$config['require_ip_for_login'] = 'n';
$config['require_ip_for_posting'] = 'n'; 

Here is a link to a post on the ExpressionEngine forums where I had a similar issue previously...

| improve this answer | |
  • As @Bob mentions, it could have something to do with the cookie-domain. Could you see what cookies are set when you try to login, if they are set with the correct domain and session-key you could check the db-sessions(if you use them). I have also had problems when redirects in my htaccess has cleared out POST-data on submit. – Kim Wickell Dec 2 '12 at 1:09
2

Sometimes its as easy as clearing your browser cache or trying on another browser to see what happens. Also, try clearing your cookies for the domain. Has anything changed in the environment recently?

| improve this answer | |
1

Also you're a few versions behind the most recent build. It certainly wouldn't hurt to upgrade.

But clearing your cache and trying another browser is also a great idea. I'd try that first.

Refreshing your files with an update is one way of making sure there is no file corruption.

| improve this answer | |
1

I have run into this several times, doing all three of these usually clears up the issue:

  1. Clear cache
  2. Clear all cookies
  3. Close all browser windows and re-open

If this does not solve the issue then you probably have a bad redirect in your .htaccess file, and/or a bad path set in your config.php file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.