0

These instructions don't seem to be working ...

Copy system/expressionengine/utilities/offline.html to your web root folder (the same place you have your main index.php file).

Rename offline.html to index.html. Now your visitors will see the “offline” page while you update your site.

In your ExpressionEngine Control Panel, go to Tools ‣ Data ‣ Clear Caching. Select All Caches and click Submit.

I add the index.html file as it says here but my sites home page remains?

0

Super Admins by default can see the site when the site is offline (hence why you are seeing the homepage and the site) can you confirm in another browser (or something like incognito)'?

If that does not in fact fix the issue you will need to add

DirectoryIndex index.html index.php

To you htaccess to give priority to index.html over index.php

| improve this answer | |
  • thanks that seems to have worked in other browsers although my default browser is still showing the site even when signed out of the CP ... The only thing I can think is that it is some kind of of browser cache issue specific to that browser. I have started my update now so can't really do any more tests but next site update I will test this further to find the issue. – MarkerMaker Apr 6 '13 at 15:10
  • When you have the system off you would need to clear your cache and cookies in the browser to make sure that you main browser has a fresh start. Also remember to remove index.html from the DirectoryIndex in your htaccess if you added it – Justin Long Apr 6 '13 at 20:28
1

Rename your index.php file to something else - your web server likely is prioritizing index.php over index.html.

| improve this answer | |
  • Mmm ... still having the same issue. Not sure what could happening here. – MarkerMaker Apr 5 '13 at 18:46
0

Have you cleared your browser caches too? It's different for each browser but on Chrome for instance go to Preferences > Settings > Show advanced content > Privacy > Clear Browsing Data > and Empty the cache. It's probably the cached copy of your site you're seeing.

Also be sure that index.html is in the same directory level as index.php in your public site root.

| improve this answer | |
  • Yes I have now cleared the Cache but no change. Yes in correct directory ... MMMmmmmm? – MarkerMaker Apr 5 '13 at 18:15
  • What server are you running? Apache? If so what do you have in your .htaccess file? As an alternate suggestion you could always turn your system offline in Admin > General Configuration ? Is system online (No). It is a bit better to actually put up an offline page however. – Ian Apr 5 '13 at 18:54
  • Yes Apache and the contents of my .htaccess is: RewriteEngine On RewriteCond $1 !\.(gif|jpe?g|png)$ [NC] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /index.php/$1 [L] – MarkerMaker Apr 5 '13 at 18:57
  • Nothing strange there. Try adding DirectoryIndex index.html to your htaccess file. – Ian Apr 5 '13 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.