1

I'm trying to publish a new entry into an existing channel. This channel has one other entry. When I hit the Submit button on the new entry, I'm not seeing any error messages.

This same site has a dev instance, with its own database. I'm able to publish the entry on the dev site, but not on production. EDIT: I can add and edit templates on production, but cannot add or edit any channel entries. So possibly it's some channel setting???

How can I start troubleshooting this?

  • Running ExpressionEngine 2.5.3, running on AWS
  • Logged in as a super admin
  • When I try to create or edit an entry, I just get taken right back to the entry form when I hit Submit
  • Have tried turning on template debugging, but no change/no error messages generated
  • Are you logged in as Super Admin or a member in some other member group? In your main index.php page in site root also change $debug = 0; to $debug = 1;. – Ian Apr 5 '13 at 17:43
  • What happens when you hit submit? You say you're not seeing any error messages, but what are you seeing? – Derek Hogue Apr 5 '13 at 18:41
  • I've edited my question to include this info: I'm logged in as a Super Admin. When I hit Submit, I get taken right back to the entry edit form. (The site is otherwise displaying just fine.) – user800 Apr 5 '13 at 18:52
  • Be sure to check all of the publish form tabs for errors, sometimes they are hidden. – Derek Hogue Apr 5 '13 at 18:58
  • I'd had this before and it was a required field which had not been filled in. The error was subtle but it was causing the problem. Check any fields for any error messages too. Also do you have any addons installed such as QuickSave which interact with the publish page saving mechanism? One last thing to check is if you have the Pages module installed and is this a Page entry? – Ian Apr 5 '13 at 19:34
1

Sounds like you have a required field that isn't getting filled out on one of your publish tabs. Unfortunately, EE does a terrible job of indicating this error.

I suggest installing the EP Mega Error addon so you will always see such errors. Once installed, you will see a very obvious error like this:

enter image description here

| improve this answer | |
  • Nope - that wasn't it. I went and made all channel fields NOT required, just in case. I even looked for the little error bar. (Thanks for telling me about EP Mega Error, though, I can think of other instances where something like this will be helpful. EE 2.x's CP has a few areas where usability is less than optimal, and error indication is one...) – user800 Apr 5 '13 at 20:07
  • Okay, next thing I'd suggest is to temporarily disable extensions by adding $config['allow_extensions'] = 'n'; to your config.php file. An extension could be causing a conflict. – Anna_MediaGirl Apr 5 '13 at 20:15
  • Also, check the console in your browser... do you see any JS errors? If so, it's possible some JS for EE or an addon is missing, out of date or corrupted. Reuploading the file should do the trick. – Anna_MediaGirl Apr 5 '13 at 20:16
1

Believe it or not, simply refreshing the page first, then republishing may solve your issue. I have run into this a few times myself, and this has worked... I know it sounds rudimentary but try it.

| improve this answer | |
  • Unfortunately I've tried that! I even tried loading it in each of the browsers I have installed on my laptop, just to make sure it wasn't some weird browser-specific issue that would have started happening since Monday. – user800 Apr 5 '13 at 20:18
1

So I figured it out. It's very weird.

This morning, I had opened the Admin>General Configuration settings screen, and set the site's root directory URL to be simply "/" so that people could view the site, or more specifically a certain set of templates, through either http or https. I've done this on other installs, even other installs for this particular client, and not had any problems.

Once I re-set the site's URL to the actual domain, instead of the more global "/", I could edit existing and publish new entries again.

Weird. Weird, weird, weird.

| improve this answer | |
0

Long shot here, but you're not seeing the published entry on the dev site, are you? Could it be using the dev database?

| improve this answer | |
  • Nope, the entry is not showing up on either the dev nor the production database. (And nope, the dev and prod sites each use their own separate databases.) – user800 Apr 5 '13 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy