5

When I upgraded to Assets 2, I noticed that when uploading a file from the modal window in a channel entry form that once the file is uploaded, Assets doesn't automatically select it for me anymore. I have to do a search for the filename. Is that the normal behavior for Assets 2? Or am I the only one experiencing this? And, if it's just me, is there any way to solve it.

Here is a step-by-step list of the process:

  1. Open either a new or existing channel entry form
  2. In the Assets field, click Add file
  3. In the Assets modal window, click Upload files
  4. Locate file to upload from file system, then click OK
  5. The file uploads
  6. this is what's not happening: Assets automatically selects the just-uploaded file(s)
  7. Double-click on the newly-uploaded file to add it to the Assets field

screenshot of what Assets isn't doing

Here's a new/interesting discovery: step 6 above does happen when I use a computer that is not on my organization's official network. I'm wondering if it's blocking a Javascript or something like that??

Currently running Assets 2.1, was running Assets 2.0.5, on EE 2.5.2 issue happens in both versions for me.


April 11, 2013

Screenshot of Javascript console errors screen shot of javascript console errors

The Uncaught TypeError: Object... happened on page load, the Double-instantiating a select... happened (and I'm not really sure if it's an error or just logging) when Assets completes the file upload and selects the document.

Thanks! - B

  • Hi, Brett - can you add to your original post the step by step clicks you're taking, and what the expected outcome is? For instance, I went to a new channel entry and clicked "Add Files". I chose some files and double clicked, and it added them to that custom field. You're right that they weren't selected there. You expect them to be highlighted at that point? I may not be following quite what you are expecting to happen, so more details would help me to help you. Thank you! – Lisa Apr 10 '13 at 17:06
  • Hi Lisa! Thanks for your quick reply. I've added the steps and a screen shot, plus an interesting tidbit I discovered. I'm not sure if you're notified once the original post is modified, so I thought I'd leave a comment, too. – Brett Apr 10 '13 at 19:55
  • Brett, that illustrates where I went wrong in trying to reproduce. blushes Thank you! Hrm; are you familiar with your browser's dev console? If you check that when doing this in your office, do you see any JS errors? Also, have you tried a different browser in your office? – Lisa Apr 10 '13 at 23:09
  • Hi Lisa! I did copy the two lines that appeared in Google Chrome's dev console. They are: Uncaught TypeError: Object [object Object] has no method 'tablesorter' compressed.js:39 Double-instantiating a select on an element garnish-0.1.min.js:18 – Brett Apr 11 '13 at 18:20
  • Also, we're limited to Chrome (most current version) and IE7 (hideous). I was using Chrome. – Brett Apr 11 '13 at 18:21
2

We were seeing this same issue running Assets in our EE 2.5.2 environment. After we updated to Assets 2.2.2 it began working as expected.

| improve this answer | |
0

I am having this same issue and have talked to P&T support about it. We isolated it down to a scenario in which the upload directory has a large number of images and the uploaded file falls somewhere below (out of range of) the images that are already displayed / loaded in the modal.

For example, if I upload an image with a name that starts with 0 or A, the image is highlighted as you would expect and the add button is available because it falls in the range of the displayed files. Conversely, if the file name starts with Z or some letter / number that is not already displayed in the modal then the image is not selected and the add button is not available so you have to manually search for the file or click on "Recently Uploaded."

This may not be the case for you but I thought I'd share it for anyone else that may be experiencing this issue.

Update: I have found that if I use List View in Assets, and then sort by newest first, the problem is solved. To help with this, I set List View as the default in the Channel Field settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.