1

Another perplexing "is probably an easy fix" question:

I have an EE site, and am using Safecracker to maintain a customer data channel. Each week, the customer receives a notice about an upcoming grocery delivery. When they do, they have the opportunity to submit a note about it – for example, "I don't want beets."

I have a another textarea field that collects all of these notes.

I was using a hidden Safecracker field to populate the textarea:

<input type="hidden" name="customer_bin_notes" id="customer_bin_notes" value="{customer_bin_notes}\n{customer_bin_recent_note}">

I can't get the line break to work. I also tried
and \l but those didn't work either.

I'm sure I'm overlooking something simple here.

Suggestions?

0
1

Have you tried <br /> instead of \n?

2
  • Yes, I've tried <p></p> as well.
    – Ty Morton
    Apr 12 '13 at 11:48
  • If you're placing it in an input field then I'd imagine everything will be stripped because of the type of data field it is. In the database it expecting a VARCHAR (a string) of a capped limit and EE will no doubt be parsing all input for security reasons. You'd have more flexibility submitting as a textarea rather than an input field.
    – Ian
    Apr 12 '13 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.