1

Anyone ever got images on an EE site working on a Windows server that uses UNC paths, e.g. //server/folder/?

I'm using imgSizer to resize images but am getting errors like:

imgsizer.Error: /wwwroot/uploads/img/image.jpg image is not readable or does not exist

Support for the server says that it seems that EE is trying to serve images from a path with a single / at the front instead of the //

1

Can you force C:\path\to/webroot/folder instead? I have that in use on a Win server with EE. You might also change from Imgsizer to CE Image - when I did that I was able to remove the base_path type parameters from my plugin calls.

0

The imgSizer plugin uses remove_double_slashes() function of Functions library to remove the double slashes to a single slash. So it will not work either with "base_path" or "src" parameters of imgSizer.

You can try "ED Imageresizer" by having "ed_server_path" config variable like:

$config['ed_server_path'] = '//server/folder/';

It would work.

1
  • Tried ED Imageresizer and it's not working either. :( – Tyssen Apr 18 '13 at 7:01
0

Following on from Chad Crowell's answer: I would say that the easiest way to fix this -- assuming you're connecting to a single UNC server -- would be to map the UNC path to a drive letter. This is really easy, in Windows -- just open an Explorer window and go to Tools -> Map Network Drive. Enter \server\images in the obvious box, and pick a drive letter in the other obvious box. If the server uses different credentials than the Windows login, then check the "Use different credentials" box. Then click "OK". (If you've checked 'use different credentials', it will prompt you for those after you've clicked OK; there will be an option to save them.

Then you can reference the paths from Imagesizer as, say, Q:\media (maps to \server\images\media) or Q:\stuff (maps to \server\images\stuff).

Failing that, use CE Image. :)

1
  • I don't have any control over this server so can't make any of those config changes (and apparently they've got some sort of NAS set-up in play). I've just tried CE Image but am getting the same sort of error relating to the image not existing or not being readable. – Tyssen Apr 18 '13 at 6:41
0

For:

/wwwroot/uploads/img/image.jpg

try:

\wwwroot/uploads/img/image.jpg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.