0

Assets isn't resizing my too-large files as it should per the Upload Destination's maximum dimensions (reference here). I have this for an upload destination:

Upload Destination: General Images
Maximum Image Width (in pixels): 1600
Maximum Image Height (in pixels): 1600

Yet I am able to upload an image with the dimensions 3264 x 2448 and it does not resize it. This used to work just fine, and I've left it alone for a while, so it was a surprise that it's now not working.

(Incidentally, the reason I noticed it is because it caused a CE Image error. But that's a topic for another post.)

Anyone have any ideas?

Update: I am using ExpressionEngine 2.5.3, Assets 2.1, and CE Image 2.4.3. Local image storage (not S3). Also, my intention with the image resizing on upload was only to shrink files that are way too large to a manageable size (1600 px max in either dimension). Then the actual page-by-page image sizing would be handled by CE Image.

Update 2: I made a standalone phpinfo file and checked it. GD Support is "enabled", and GD Version is "bundled (2.0.34 compatible)".

  • You mentioned CE Image but which one are you using to do the resize on upload? Assets, CE Image or native EE? – Ian Apr 22 '13 at 21:50
  • Also, what version of EE and Assets? And is this a local source, or S3? – Lisa Apr 22 '13 at 21:51
  • One final thing to check would be that you have the GD lib installed. If you go to Tools > Utilities > PHP Info and search for 'GD Version' what does it tell you? More questions than you bargained for. :) – Ian Apr 22 '13 at 21:53
  • I am using the latest versions of EE and Assets, and the images are local source (not S3). I thought I was using native EE functionality for the resize on upload. That was my intention, at least. Is there a way to do it with Assets? I will have to check on the GD lib. – Amy Witty Apr 23 '13 at 1:25
  • Yes, that is possible. Can you let me know the version numbers, and also, if you can email a copy of the problem image to support@pixelandtonic.com - and refernece this thread - then I can reproduce. Also, those are limits - if you want resizing, have you considered setting up some image transforms? – Lisa Apr 23 '13 at 1:33
0

Apparently this was a bug in Assets which has been fixed as of Assets 2.1.2 (see changelog here).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.