Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively.

I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {assets_86:{filedir_2}faculty-staff-stats.png}

When it gets rendered, it looks like this: http://mysite.dev/uploads/assorted/faculty-staff-stats.pngfaculty-staff-stats.png}.

Same code worked perfectly prior to upgrading.

  • 3
    Traced this back to Wygwam_helper::replace_asset_tags(). A slight change to the regex at the top of the method fixed things for me: Change this: preg_match_all("/\\{assets_(\\d*):((.*)(\\}))/uU", $data, $matches); To this: preg_match_all("/\\{assets_(\\d*):((.*?)(\\}))/uU", $data, $matches); Commented Apr 23, 2013 at 22:13
  • Thanks Rob! I'll go ahead and post this as a bug for us to look at.
    – Lisa
    Commented Apr 23, 2013 at 23:00
  • Was this ever fixed? I am still getting this error with Wygwam 2.7.1 and Assets 2.1.3. I have found that on first publish after adding an image I get the error with the URL like described above. But, once I save again (without changing anything), the URLs are fine.
    – James
    Commented May 27, 2013 at 18:13
  • Unfortunately this is not yet fixed; does the above change get this working for you in the meantime?
    – Lisa
    Commented May 27, 2013 at 18:46
  • I hadn't tried it yet... I didn't want to hack the module if there was a more official fix.
    – James
    Commented May 27, 2013 at 18:49

1 Answer 1


If you are on EE 2.6, 2.6.1, or 2.6.2 and using Assets 2.1.1, you should update to the latest versions of both. If you're stubborn, Rob's fix above will work for you.

If you even more stubborn and on EE 2.5.5 or below, then stop being stubborn and update. Said with kindness in my heart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.