I'm trying to duplicate a site onto a different server and am running into the old "Site Error: Unable to Load Site Preferences; No Preferences Found" error. Through searchign the forums some fixes I've tried are to re-export / import the database, re-uploaded all the files to the server and no dice. I've got 777 permissions on my config.php and database.php. I have also checked with simple PHP script to see if I am able to successfully connect to my DB with my settings and that worked fine.

I did find that the code causing the error (in /core/EE_Config.php):

if ($query->num_rows() == 0)
    if ($site_name == '' && $site_id != 1)
        $this->site_prefs('', 1);

    show_error("Site Error:  Unable to Load Site Preferences; No Preferences Found", 503);

Can someone out there help to explain what this means and perhaps a potential solution?

  • Which version of EE is this and is it a standalone installation or running Multi-Site Manager (MSM)?
    – Ian Young
    Commented Apr 24, 2013 at 17:45

2 Answers 2


This error may caused if EE couldn't make database connection. Check your hostname, username, password within "/system/expressionengine/config/database.php".

Also could you check "exp_sites" database table if its having at least one record (multiple records for MSM site) if not, import this table properly.


I've run into this error many times and it always ends up being an issue connecting the to database. These are the things I check:

  1. If you're trying to connect to a remote DB from a local instance of EE, make sure that the MySQL port is open on your DB server. By default the port is 3306. If you're not sure how verify if the port is open, see if your host will do it for you. I use Rackspace for hosting and they're very helpful with things like this.
  2. EE provides you with a DB testing utility which can be found in system > expressionengine > utilities > dbtest.php. Copy that file to your webroot, modify lines 4-7 with the credentials from your database.php file, and hit the page. You'll get feedback on failure or success with your connection.
  3. Verify that your config.php and database.php files have 666 permissions. I do not recommend that you set these to 777 as you stated above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.