1

I upgraded one of my EE sites tonight to EE 2.6 and also went to upgrade to the new Field Pack v2.0 but I am receiving a series of errors like so:

A PHP Error was encountered Severity: Notice Message: Use of undefined constant PT_FIELD_PACK_VER - assumed 'PT_FIELD_PACK_VER' Filename: api/Api_channel_fields.php Line Number: 117

I receive one for each of the fields. Any thoughts?

Thanks, John

  • Hey John - I'm sorry you have run into this. Can you let me know what steps you took to upgrade to the new Field Pack? Also, is Super Admim and FTP info available? If so, please email them to support@pixelandtonic.com and we'll have a look. Thanks! – Lisa Apr 25 '13 at 2:44
2

I ran into this problem as well - To solve it I:

  • Installed each of the new "Field Pack" plugins (which uninstalls the old versions automatically).

  • Once they were all uninstalled the problem resolved itself.

  • To keep the third party folder nice and tidy I then deleted the old PT_ files from the plugin directory (but you want the new pt_field_pack folder still!).

Hope that helps,

Tom

| improve this answer | |
0

John,

Did you remove the old field pack and any dive bar files you had in the filesystem? I think those remaining there may be the cause of this error. Of course please make backups first!

Let me know if that fixes this up for you, please. Thank you!

-Lisa, P&T

| improve this answer | |
  • Thanks, Lisa. That was the problem. I was hesitant to remove them while receiving the errors, since I need those fields, but removing the old versions did work. – John C. Derrick Apr 26 '13 at 12:15
  • Thanks John! I've sent this to our devs to see if we can make it cleaner yet. :) – Lisa Apr 26 '13 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.