I'm working a multilingual site in EE and I am optimizing the URL's for SEO reasons in multi languages as well. The purpose is that people can visit the URL

http://www.domain.com/nl/contact/medewerkers and also http://www.domain.com/fr/contact/personnel

both pointing to the same templategroup 'medewerkers' (medewerkers is staff in English fyi)

Just to be complete: the switch of the language is triggered by the first segment in the URL and works fine

The idea was to have some entries in the .htaccess in the /fr subdir of the site to make the 'translation' of the URL to right template group.

So in this /fr/.htaccess I've specified

    RewriteRule ^contact/personnel$ contact/medewerkers

However for some reason this does not seem to work properly

1 Answer 1


It might be that this problem is bound to my server environment (although I was able to reproduce this locally with MAMP), but this is how I've got it solved after many hours of swearing.

In the /system/expressionengine/config/config.php file there is a setting the specify how EE should deal with URI's. In a standard EE setup this is specified as

$config['uri_protocol'] = 'AUTO';

Changing this to

$config['uri_protocol'] = 'PATH_INFO';

solved my problems and it might solve yours!

regards, Tim

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.