2

I have a problem with displaying all markers on a map. My channel has 129 entries for dealers that need to be shown on a map. For some reason only 95 are displayed via a marker on the map. The template setup is relatively easy

{exp:channel:entries channel="dealers" dynamic="no" disable="categories|member_data|pagination" limit="999"}

// all sorts of data about the dealer like name, phone, etc in a list

// the markers
{exp:gmap:marker 
        id="map" 
        infobox="true" 
        extend_bounds="false"
        icon="/themes/third_party/gmap/icons/pin-location.png" 
        latitude="{dealers_latitude}" 
        longitude="{dealers_longitude}" 
        zoom="8" 
        clustering="true" 
        show_one_window="true" 
        limit="1"
        style="width: '350px'"
        offsetY="-45" // Offset the X position of the window
        offsetX="15" // Offset the Y position of the window
        closeBoxMargin="5px" // Sets the box margin (could also be done in stylesheet)
        class="ui-infobox-dark" // Uses the dark theme made available by Google Maps for ExpressionEngine v3
        closeBoxURL="/themes/third_party/gmap/css/images/white-close-button.png" //Uses an alternative close button
        open_windows="false"
        //geocode="true"
        }


{/exp:gmap:marker}
{/exp:channel:entries} 

It appears that -as expected- the javascript is not generated for the entries that not shown. It is not random, so the problem is consistent. But I really cannot see why those entries would be different than any others..

I’m running EE 2.5.5 and Google Maps 3.2.3

rg, Tim

1

Got response from the developer. Thought I post it here too for others to use it. Setting

geocode="false"

does the trick

| improve this answer | |
  • Thanks. This by far the most frequent support request. If I could do it over again, I would make geocode="false" the default, but if I did that now, people would have some real issues when they upgrade for 3.x. – Justin Kimbrell Apr 29 '13 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.