Our Wygwam editor suddenly stopped working today at a particular time. It had been used all day up to that point without any problems. Our hosting company says no changes were made to server permissions.

When I load the control panel editor page the web page loading is cancelled due to this file...


When wygwam has problems it seems to be usually related to an incorrect file path or something similar. I've tried upgrading Wygwam to version 2.7 and reinstalling the DevDemon Channel Images wygwam plugin. When I set a field to NOT defer loading of Wygwam we just get a blank grey area on the Editor page.

This is happening in all web browsers that we've tried.

  • Check your browser's JavaScript console to see if it's logging any errors?
    – Brad Bell
    Apr 30, 2013 at 0:15
  • There is a javascript error... Error: this.config is undefined Source File: https://mysite.net/themes/third_party/wygwam/scripts/wygwam.js Line: 30 My new working theory is that this may be related to a PHP memory limit being reached. We are having that issue separately. Not sure how that might effect this. What JavaScript library does Exp Eng itself use? I've had issues with javascript when a hosted library is updated and the code on the site is broken from that.
    – Bob Foster
    Apr 30, 2013 at 15:41
  • Have to tried increasing your PHP memory limit to verify?
    – Brad Bell
    Apr 30, 2013 at 17:16
  • Our hosting company has a strict limit of 64MB that can't be changed. I've solved the issue with the memory limit being reached which was due to an Importer module log table being full. But unfortunately solving that hasn't solved this Wygwam issue.
    – Bob Foster
    Apr 30, 2013 at 21:24
  • @Brad-Bell Duh, sorry I didn't realize you're on the team at Pixel and Tonic. I sent an email in through the P and T support page.
    – Bob Foster
    Apr 30, 2013 at 22:21

1 Answer 1


This turned out to be a stray line return character that was somehow added to a Title field in Exp Eng. The line return was breaking the Wygwam javascript that sets up the editor items. Editing the title of the offending channel entry to remove the line return solved the problem.

The way I finally noticed it? In firefox I copied the line in the web page where the error occurred and pasted that into a text editor. Since everything should have been on a single line of code the second line showed up where the offending title was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.