0

Good Morning Everyone,

im sorry if this is duplicating my post on Ellislab forum, but I though id attack from all angles.

Im new to EE and Cartthrob, however I have an issue after each attempt at installing Cartthrob.

EE installs ok, however during the installation of templates and template store from the cartthrob I get an Internal Server Error, after a refrsh everything seems ok, however when i active the test store most of the pages produce the following error

Error Unable to load requested field type file: ft.rel.php. Confirm the fieldtype file is located in the expressionengine/third_party/ directory

I spoke to CT, but they say this error relates to EE not CT.

Any advise would be greatly appreciated

  • Which version of EE and CT are you using? – Ian May 1 '13 at 8:20
  • Sorry that should have been in the question. Im on EE 2.6.0 and CT 2.2.9 – springboynick May 1 '13 at 8:38
  • I think, your EE setup still using old relationship field type (EE's lower version than 2.6) which may causing this issue. Is your EE installation is fresh installation for v2.6 – Bhashkar Yadav May 1 '13 at 8:51
  • Im installing as a full fresh install of v2.6.0. I did wonder if something was wrong with the version as I could not find 'ft.rel.php' in the sites files anywhere, but I did find 'ft.relationship.php', is this the same file under a diffrent name? – springboynick May 1 '13 at 8:54
  • CartThrob has not been updated since the release of 2.6 (as is the case with many add-ons). I suspect it's assuming that it will find the old relationship fieldtype (which was called ft.rel.php) somewhere in its code. – Derek Hogue May 1 '13 at 13:06
1

I am having the same problem.... I even rolled back the version of EE to 2.5.5 and removed the CT pluggin and also turned off extension. Still getting the error. Something has changed in my database. I am in the middle of trying a full server restoration and putting a bullet in my head.

| improve this answer | |
1

To summarise...

CartThrob has not been updated since the release of 2.6 (as is the case with many add-ons). I suspect it's assuming that it will find the old relationship fieldtype (which was called ft.rel.php) somewhere in its code.

Until the CT guys update the CT auto-install templates to work with EE 2.6 your options will be to either work without the auto-install templates or stick with EE 2.5.5. Prior to that EE 2.5.5 would have been the download in your account. Your best bet will be to drop EllisLab an email (sales@ellislab.com) and just explain why you need the previous version. I'm sure they'll help you out.

| improve this answer | |
1

Had the problem as well after updating an old website. Here is how I solved it.

  1. As mentioned in the comments ft.rel.php is the old relationship field. It was causing problems even though I wasn't using it because it was listed in the database.
  2. Check that you are not using it in any of your fields by going to the exp_channel_field table and checking the field_type column. You should see no sign of a rel field there.
  3. If that's the case, simply delete the row for rel field in exp_fieldtypes

That solved the problem for me.

| improve this answer | |
0

I had the same problem only it was "ft.matrix_url_title.php"

I am on 2.6.1 and Matrix 2.5.5

The weird thing was that it was ok on my local machine but not on my dev server.

Turns out that the db table exp_fieldtypes on the dev server had the field type name ("name" in the db column) as "matrix_url_title" whereas the local db had "matrix". Once I changed the dev server db to matrix it worked. So there was obviously a conflict when upgrading either to 2.6.1 (from 2.4.0) or to Matrix 2.5.5.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.