1

I have a problem with my checkout process.

I've read the docs and looked at 2 or 3 similar posts, but none of them had the same problems as I do.

I use Zoo Visitor, I have set up the fields in store's settings, the user account is created, the emails get sent with the right data, the order is correctly tied to the user account. it's just the membership fields that are not saved!

I can register without a problem via the {exp:zoo_visitor:registration_form}

when logged in, everything is working as expected.

in my checkout I have the following code:

    {if logged_out}
        <h2>Mitglied werden?</h2>

        {field:register_member} <label for="register_member">Als Mitglied registrieren?</label>

        <div class="toggle">
            <p>Sie müssen einzig ein Passwort angeben und schon sind sie Mitglied mit eigenem Login</p>

            <div class="control-group {if error:password}error{/if}">
                <label class="control-label" for="password">Passwort<em class="required">*</em>:</label>
                <div class="controls">
                    <input id="password" class="control-input required" type="password" size="30" maxlength="256" value="" name="password"> 
                    {error:password}
                </div>
            </div>
            <div class="control-group {if error:password_confirm}error{/if}">
                <label class="control-label" for="password_confirm">Passwort bestätigen<em class="required">*</em>:</label>
                <div class="controls">
                    <input id="password_confirm" class="control-input required" type="password" size="30" maxlength="256" value="" name="password_confirm"> 
                    {error:password_confirm}
                </div>
            </div>
        </div><!-- end .toggle -->
    {/if}

I even tried with or without the register_member parameter. and the behaviour didn't change.

this thread is very close to my problem, and although it sais that it has been fixed, it hasn't fixed my problem: Membership Fields Failing to Map During Checkout / Account Creation in Expresso-Store

maybe it's because I have named my zoo visitor fields the same as the store member fields?

I am on EE 2.5.5
store 1.6.4
zoo-visitor 1.3.25

EDIT: I HAVE CHECKED IT ONCE AGAIN: WHAT HAPPENS IS THAT IT CREATES THE MEMBER, BUT ONLY A STANARD MEMBER – NOTHING IS SAVED TO THE ZOO MEMBERS CHANNEL!

please help - it's rather urgent!
stefan

  • Did you ever find a solution for this? – Adrian Macneil Nov 1 '13 at 11:28
  • the solution was to use a different workflow... a typical 3 choices checkout workflow: login, continue without login or register... finally it was easier to grasp for customer and more standard that what I was trying to achieve. nevertheless I've never rechecked if the bug was gone... – outline4 Nov 5 '13 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.