Questions tagged [404]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
2answers
120 views

EE 5.2: Parse error: unexpected '/' in … ee/legacy/libraries/Functions.php(627) : eval()'d code on line 27

I just have been noticed by Google Search Console that there are two pages with Soft 404 errors. So I cannot be sure when the error appeared first. When calling the URL I get a blank page with the ...
0
votes
1answer
37 views

Template Routing, display both a specific channel entries and a couple of index pages on the root URL '/"

Using Expressionengine 3.5.11 I need to display the entries from a specific channel, thus '/entry-url', this is obviously not difficult, however I also need to display an index page for a couple of ...
1
vote
1answer
57 views

Template Routing with extra segments, how to catch 404's?

I'm using the extra segment approach to direct requests to pages, as described here: Template Routes and extra segments This is working great and allows me to create a common wrapper for pages, but ...
1
vote
1answer
71 views

Specific word choice in URL title is causing a 404 error on a page. Can anyone help?

I'm working in EE3 and have just come up against a problem that I've never experienced before and I'm really hoping someone can help. I have created a page with the URL /destination-reports. When I ...
1
vote
0answers
56 views

Is EE able to handle this db/site ok?

It's quite a "general" question. Our site has 60k posts. Each post has 10-15 relations and almost 50 custom fields and several categories options. Mostly focused in one channel. One category group ...
0
votes
1answer
43 views

404 page going to listing entry template only in first segment

I can only trigger the 404 template for anything more than two segments, for example, if this is bad link I see 404 page: site.com/wrong/link When just accessing one segment like this for example, ...
0
votes
1answer
225 views

Site suddenly displays “Site Not Found”

We have a client website which we inherited from another agency. It came with EE 2.10.1. We are normally a Craft agency, so we aren't unfamiliar with the way EE works. Last night, I got a message ...
0
votes
2answers
50 views

404 Redirect when there are too many segments

Having some issues forcing a 404 redirect when there are too many segments. Here is the page I am working on http://syntropy.highimpact.com/case-studies/aurora-flight-sciences/ I'm using the ...
2
votes
1answer
32 views

404 pages not working for Blog channel - but do for everything else

I have just taken on an Expression Engine site (my first time with EE) and I am experiencing a strange issue. We have a custom 404 error page which is working across the site except for on the blog. ...
0
votes
1answer
75 views

Getting 404 error when trying to access Content > Edit in v2.10.3

I'm getting a 404 error when trying to go to Content > Edit via the admin, as well as Content > Edit > My Channel. EE v2.10.3 Installed Extensions: The error: 404 Page Not Found The page ...
0
votes
1answer
51 views

404 Not Found error when deleting an entry

I've built several sites with EE but I've never had this error. In my last project, if I try to delete an entry (no matter from which channel) I receive a Not Found Page. Not Found The ...
0
votes
1answer
54 views

Why is keeping URLs clean so messy?

I am using EE2.9.2 with Stash and CE Cache. While trying to create a clean URL structure, ie. raising the appropriate 404s where necessary, I ran into challenges I'm struggling to solve. I have a ...
0
votes
2answers
76 views

Entries can't be updated - 404

I'm having a problem with EE; when updating or creating an entry I get redirected to the 404 page. I've researched a lot because this is getting annoying. I've tried checking the .htaccess as a common ...
0
votes
0answers
37 views

Submit goes to 404

I have an inconsistent problem with an installation that serves the 404 page sometimes after the submit button is pressed. This happens on anything including entries to administrative actions. Does ...
0
votes
1answer
36 views

Removing index.php gives *no* 404 errors for wrong template groups

I have the opposite problem to many: When I use the official method to remove index.php and then enter an invalid url/template group, e.g. http://www.example.com/blahblah I do not get a 404 error, ...
1
vote
0answers
56 views

404 not rendering correctly when using template layouts

I'm finding in EE 2.10.1 that if I try to check for the presence of a valid category in a URL using Low Seg2Cat and then perform a redirect on error that when the 404 template is rendered it inherits ...
0
votes
1answer
126 views

404 redirect on structure site not working

...or only "partially" working. My issue is if someone types in a non-existant url using an existing template group like this: www.mysite.com/existing_template_group/cvgdghdbhbcdbcdh The results ...
3
votes
2answers
482 views

Querystrings on 'home' url go to 404 page

I've got a problem with an old site (running EE2.4) which is issuing a 404 if the URL contains a querystring. This is happening on the homepage only. i.e. http://www.example.com/?foo=bar causes a ...
0
votes
2answers
79 views

404 redirect not working, sending to another segment

I'm having problems with a template sending a missing page to another segment rather than the 404 page. For example, The URL below would give us our Disney Ship. WEBSITE/cruises/disney/ships/...
0
votes
1answer
137 views

Remove index.php - interior pages are blank

I've got a site that works correctly on localhost and the staging domain, but after moving to the live server all interior pages return a 404 page. .htaccess has the following <IfModule ...
2
votes
2answers
52 views

Using Pages module, how can I still get 404 pages?

I have a template set up that I point various Channel Entries to via a pages URL. For example, I might have a channel on my site that contains all the various pages for a department, and all those ...
0
votes
2answers
571 views

404 not working; bad URLs show only blank page

My website is displaying a blank page when incorrect/absent URLs are used. But I would like it to show a 404 page such as this template I've created. I have tried to set my global template ...
0
votes
0answers
72 views

Adding “require_entry” gives no results

I have the following simple EE query: {exp:channel:entries channel="australia" url_title="{segment_2}" limit="1" dynamic="no" disable="categories|category_fields|member_data|...
0
votes
1answer
46 views

Local copy of working site > admin work > pages all get 404

We're taking over hosting a clients site, and I've downloaded a copy of the site and the database, and set up both in mamp. I've adjusted the db config, and the '/admin/' area all works - however, if ...
0
votes
1answer
244 views

404 not working - must not have strict URLs

I have set the 404 page on Templates > Global Template Preferences, but it is having no effect. I do not want to turn on 'Enable Strict URLs' as it cause several problems on some pages. And anyway, I ...
0
votes
2answers
468 views

404 error when editing or posting a new article

I'm having an issue with a 404 error that appears after creating a new article entry, or editing a template. I recently upgraded my website to the latest version of ExpressionEngine, following the ...
0
votes
1answer
772 views

URL Redirecting Issues

We are running expression engine v2.7.2 and the issue we seem to be having is that URLs are redirecting to the segment 2. ex. 1 http://www.website.com/pagedoesntexist - displays 404 error ex. 2 ...
0
votes
2answers
294 views

Cannot get to CP - 404 Error

Today a site I administer started getting a 404 error when trying to access the CP at www.thedomain.com/admin.php It was working fine and as far as I know there have been no changes to the system by ...
1
vote
2answers
568 views

Why doesn't {if no_results}{redirect=“404”}{/if} return a 404 header?

Under Design > Templates > Global Template Preferences I have Strict URLS set to yes and I've defined the 404 page (It lives at /errors/404). We're running EE 2.8.1 and PHP 5.3.27 Something like ...
0
votes
1answer
122 views

Invalid “segment_2” to return 404

Hi can anyone please help. I have a template group called "blog", in that template group i have the following: index.html view.html "index.html" holds all the blog items getting pulled through with ...
0
votes
0answers
428 views

random 404 errors on existing files

this may not be due to EE, but my site runs on EE so I want to ask. We are randomly getting css and js files returning a 404 error. They exist, and a refresh loads them properly but it's hardly a ...
3
votes
1answer
255 views

Unexpected results when using {redirect=404} and template layouts

It appears that when using the recommended method of {if no_results}{redirect=404}{/if} in a template that uses the template layout feature, it duplicates the layout, if a layout is also used on the ...
0
votes
1answer
62 views

Issues with EE On IIS with Directories

I moved my IIS site from a hosted server (Apache) to IIS. In doing so I Made the normal IIS install, installed PHp and mysql Copied all the files to wwwroot Added the database. Now what happens is ...
0
votes
0answers
145 views

404 Page is Appending Home Page

We have created a template called /site/404. The site is working correctly as far as pulling articles, and content properly for all of our different URLs. When we go to either a template that does ...
1
vote
3answers
458 views

After removing index.php from URLs, 404s on every template except homepage

UPDATE When first posting this, I didn't understand the problem. When I removed the index.php from the urls with a .htaccess file (http://ellislab.com/expressionengine/user-guide/urls/remove_index....
0
votes
1answer
2k views

ExpressionEngine 404 Not found - /index.php/products was not found

I have just begun working with ExpressionEngine. The production site is working just fine and I wanted to create a local version for dev purposes. I am receiving 404 not found errors on my localhost ...
0
votes
1answer
93 views

Conditionally targeting the 404 template

When I get a 404 page, the URL in the browser remains pointing to the page I was trying to reach. ie. the address bar will show domain.com/unreachable-page not domain.com/404. Which is fine and, I ...
2
votes
1answer
41 views

Non existing content redirection

my google-fu failed again, and i have a serious problem. I have a channel and template for it called html, when i go to page.com/html/(existing article name), it works just fine, but when i go to page....
0
votes
3answers
442 views

404 when accessing channel content

When I try and access channels in Expressionengin I get 404 pages... A URL like http://www.nameofsite/news/index.php tells me 'The requested URL /news/index.php was not found on this server." ...
1
vote
1answer
144 views

Template group not appearing in file system

I've created a template group called temp, and inside this template group I've create a few templates. But when I try to view the templates I get a 404 error. I've checked my files and the template....
1
vote
2answers
75 views

404 returning to site index

I just realized that when I go to website.com/faljalsdfkj, it should cause a 404 and take me to the 404 page. I have this same setup on ann older site and it seems to be working correctly, but Can't ...
2
votes
2answers
112 views

404 ErrorDocument returns home page incorrectly

We have created http://www.macobserver.com/tmo/404_not_found — That page works. I then added ErrorDocument 404 /tmo/404_not_found to our apache config. Without that line in there Apache delivers ...
1
vote
1answer
85 views

Index.php was not generated on localhost. (not a .htaccess issue)

when searching for an answer it always lead to a .htaccess issue, but that's not what this is. i'm new to EE since my companies website works on it i'm learning on the fly. to try to learn it better ...
2
votes
1answer
730 views

Template 404 Redirect

Do you know if it's possible to redirect to a specific 404 page when a template group isn't found rather than just show the 404 with the incorrect url? For example, If I go to example.com/...
2
votes
1answer
146 views

404 error when trying to list category entries

I've been trying for days to figure this thing out. I'm building a News section in the site, and under news are 3 categories: Updates, Events, Archive. When you click on one of the categories, i want ...
1
vote
1answer
62 views

Simple redirect with Redirectee doesn't work

In my Templates Global Preferences I've set the 404 page to go to pages/404.html template. In that template is a redirect to the 404 page: {exp:redirectee:redirect status="404" url="/404/"} It doesn'...
0
votes
0answers
102 views

Uploaded links 404 error. Can't edit entries under super admin

All the .doc and .pdfs (.jpg is fine) that we have uploaded to our site generate a 404 error and do not download. We have not changed anything on the back end of our site in quite some time and ...
0
votes
3answers
115 views

Check if a template group exists

Is there a way to check if a template group exists either in the templates or in a add-on? For example, I would want to do something like this {if {exp:foo:template_exists name="blog/test"} == "true"...
2
votes
1answer
229 views

Multi Site Manager gives 404 when using Sub Folder

We have setup Multisite Manager but we are not using sub-domains, we want them in sub-folders. The EE instructions do not reference this setup, only domains and sub-domains. Its not working for us, ...
1
vote
1answer
124 views

Mistyped URLs sending me to blank pages

My original EE setup had it where if you mistype a url (eg. www.site.com/carrers) it is set to load in an empty template. Just recently, if you mistype URLs, you get a blank page of nothing. Any ...