Questions tagged [assets]

Image-management module by Pixel & Tonic.

88 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
138 views

Assets used in WYGWAM fields don't update when file is moved

I'm using Assets 2.1.4, WYGWAM 2.7.1 and EE 2.5.5. I have a WYGWAM field, and two assets directories, one local and one Amazon S3. In the Assets interface, I can move a file from local to S3 just ...
2
votes
2answers
231 views

Unable to upload files

I need to get images added to a team page, however there is no error message showing, when viewing images that are in the library, they are showing as checkered boxes (checkered wallpaper). Not ...
2
votes
0answers
123 views

Assets not working with Amazon S3 external source

I have set up an external source for S3 and it's not working. I cannot update the index - the white bar shows up but nothing happens. I cannot upload - when I try, I get this error dialog box: "Could ...
2
votes
1answer
329 views

File Manager and Assets Sub Folders

I am having an issue with Assets sub folders and Expression Engine File Manager. I have a folder called photos. In assets i create sub folders more for organisation purposes as having lots of images ...
2
votes
0answers
42 views

Automatic Indexing Assets

Is automatic indexing possible? I want to be able to ftp files up and not have to worry about going into control panel and indexing to get them to pull through on the frontend. This wouldnt be a ...
2
votes
0answers
146 views

Simple HTML file field uploads for an Assets field that appears in a Matrix field in a Safecraker form

I have a Safecracker form that contains a Matrix field, that contains an Assets field. Is there anyway to handcraft the matrix field as per this article: http://themetaq.com/articles/bring-matrix-...
2
votes
0answers
157 views

Assets Upgrade "duplicate" error

I was in the process of trying to upgrade my Assets in the EE 2.5.2 install from version 1.1.5 to 2.1.4. I was able to do the update without issue in our development and staging environments, but when ...
2
votes
0answers
118 views

Using Assets Wygwam, how can I pull in the caption for an image in the text editor?

I need the basic ability to load the caption from an image (assigned in Assets) into Wygwam. Is this possible?
2
votes
0answers
116 views

Assets CSS with Safecracker

Assets looks a bit wonky in a Safecracker form. See attached image. The image container gets calculated wrong. Is there a different CSS file I have to reference when using Assets as a Safecracker ...
2
votes
0answers
140 views

Too many files for Assets to display

I have Assets hooked up to S3, and have over 35,000 images indexed. When loading the Assets module file manager, the browser clocks and cannot render the file list. Same thing when selecting a file ...
2
votes
0answers
199 views

Bulk Convert File Fields to Assets

I'm retrofitting Assets into an existing site and need to convert all of the existing file fields to Assets. All the file fields use the same upload directory and options, so I tried a query: UPDATE ...
1
vote
0answers
168 views

Assets / S3 and Cloudfront Invalidation Issue

Recently moved the site to a new server with php7 and configured AWS for assets. When I upload images, I get an error in the console as follows: <div style="border:1px solid #990000;padding-left:...
1
vote
1answer
130 views

Assets Image Rotation

We have a client that uses a Windows computer that auto rotates images from his camera, but when uploaded are rotated 90 degrees. We know you can rotate images in the File Manager, but it's not very ...
1
vote
0answers
68 views

Assets + multiple files + file manipulations: offset not working

I've got a grid field (slides) that contains 2 Data Types: Text Input - field name: text Assets (multiple selections allowed.) - field name: img The Assets folder that has been selected has a image ...
1
vote
0answers
119 views

Assets upload button disabled for members

I'm having a peculiar issue: Assets works just fine when you're logged in as a super-admin, but when you're logged in as a member, the "upload files" button is disabled. I have no idea what's ...
1
vote
0answers
24 views

Show small icon in Assets if image is being used in system or not?

Looking for a way to show, with a little icon or other indicator, if a file in the Assets module is used in the system or not, as this would be a great help to editors. This would help while ...
1
vote
0answers
57 views

Channel forms - Is it possible that channel form with assets field downloads lots of data?

We've set up a blogging solution for a client that uses channel forms with all the necessary fields, including an Assets field for image upload. Nothing out of the ordinary. The template is as light ...
1
vote
0answers
115 views

500 error when attempting to upload images using pixel and tonic assets module on localhost

I have set up a vhost in mamp (http://az-cms:8887/) - and installed expression engine as well as the assets module. I have a directory set up on my local hard drive within the expression engine ...
1
vote
0answers
62 views

All External Assets Sources Display on MSM Site

I have several S3 external sources set up with Assets on an MSM site. Some sources are for Site 1 and some are for Site 2. However, when I go to the Assets file manager on Site 2, the external sources ...
1
vote
0answers
49 views

Can't make keyword delimiters work in Assets Files tag

Using P&T Assets, assuming I have two files in my Assets folder (folder_id="2"), one having the keyword "tinman" associated with it, the other with "scarecrow", shouldn't this template code return ...
1
vote
0answers
317 views

Images in Assets with .JPG (in capital letters) file extension don't appear in editor

I had a client run into trouble uploading an image in Assets and then trying to drop it in to the WYSIWYG editor. If the file had a .JPG extension — in capital letters — the image would only appear as ...
1
vote
0answers
213 views

Assets and Channel Form Upload

Is there a way to see the files I have selected and to be able to remove them if needed from the upload file button? I am using So I selected for this example 2 files and it only says you have "2 ...
1
vote
1answer
172 views

Possible to upload to S3 when using Assets field in channel form as file input?

Within a channel form, I'm using an Assets field that points to an S3 external source. I'm using the <input type="file" name="assets_field_name"> method (from http://docs.pixelandtonic.com/...
1
vote
0answers
119 views

Does Assets inherit the EE file upload settings?

Assets doesn't seem to use the same settings for file uploads as what is set in the default file manager of Expression Engine. I've made an upload location, only for images not larger than 4M and ...
1
vote
0answers
60 views

Spaces in Image Names

Since updating to Assets 2.2.2, any images that were uploaded with spaces in the file name are now completely absent from the front end. Is there a quick fix for this or do I need to go into Assets ...
1
vote
0answers
166 views

Moving from EE file manager to Assets inside Matrix

I have been moving from EE file manager to Assets on a few sites without problems. The images turn up in the assets channel fields and all looks good. But now I tried changing a field inside Matrix. ...
1
vote
0answers
261 views

I'm getting a "Failed to parse time string" PHP error in Assets when trying to open the file information

I'm getting the following PHP error in the console when trying to open up the image information: <h4>A PHP Error was encountered</h4> <p>Severity: Warning</p> <p>Message:...
1
vote
0answers
62 views

How deep into a Matrix field type can I go with IF statements?

Bear with me as I explain my setup... I have a channel called Speaker and a channel field called speaker_media that is a matrix field type. Inside the matrix I have a channel field for speaker_audio, ...
1
vote
0answers
86 views

Assets Uploads files but says an error occured

In Assets I can get a response by uploading an image to my 'files' folder, it tells me my thumbs isn't writable but it is. When I go to upload anything else it just keeps spinning like it's doing ...
1
vote
0answers
17 views

Is there a way or add-0n to show an image or file is linked from an entry if a user tries to delete it?

A client wants to prevent an editor from renaming or deleting an asset/file/entry that is linked from anywhere on the site. I cannot find an add-on that does this. They are requesting a list that ...
1
vote
0answers
77 views

On entry save... redirecting tp front-end homepage

Currently have a channel entry that has amongst one of its fields a MATRIX to upload a series of images too. Now this is currently been populated using the MATRIX MULTI UPLOAD and for the most part is ...
1
vote
0answers
140 views

Assets throwing PHP error with BetterWorkflow

I'm using EE 2.6.1 Assets 2.1.3 BetterWorkflow 1.6.2.5 Matrix 2.5.5 I'm working with the BWF team too, but since their developer is out for the week, they recommended I also check here. I've ...
1
vote
0answers
126 views

File Category or Assets Folders for File Listings?

I'm using Assets and need to output a 'Resources' section listing various types of PDF's - Brochures, Technical Data, Operating Manuals with a 'category' nav to filter them. I initially set them up ...
1
vote
0answers
116 views

Assets 2.1.1 - No S3 Thumbnails!

Using Assets 2.1.1 with a single S3 source. All images are displaying correctly on the front-end, but no thumbnails are viewable in the Assets file sheet. All of the images are indexed, and the ...
1
vote
0answers
649 views

Assets php error undefined index

I'm getting these PHP errors with Assets 2.05 installed in EE 2.5.5. When an uploaded image is edited through the File Manager "Edit File" or "Edit Image" actions, these warnings show: Undefined ...
1
vote
0answers
153 views

Assets duplicate on front end

Weird one, front end showing duplicates of assets but only sometimes on some entries and always disappears after saving the entry. It appears to be random, that is to say with 300+ products we only ...
0
votes
2answers
24 views

Replacing spaces in image file names

I'm working on an upgrade of an EE2 site to EE6. The site is using Assets and CE Image. A lot of the images that have been uploaded over the years (since 2012) have spaces in the filenames. CE Image ...
0
votes
2answers
28 views

Assets and s3 Expression Engine 2

We run a really old website on EE2.... we're not in a position to upgrade for various reasons. I've just come to hookup s3 with the Assets module and when putting the secret id and access key and ...
0
votes
1answer
139 views

Use the same Assets library across multiple sites

I'm developing two sites to work off the Multi-Site Manager in EE 5.2.2 and ideally would like them to share the same image library as the same logos, adverts and some other images are used on both ...
0
votes
1answer
37 views

Expression Engine 4 / Assets numeric value out of range for column 'filesize' error

We use Expression engine 4 and the latest Assets. After adding a new external source (AWS S3), and trying to update index, I'm getting an error: "Numeric value out of range value for column '...
0
votes
2answers
165 views

Assets field inside grid inside fluid

I’m having an issue where I'm using Assets (EEharbor) inside a EE Grid, inside an EE Fluid field. I think I have the tags correctly set up, it’s outputting the correct number of results (files) from ...
0
votes
1answer
43 views

exp:assets:files fixed_order parameter not working

Assets 2.6 EE 2.9.3 I have the following test code in an otherwise empty template {exp:assets:files fixed_order="3922|834|3991" } <p>{file_id}</p> {/exp:assets:files} I would expect it ...
0
votes
0answers
68 views

Assets hangs on update index

Assets 2.6 EE 2.10.3 This is a rescue site which I didn't build and I'm trying to get it working on the server. When I go to assets, which I just upgraded to the latest version, and try to update ...
0
votes
1answer
40 views

Display an array of pictures in order

I need to display an array of pictures in order but i am not aware of how to accomplish this. this is an EE 2.4 system.
0
votes
1answer
67 views

Bug when using conditional on Assets field value, followed by regular Grid tag

I am using EE 2.10.1, with Assets 2.6. I'm getting a very strange bug in my template. I have an assets image field, and a grid field that contains an Assets column. A PHP Error was encountered ...
0
votes
1answer
27 views

How to prevent Assets uploads within Wygwam for specific user group(s)?

I have created a restricted user group for external bloggers; I want to be able to prevent them from uploading images via Assets, but I'm not sure how. I've restricted access to the Assets module for ...
0
votes
1answer
120 views

Assets 2.6 Uploading Fails

could not upload the file - server returned an unexpected response. please check the server settings I have read every single post about Assets upload fails here (I think!), but sadly, nothing is ...
0
votes
1answer
51 views

Help! Unable to save Assets entries in Grid

Unable to save Assets entries in GridI'm using Assets 2.6 on EE 2.10.2 running with Publisher 1.6.8 I'm able to define Assets fields within Grid fields. The resulting Asset Fields work insofar as ...
0
votes
1answer
256 views

Assets - Strict Standards Error

I have a error on the back-end of my clients site relating with assets which I urgently need to resolve somehow. It is using Assets 2.4 and EE 2.7.1 Strict Standards: Static function ...
0
votes
2answers
84 views

Unable to save Assets entries in Grid

I'm using Assets 2.6 on EE 2.10.2 running with Publisher 1.6.8 I'm able to define Assets fields within Grid fields. The resulting Asset Fields work insofar as they open Assets and allow the ...