Questions tagged [assets]

Image-management module by Pixel & Tonic.

Filter by
Sorted by
Tagged with
6
votes
1answer
649 views

Assets in Wygwam not displaying on front end in EE 2.6/Assets 2.1.1/Wygwam 2.7.1

Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively. I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {...
4
votes
2answers
1k views

Assets not showing the correct upload directory

I just upgraded to Assets 2.0 on EE 2.5.3. Installation went smoothly. However my upload locations aren't acting correctly from within Assets. My folder structure looks like this: system html ...
7
votes
1answer
562 views

Migrating Assets to S3

Using Assets 2.x in a recent site build. When we initially built the site, we didn't opt for S3 as it wasn't approved by the client. Since then, the site has yet to launch and thinking has changed - ...
6
votes
2answers
227 views

SafeCracker + Assets: Restrict file browser to display logged-in member's files only.

Is there a way to configure the Assets file browser in a SafeCracker form to only show assets for the currently logged-in member?
2
votes
1answer
261 views

403 Error with Assets 2.0.5 and Freemember

I'm running into an issue with Assets and Freemember running together. I've narrowed it down to some code in Assets. Freemember is throwing a 403 error on register because it's generating the ...
7
votes
1answer
712 views

Simple HTML file field uploads with Assets and Safecracker

The release notes for Assets 2 says "Added support for simple HTML file field uploads via SafeCracker". Does anyone have any example template code of how this should work, including how to remove the ...
3
votes
1answer
199 views

Assets and WYGWAM 2.7

I see in the latest version of WYGWAM 2.7 that if I use Assets 2.0.4 it will connect my files if I move or rename them. Does this affect just new files or is it 'clever' enough for all of the past ...
3
votes
1answer
150 views

Assets in Wygwam only inserting {assets_X} on first save

So, similar to this question when using Assets in a Wygwam field I am having to re-save an entry to get the image to output on the frontend. When I check what is getting saved to the db I get {...
2
votes
1answer
141 views

Assets 2.0 update crashes CP & site [closed]

More specifically, when opening the modules>assets screen I get a whitescreen in both the site and the CP with the following: Parse error: syntax error, unexpected T_STATIC in /home/ingedingen/...
2
votes
1answer
322 views

File Manager and Assets Sub Folders

I am having an issue with Assets sub folders and Expression Engine File Manager. I have a folder called photos. In assets i create sub folders more for organisation purposes as having lots of images ...
5
votes
2answers
295 views

Restrict Assets directory access per-user in Safecracker

Taking a look at Assets 2.0 docs I can see that with the {exp:assets:folders} tag we can determine the folder where the photos are uploaded in a simple file uploading field, my question is if the same ...
2
votes
1answer
276 views

Parse order fun! Getting a stashed Assets image resized using CE Image inside a plugin parameter

Alright, let's see if I can explain this correctly: I am using Assets to store images to S3 CE Image is being used to manipulate the images and save/serve them from S3 I use stash to try and stay DRY ...
2
votes
2answers
199 views

Assets 2 field not working properly within 2.6 relationship

I've got an assets field within a single relationship, using the new 2.6 tags, and I'm having a couple of problems: The assets tag pair only loops once, regardless of how many assets are in the field ...
4
votes
1answer
250 views

PHP error when using Low Variables with Grid and Assets

I created a Low Variable, using a Grid field. One of the Grid columns is an Assets field. It actually all works as supposed to. Except that I get an annoying PHP notice: Severity: Notice Message: ...
4
votes
2answers
1k views

Assets - 403 forbidden on all requests

I seem to be getting 403 forbidden errors when using assets. I can see this happening in firebug when I try to index folders and if I try to upload a new file, it simply shows an alert saying '...
1
vote
1answer
166 views

Problem with External S3 Source in Assets 2.1.3 and EE 2.5.5

I get the following error when attempting to save an external source using Assets 2.1.3 in EE 2.5.5: Fatal error: Call to undefined method stdClass::result_array() in /home/active/public_html/...
5
votes
1answer
193 views

With Assets 2 is it possible to restrict upload access to a folder within an S3 bucket?

Currently I have about 20 upload paths set in the native EE file manager. all of them point to a variation of subfolders within my main /images folder. I was originally planning to use Assets 2 to ...
5
votes
2answers
158 views

Clicking on folders in the Assets 2 file manager does not work on IE8

I'm using Expression Engine v2.5.5 and Assets v2.0.3 with mulitple upload folders. When using the file manager in IE8 clicking on the folder links does not update the view to show contents of that ...
4
votes
1answer
1k views

How do I get the full Assets URL from Low Variables?

I'm having trouble getting the full URL to an image using Low Variables and Assets. Using the short name of the variable just returns the file name without the rest of the path. {lv_my_image} renders ...
4
votes
3answers
402 views

BetterWorkflow preview throws PHP warnings

ExpressionEngine 2.5.3, Assets 2.0. I also have a ticket into ElectricPutty's support but they suggested that since Assets is supported natively by BWF now, that I post it here. When previewing ...
4
votes
1answer
494 views

Is it possible to convert an EE File Upload path to Assets S3?

I currently have 31 native EE file upload paths all pointing to a location within /images. I'd like to serve all of my image assets from an S3 bucket, so I've created images.domainname.com. I've also ...
4
votes
1answer
348 views

Dynamic Filepaths to Assets Files in Wygwam Fields

How does one go about building a dynamic link to a file managed by Assets within a Wygwam field? In other words, when we move our EE project from dev.example.com/projects/project_name to example.com, ...
3
votes
1answer
114 views

Full Path seems incorrect after update to Assets 2.0.4

After updating to Assets 2.0.4 on EE 2.5.1, I noticed that that when I view a custom Assets field, the previously defined upload directories are no longer checked. After some digging around the ...
3
votes
2answers
456 views

Assets not displaying correctly after moving server

We moved a completely running website to a new server. The whole migration worked out well. The domain name, server settings, paths, MySQL stayed identical. However all uploaded images and assets ...
3
votes
2answers
404 views

Assets doesn't upload files larger than 2Mb

this problem only occurs in my local MAMP PRO 2 environment. Assets acts like it's working (I see the progress bar till the end) but then no files! NOTE THAT On my staging/production environment it'...
3
votes
1answer
389 views

Assets field inside of a grid inside of a low variable — Asset not saving

Having an issue with a low variable of the "Grid" persuasion. I have an assets field inside the grid, and I can upload and add the asset just fine, but when I save the Low Variable, the CP never shows ...
3
votes
1answer
260 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
3
votes
1answer
197 views

Low Variables with Matrix and Assets

We've setup LV with a Matrix field, inside of which is an Assets field. When we submit the changes, these are written to the DB but when the page reloads, the Asset field is blank. It appears this ...
3
votes
1answer
859 views

Assets stopped connecting to Amazon S3, Access denied by target host

Assets has been working well for the past couple of weeks uploading files to Amazon S3. The past few days the customer has started uploading the main bulk of his files Wav files, approx. 10Mb up to ...
2
votes
1answer
569 views

Problem after upgrading Assets: Underscores in folder-names

I upgraded from assets 1 to assets 2. now my folders which start with an underscore are no more recognized. they exist, the images in those folders are shown in the frontend, but i can no more use ...
2
votes
2answers
140 views

Console Error with Assets when Attempting to Index Amazon S3 folder

When I attempt to Index an Amazon S3 folder, I was getting no response. I get the bar, but no progress. Everything works fine when I'm indexing a local folder. So I tried doing it with the Console ...
2
votes
1answer
247 views

Assets 2 on MSM: Tags have no output on second site

I'm branching this off of another question: Assets 2 MSM Cannot Upload or view images I'm not seeing any tag output from Assets in the second site. I'm running EE 2.5.5 with Assets 2.0.5. This is a ...
2
votes
3answers
76 views

On back-end, trying to use Assets loads my homepage on the Assets box!

I have an Assets field on my site. When I click to upload files, the assets box opens as it should, but displays my homepage. Any ideas?
2
votes
1answer
168 views

Assets: Cannot upload file using “simple file input” method

I have an assets field called "member_thumbnail" on my "members" channel (created by zoo visitor). When I make a channel:form edit form or the equivalent edit form from zoo visitor, I am able to ...
1
vote
1answer
48 views

Expression Engine, Assets, ExpressoStore [duplicate]

I have almost finished a white label version of a photography download e-commerce site. I have now hit a brick wall. If I keep all of my photos in the root folder say 'photos' everything is fine. But ...
1
vote
1answer
129 views

Assets out of memory

memory_limit is 2048M (from 7GB) but I got error when indexed big amazon s3 folder PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 25415 bytes) Tried add $...
1
vote
0answers
152 views

Assets duplicate on front end

Weird one, front end showing duplicates of assets but only sometimes on some entries and always disappears after saving the entry. It appears to be random, that is to say with 300+ products we only ...
1
vote
1answer
85 views

Change sort order of files in Assets 2

In Assets 2, is it possible to change the sort order of files so that it automatically shows the most recently uploaded files first? I was hoping there would be a setting or config override for this, ...
1
vote
1answer
139 views

Problems with Assets 2.1.3 when upgrading - throws db error

I'm trying to upgrade to version 2.1.3 of Assets but during the update process it throws the following error: A Database Error Occurred Error Number: 1265 Data truncated for column 'folder_id' at ...
0
votes
1answer
375 views

Assets 2 not indexing

I have installed Assets 2 on a 2.5.5 EE install. I have tried to index the files, but it just sits there and does nothing. No loading bars display like on another website I have used this on. I ...
0
votes
2answers
209 views

Assets2 borked after removing index.php (official Ellislab method)

Using Assets 2.0.5 on EE2.5.5 When I remove index.php using Ellislab's official method Assets simply stops working. It's hard to explain without screenshots, but on existing entries all thumbs are ...
0
votes
2answers
36 views

Assets orderby Title

I can't seem to be able to sort Asset files by their title, instead only by their filename through orderby="name". Is it possible to use the Title field for ordering?