Questions tagged [assets]

Image-management module by Pixel & Tonic.

Filter by
Sorted by
Tagged with
7
votes
1answer
807 views

Assets errors with MySQL 5.7.X

I've started having issues with old EE sites on my development machine now that I'm running newer versions of PHP and MySQL. I've been able to sort most of these out except for the following MySQL ...
7
votes
1answer
714 views

Simple HTML file field uploads with Assets and Safecracker

The release notes for Assets 2 says "Added support for simple HTML file field uploads via SafeCracker". Does anyone have any example template code of how this should work, including how to remove the ...
7
votes
1answer
570 views

Migrating Assets to S3

Using Assets 2.x in a recent site build. When we initially built the site, we didn't opt for S3 as it wasn't approved by the client. Since then, the site has yet to launch and thinking has changed - ...
6
votes
2answers
227 views

SafeCracker + Assets: Restrict file browser to display logged-in member's files only.

Is there a way to configure the Assets file browser in a SafeCracker form to only show assets for the currently logged-in member?
6
votes
1answer
654 views

Assets in Wygwam not displaying on front end in EE 2.6/Assets 2.1.1/Wygwam 2.7.1

Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively. I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {...
5
votes
2answers
263 views

Assets 2 select file on upload

When I upgraded to Assets 2, I noticed that when uploading a file from the modal window in a channel entry form that once the file is uploaded, Assets doesn't automatically select it for me anymore. I ...
5
votes
2answers
162 views

Clicking on folders in the Assets 2 file manager does not work on IE8

I'm using Expression Engine v2.5.5 and Assets v2.0.3 with mulitple upload folders. When using the file manager in IE8 clicking on the folder links does not update the view to show contents of that ...
5
votes
2answers
296 views

Restrict Assets directory access per-user in Safecracker

Taking a look at Assets 2.0 docs I can see that with the {exp:assets:folders} tag we can determine the folder where the photos are uploaded in a simple file uploading field, my question is if the same ...
5
votes
3answers
405 views

Assets won't upload large file?

I'm running into an issue where Assets doesn't upload a file over ~10MB. I've used EE's file manager and that could upload two different files, one ~18MB and one ~23MB. I have this in .htaccess (...
5
votes
1answer
196 views

With Assets 2 is it possible to restrict upload access to a folder within an S3 bucket?

Currently I have about 20 upload paths set in the native EE file manager. all of them point to a variation of subfolders within my main /images folder. I was originally planning to use Assets 2 to ...
4
votes
1answer
1k views

How do I get the full Assets URL from Low Variables?

I'm having trouble getting the full URL to an image using Low Variables and Assets. Using the short name of the variable just returns the file name without the rest of the path. {lv_my_image} renders ...
4
votes
2answers
153 views

Assets 2.0: Why do public templates stall while Assets is working in the admin panel?

I just updated a large EE 2.5.2 install to Assets 2.0 and updated indexes. Everything went smoothly, and I've noticed a strange new behavior: thumbnail generation (any size) in the admin panel will ...
4
votes
3answers
407 views

BetterWorkflow preview throws PHP warnings

ExpressionEngine 2.5.3, Assets 2.0. I also have a ticket into ElectricPutty's support but they suggested that since Assets is supported natively by BWF now, that I post it here. When previewing ...
4
votes
2answers
1k views

Assets not showing the correct upload directory

I just upgraded to Assets 2.0 on EE 2.5.3. Installation went smoothly. However my upload locations aren't acting correctly from within Assets. My folder structure looks like this: system html ...
4
votes
1answer
403 views

Assets and Channel Form upload only

I wondered if it was possible to have a straight-to-upload feature for safecracker (channel form) uploads? On the front end, I'd want to bypass the 'browse' section and only allow users to upload an ...
4
votes
2answers
1k views

Assets - 403 forbidden on all requests

I seem to be getting 403 forbidden errors when using assets. I can see this happening in firebug when I try to index folders and if I try to upload a new file, it simply shows an alert saying '...
4
votes
1answer
349 views

Dynamic Filepaths to Assets Files in Wygwam Fields

How does one go about building a dynamic link to a file managed by Assets within a Wygwam field? In other words, when we move our EE project from dev.example.com/projects/project_name to example.com, ...
4
votes
1answer
179 views

Assets 2 Database Update Error on EE 2.5.1 [closed]

Just ran into the following database error while upgrading from Assets 1.2.2 to 2.0.1. I'm running EE 2.5.1 A Database Error Occurred Error Number: 1050 Table 'exp_assets_folders' already exists ...
4
votes
1answer
88 views

Migrating from Bucketlist (ee1) to Assets (ee2)

I have upgraded a site to EE2 that used Bucketlist extensively (over 8000 items) to serve content from S3. Bucketlist was not updated to EE2, and won't be by the looks of things, so I need to find a ...
4
votes
0answers
143 views

Assets used in WYGWAM fields don't update when file is moved

I'm using Assets 2.1.4, WYGWAM 2.7.1 and EE 2.5.5. I have a WYGWAM field, and two assets directories, one local and one Amazon S3. In the Assets interface, I can move a file from local to S3 just ...
3
votes
2answers
1k views

Can't upload files to Assets 2.0.5 in ExpressionEngine 2.5.5

Cannot upload files with Assets v2.0.5 in ExpressionEngine v2.5.5. Files uploaded with native EE file manager works. Directory permissions for upload directory is 777 (for troubleshooting sake). XSS ...
3
votes
1answer
257 views

PHP error when using Low Variables with Grid and Assets

I created a Low Variable, using a Grid field. One of the Grid columns is an Assets field. It actually all works as supposed to. Except that I get an annoying PHP notice: Severity: Notice Message: ...
3
votes
2answers
412 views

Assets doesn't upload files larger than 2Mb

this problem only occurs in my local MAMP PRO 2 environment. Assets acts like it's working (I see the progress bar till the end) but then no files! NOTE THAT On my staging/production environment it'...
3
votes
1answer
262 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
3
votes
3answers
196 views

Does P&T Assets work with Rackspace cloudfiles?

I have noticed that Pixel & Tonic Assets add-on explicitly states compatibility with Amazon S3. We use Rackspace for our site and are expanding to CloudFiles to take advantage of the integrated ...
3
votes
1answer
865 views

Assets stopped connecting to Amazon S3, Access denied by target host

Assets has been working well for the past couple of weeks uploading files to Amazon S3. The past few days the customer has started uploading the main bulk of his files Wav files, approx. 10Mb up to ...
3
votes
2answers
951 views

Assets 2.1.4 strange behaviour: "Could not upload the file ... "

Assets is the only thirdparty module/filedtype installed. Native cache folder are 777. File upload directory is working and uploads images correctly. Assets shows no folder at all. But if I upload one ...
3
votes
3answers
276 views

When trying to update indexes a get a JS error and it never finished

I go into the Assets add-on, then to "Update Indexes," select my image group and hit the "Update Indexes" button and get an immediate JS error: Uncaught SyntaxError: Unexpected token < assets.min....
3
votes
1answer
199 views

Low Variables with Matrix and Assets

We've setup LV with a Matrix field, inside of which is an Assets field. When we submit the changes, these are written to the DB but when the page reloads, the Asset field is blank. It appears this ...
3
votes
2answers
459 views

Assets not displaying correctly after moving server

We moved a completely running website to a new server. The whole migration worked out well. The domain name, server settings, paths, MySQL stayed identical. However all uploaded images and assets ...
3
votes
1answer
393 views

Assets field inside of a grid inside of a low variable -- Asset not saving

Having an issue with a low variable of the "Grid" persuasion. I have an assets field inside the grid, and I can upload and add the asset just fine, but when I save the Low Variable, the CP never shows ...
3
votes
1answer
160 views

Assets + Low Variables // Limiting and Ordering By "Random"

Trying to do something I feel should be very simple to execute, but I cannot for the life of me seem to get it to work. Here's my template snippet: {exp:low_variables:parse var="...
3
votes
1answer
72 views

Best Practice for moving a site using Assets

I have a fairly big site with substantial use of Assets2 in development and am wondering what general guidelines / best practices anyone can suggest for when moving this to the production server? Any ...
3
votes
1answer
339 views

More efficient way to check if Asset field is blank within Matrix

Need to display if a Asset field within a Matrix field has a file or not. While this works, the overhead is really high. Is there a way to write this with less overhead? Based on the EE template ...
3
votes
1answer
501 views

Is it possible to convert an EE File Upload path to Assets S3?

I currently have 31 native EE file upload paths all pointing to a location within /images. I'd like to serve all of my image assets from an S3 bucket, so I've created images.domainname.com. I've also ...
3
votes
1answer
59 views

Bulk edit in Assets

Is it possible to select multiple images for editing their attributes? e.g. changing keywords, date etc.
3
votes
1answer
200 views

Assets and WYGWAM 2.7

I see in the latest version of WYGWAM 2.7 that if I use Assets 2.0.4 it will connect my files if I move or rename them. Does this affect just new files or is it 'clever' enough for all of the past ...
3
votes
1answer
389 views

Assets and MSM won't upload/display

I have sites A and B Each site has it's own uploads directory, and I have the upload preferences set dynamically: $config['upload_preferences'] = array( 1 => array( ...
3
votes
1answer
1k views

Assets and Member Group Permissions

I recently installed 'Assets' by Pixel & Tonic for a client that has multiple member groups with access to the control panel. Each member group has varying permissions level. The install went fine,...
3
votes
1answer
150 views

Assets in Wygwam only inserting {assets_X} on first save

So, similar to this question when using Assets in a Wygwam field I am having to re-save an entry to get the image to output on the frontend. When I check what is getting saved to the db I get {...
3
votes
1answer
115 views

Full Path seems incorrect after update to Assets 2.0.4

After updating to Assets 2.0.4 on EE 2.5.1, I noticed that that when I view a custom Assets field, the previously defined upload directories are no longer checked. After some digging around the ...
3
votes
0answers
74 views

Assets 2 update causes PHP errors [duplicate]

Possible Duplicate: Assets not showing the correct upload directory I'm running EE 2.5.1 and updating from Assets 1.2.2 to 2.0.1. I've followed instructions from the Pixel & Tonic docs. ...
2
votes
1answer
80 views

EE "Assets" not recognizing FLV file

I've installed P&T "Assets", set up an upload directory "/videos", added 4 files to it, and had Assets "index" that folder: http://d.pr/i/kG39 Assets ignores the .flv file but finds, or I presume ...
2
votes
2answers
148 views

Assets2: exp_assets_folders table gives error on migration [closed]

just upgraded to Assets 2 and must say the visuals are stunning. When migrating from my local machine to my online development enviroment i got the following SQL error when uploading the database. ...
2
votes
1answer
141 views

Assets 2.0 update crashes CP & site [closed]

More specifically, when opening the modules>assets screen I get a whitescreen in both the site and the CP with the following: Parse error: syntax error, unexpected T_STATIC in /home/ingedingen/...
2
votes
2answers
200 views

Asset field in Matrix not updating

I have an Assets field in a Matrix column that has stopped updating. If you edit or delete the asset and save the entry, the entry will save successfully. However, if you reopen the entry (or view it) ...
2
votes
1answer
326 views

image manipulation with assets 2

is it true that assets 2 does not support image manipulations anymore? I just had a hard time debugging a site after updating to assets 2. I'm on EE 2.5.5 and assets 2.0.2 it was one of my favorite ...
2
votes
1answer
160 views

Why are my P&T Assets folders taking 2 minutes to load?

I am using Assets to manage some of the images on my site. The CP loads as expected and nothing is too out of the ordinary. I have 196MB RAM set in PHP.ini and on a VPS. When I click on an assets ...
2
votes
2answers
249 views

Assets in Grid In Low Variables - multiple files

EE 2.10.1 Lv 2.6.1 Assets 2.6 I've got a Low Variables grid with a once cell Assets and in the assets you can upload multiple images. Using this thread I was able to successfully display a single ...
2
votes
2answers
61 views

How to trigger P&T Assets to Update Indexes from a template

I have created a PDF generating tool that creates certificates for members, creates a sub-folder within a one of my file upload directories, then places the file into the new directory. I am trying ...

1
2 3 4 5
9