Questions tagged [assets]

Image-management module by Pixel & Tonic.

Filter by
Sorted by
Tagged with
0
votes
1answer
72 views

Weird URLs for images from Assets

I'm troubleshooting a problem with an older, rarely updated site, so I'm not sure how recently this issue cropped up, though I'm fairly certain it worked when I handed it off. We have a Low Variable ...
1
vote
1answer
129 views

Assets out of memory

memory_limit is 2048M (from 7GB) but I got error when indexed big amazon s3 folder PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 25415 bytes) Tried add $...
0
votes
2answers
136 views

Assets: Unable to Replace File on S3

When attempting to replace an existing file on an S3 source, the upload fails. Here's the sequence of events: Upload file sample_image.jpg for the first time (works fine) Click 'Upload' and select ...
1
vote
2answers
68 views

Working with staging server and production server - can they share the same Assets locations?

I have 3 installations of my website: beta, demo, and production. Template and functionality changes are made on beta, content is entered on demo and everything moves to production as it is approved. ...
0
votes
0answers
311 views

Assets Upload Failing

I'm trying to upload some files to EE via Assets but they keep failing. This is the response: Could not upload the file - server returned an unexpected response. Please check the server settings....
1
vote
3answers
1k views

Delete Assets input fields in a front-end form

I have the following in a Zoo Visitor Update form: <label class="control-label" for="member_photo">Performer / Band Photo</label> <input type="hidden" name="member_photo[]" value="...
1
vote
1answer
157 views

Assets and Low Variables not compatible?

When I add an assets field to a Low Variable, it reports that it's added it correctly, however I then get a fatal error whenever I try to load the LV dashboard: Unable to load the requested file: ...
2
votes
1answer
42 views

Pixelandtonic Assets: Set Content-disposition?

Long story short: in Chrome, some PDF files stored in our S3 bucket (uploaded via Assets) hang up on download. Chrome just sits there, never downloading the file. (However, right-clicking the link ...
1
vote
2answers
89 views

Can't save large matrix field

I'm having a problem similar to this one where I can't save large matrix fields on my site. Large, in this case, is > 200 rows with 3 fields each where 2 of those are asset fields. EE/Matrix/Assets/...
4
votes
1answer
250 views

PHP error when using Low Variables with Grid and Assets

I created a Low Variable, using a Grid field. One of the Grid columns is an Assets field. It actually all works as supposed to. Except that I get an annoying PHP notice: Severity: Notice Message: ...
1
vote
0answers
68 views

Assets + multiple files + file manipulations: offset not working

I've got a grid field (slides) that contains 2 Data Types: Text Input - field name: text Assets (multiple selections allowed.) - field name: img The Assets folder that has been selected has a image ...
2
votes
1answer
60 views

{filedir_X} variable for Assets S3?

Is there an Assets variable like {filedir_X} that will output the S3 server path? I'm moving my images to S3 and I have referenced images in several channel entries in a textarea like <img src="{...
1
vote
1answer
157 views

Assets images and Content Elements with conditionals to control number of images displayed

This is probably really simple to solve but I've got stuck in a dead end. I want to allow users to upload single or multiple images using an Assets image field (resizing with CE Image) within a ...
0
votes
1answer
41 views

How to Use assets_ignore_folder_patterns on the config

I would like to exclude multiple folders from the Asset list to minimize the amount of folders to be loaded. I can't seem to get this config working. and there's not enough info available on the ...
0
votes
0answers
75 views

Assets & MSM: Assets field not parsing at all on second site

We've added a second site to our EE setup using MSM (and we use Master Config too). The structure is something like this (site1 is web root; site2 is a subdomain technically): master-config site1 ...
0
votes
2answers
36 views

Assets orderby Title

I can't seem to be able to sort Asset files by their title, instead only by their filename through orderby="name". Is it possible to use the Title field for ordering?
0
votes
0answers
45 views

Assets not showing up for second site

I'm setting up Multi-Site for ExpressionEngine and when I go to manage my files in the P&T Assets plugin, nothing shows up. The refresh icon just spins. Even when I create a new upload destination ...
0
votes
1answer
76 views

Can I link an entry to an Assets folder, instead of adding files?

I am using Assets to manage documents associated with entries, but each entry will have sub-folders. Categories for each document. I am hoping to show a folder navigation on the front end to click the ...
0
votes
2answers
89 views

P&T Assets not functioning correctly after migrating to new server environment

After moving my site to a staging environment I'm no longer able to view any images within the Assets portion of the CP or upload files to any Assets related fields. I'm also unable to update the ...
1
vote
1answer
48 views

Expression Engine, Assets, ExpressoStore [duplicate]

I have almost finished a white label version of a photography download e-commerce site. I have now hit a brick wall. If I keep all of my photos in the root folder say 'photos' everything is fine. But ...
2
votes
1answer
322 views

File Manager and Assets Sub Folders

I am having an issue with Assets sub folders and Expression Engine File Manager. I have a folder called photos. In assets i create sub folders more for organisation purposes as having lots of images ...
0
votes
0answers
33 views

Watermarking in Assets

I've been asked by a client if they can add a watermark credit to their images. The watermarks would need to be set on a per-image basis - there would potentially be hundreds of different image ...
1
vote
1answer
70 views

Assets thumbs not being generated

All of a sudden, thumbs are not showing in Assets. The folders are being created in the cache/assets/thumbs folders when files are uploaded, but no image is generated. The odd part is that in my dev ...
1
vote
1answer
47 views

Accessing P&T Assets files from WYGWAM

I just uploaded P&T Assets. Shouldn't I be able to access my Assets directories from a WYGWAM? I don't have any folder listed in the WYGWAM settings. What am I doing wrong?
2
votes
0answers
42 views

Automatic Indexing Assets

Is automatic indexing possible? I want to be able to ftp files up and not have to worry about going into control panel and indexing to get them to pull through on the frontend. This wouldnt be a ...
1
vote
0answers
118 views

Assets upload button disabled for members

I'm having a peculiar issue: Assets works just fine when you're logged in as a super-admin, but when you're logged in as a member, the "upload files" button is disabled. I have no idea what's ...
1
vote
1answer
63 views

once a file has been uploaded to the upload directory in expresssionengine can it be moved on my server?

Can I move files that have been uploaded to the upload directory be moved on my server, or will they be lost in the upload directory and therefore not show on the site?
1
vote
1answer
77 views

php cli & expression engine

i just installed EE 2.8.0 on a server running php cli. It seems that this is causing issues with creating new templates & uploading files in general. Hosting provider is not willing to make any ...
0
votes
2answers
227 views

How to get the Assets index in looping field tag pair?

I'm converting some code over from using grid fields with images to use a single Assets field instead. All good so far. But I need a way to get at the index (current asset number while looping ...
2
votes
1answer
185 views

Assets v2.4 producing error when saving an entry after upgrade from EE v2.4 to EE v2.9

I've recently performed an update of both Assets (v1.x to v2.4) and EE (v2.4 to v2.9) and now I'm seeing the following error/s when I try to save an entry in the EE control panel. A PHP Error was ...
0
votes
1answer
499 views

Conditional on Assets Field Tag that contains a quote in EE v2.9

Running up against a problem in the use of an Assets field tag in a conditional where there's single quotes entered into the field (in this case the Caption field). Caption: Otherwise know as 'Old ...
1
vote
0answers
24 views

Show small icon in Assets if image is being used in system or not?

Looking for a way to show, with a little icon or other indicator, if a file in the Assets module is used in the system or not, as this would be a great help to editors. This would help while ...
0
votes
1answer
95 views

Assets within a relationship field

I have tried everything I can think of, but can't get an assets field to output from a relationship. {suggested_products} {suggested_products:product_images} {product_images:url} {/...
0
votes
0answers
114 views

Assets upload with channel form to sub folder with userid

I´m trying to make users upload files to a folder in assets that contains only user files. But i want them to, when they open to select files and upload files, to have a folder with the memberid as ...
1
vote
1answer
47 views

Files disappear from assets

EE 2.4 Assets 1.1.5 Following a server upgrade from PHP 5.2 to PHP 5.4 all files in the Assets addon have gone from a clients installation. All the images in the channel entries have also vanished. ...
1
vote
2answers
218 views

Matrix Total Rows Column Search Conditional

So I have this conditional that works properly for entries with matrix rows: {if {tech_documents:total_rows search:doc_thumb="IS_EMPTY"} > 0} ... {if:else} ... {/if} However, ...
0
votes
2answers
80 views

Assets (P&T) No thumbnail for Admin group

My admins can upload images to Assets field. They even see the thumbnail before saving. After saving though, the thumbnail does not display. This is a site-wide issue. I have updated the index. It ...
0
votes
1answer
45 views

P&T Assets - old image selections returning

I've recently upgraded a site to use Assets 2.3.2 instead of the built-in File field-type. This field is a column in a Matrix field. During the process of setting the new field-type I did notice that ...
0
votes
1answer
91 views

Google Maps / Assets / Grid

I'm attempting to insert an Assets field, Grid data along with some other text input fields into a Info Box in a Store Locator page. My code is as follows: {exp:gmap:results order_by="distance" sort="...
1
vote
1answer
126 views

Wyvern and Channel Forms

I've been looking into creating a front-end client dashboard using wyvern, assets and of course channel forms. I have played with many configurations to get the 'dashboard' working. Specifically, ...
2
votes
0answers
57 views

Channel forms - Is it possible that channel form with assets field downloads lots of data?

We've set up a blogging solution for a client that uses channel forms with all the necessary fields, including an Assets field for image upload. Nothing out of the ordinary. The template is as light ...
1
vote
2answers
253 views

Importing assets programmatically

What I (or or customer) want to do is as follows: An existing external API has regularly updated documents for different products The existing product channel in EE will hold an ID that is recognised ...
0
votes
2answers
85 views

Assets: Log's me out of the cp

I have just installed Assets. But it keeps logging me out of the CP. This error occurs (console): POST http://centiv.local/admin/ 500 (Internal Server Error) It contains: {"error":"This form has ...
1
vote
1answer
57 views

Setting default upload area for Assets

Hopefully a simple answer, but at the moment, I can't figure it out. I'm using an Assets field in a channel entry. When the client clicks on the "Add file" button, it defaults to the "Recent Uploads" ...
0
votes
3answers
165 views

Does Assets support the category image field

I'm trying to attach category images from the edit category function in EE. I noticed that while adding an image category images only displays the EE file manager. I'm using Assets (S3) however as the ...
0
votes
2answers
88 views

Assets 2.3.2 Lib file - Causes PHP error

After updating to the latest versions of the Assets extension for Expression Engine. When I am logged in as a Super Admin I get the following PHP error, I don't get this error when logged in as a ...
1
vote
1answer
34 views

Assets 2.3.2 / Wygwam 3.3

I’m getting an error when saving an entry. I do the following. edit entry select image in Wygwam (browse server opens Assets) save entry When I save the entry I’ll see an example of the content with ...
1
vote
3answers
224 views

Assets 2.2.2 / 2.3.2 chequerboard / empty thumbnails

I have the chequerboard / empty thumbnails showing up in Assets, for all images. Everything is working fine on the live site. So far I've tried: Checking / applying 777 to all images and the cache/...
0
votes
1answer
31 views

Get Original URL in assets_rename_file / assets_move_file Hooks

The documentation for Assets' assets_rename_file() and assets_move_file() hooks indicates that the first argument is "an object extending Assets_base_file class for the file that is about to be [...
2
votes
1answer
214 views

Multiple Content-Elements with Assets-elements breaking on what seems to be a specific number of images

Background So i keep getting an error when adding more images to the second Content-Elements field on one of my pages. I have one for the maincontent and this one seems to work with an "infinite" ...

1
2
3 4 5
9