Questions tagged [assets]

Image-management module by Pixel & Tonic.

Filter by
Sorted by
Tagged with
0
votes
2answers
278 views

No images in Assets file manager and no Update Indexes option

Just got handed over ExpressionEngine from previous developer so we migrated it to our new server. There are no images in the frontend and backend admin panel. 777 permission were given to _assets, ...
1
vote
0answers
59 views

Spaces in Image Names

Since updating to Assets 2.2.2, any images that were uploaded with spaces in the file name are now completely absent from the front end. Is there a quick fix for this or do I need to go into Assets ...
0
votes
0answers
129 views

Assets thumbnails: The action you have requested is invalid

Thumbnails for Assets are not working for me in the admin cp, I just see the checkers background. When I try to directly access a url that's being requested for an image, I get the message "The action ...
1
vote
1answer
213 views

Why Assets writes folder with 755 write permission

I'm using assets 1.1.4 on a 2.5.3 EE install (Sorry but i cannot update now for any reason) When I create a folder in assets this folder is written as apache:apache with this permissions: drwxr-xr-x -...
1
vote
1answer
499 views

Assets Upload Error: “Getting content length is not supported.”

When I try to upload a file to Assets, I get this alert: Could not upload the file - server returned an unexpected response. Please check the server settings. The console shows a 500 error when ...
0
votes
1answer
493 views

Assets folders showing…but no image thumbnails are loading

I'm using EE 2.7.2, PHP 5.3.27, and Assets 2.2.2 and I'm running into a weird issue that I haven't come across. I'm getting 403 forbidden errors in my javascript console and I check the files on the ...
0
votes
1answer
72 views

Possible to force unique SAEF-uploaded filenames?

I'm currently building a site right now that allows registered members to add their own logo to entries they create via a SAEF. I have Assets installed for this site but also have SafeCracker File ...
1
vote
2answers
177 views

Retrieve Assets file data from custom module

I'm writing a custom module that's going to need to retrieve channel data using a direct database query. One of the custom fields is an Assets image and I need to get the full image URL and alt_text ...
3
votes
1answer
389 views

Assets field inside of a grid inside of a low variable — Asset not saving

Having an issue with a low variable of the "Grid" persuasion. I have an assets field inside the grid, and I can upload and add the asset just fine, but when I save the Low Variable, the CP never shows ...
1
vote
1answer
108 views

Error when using WYGWAM 3.2.1 & Assets 2.2.2 with EE < 2.6

According to the WYGWAM Installing and Updating page, WYGWAM requires ExpressionEngine 2.4 or late. However, if you are using both WYGWAM 3.2.1 and Assets 2.2.2 (may be the same for older versions) ...
2
votes
1answer
562 views

Assets field within Grid field does not display

I have an issue using an Assets field (2.2.2) within a Grid field (EE 2.7.2). Here is my code: {home_slideshow} <img src="{exp:img_resize src="{home_slideshow:slide_image}" width="745" height="...
0
votes
1answer
103 views

Database error after updating Matrix 2.4.3 to 2.5.8 [duplicate]

I just updated an EE site from 2.4.0 to 2.7.2. Now going through and updating (many) plugins. I just updated Matrix from 2.4.3 to 2.5.8 and I get the error below while trying to click on Matrix in the ...
2
votes
1answer
569 views

Problem after upgrading Assets: Underscores in folder-names

I upgraded from assets 1 to assets 2. now my folders which start with an underscore are no more recognized. they exist, the images in those folders are shown in the frontend, but i can no more use ...
1
vote
1answer
239 views

Pixel and Tonix Assets and Wygwam Fields within Content Elements

I looked around and could not find how to have different types of Wygwam and Asset fields inside of Content Elements. For example I want to be able to have two different types of Wygwam fields. I ...
2
votes
2answers
194 views

Asset field in Matrix not updating

I have an Assets field in a Matrix column that has stopped updating. If you edit or delete the asset and save the entry, the entry will save successfully. However, if you reopen the entry (or view it) ...
1
vote
1answer
101 views

Assests + MSM + Indexing new site = Uh oh!

SO, I have assets installed on site1 - works great. I add site 2, index the uploads, cool. I can add images in the module, but when I try to add images within an entry, the buttons are grayed back. ...
2
votes
2answers
342 views

Issue with Assets on Client end only

My client is experiencing a really weird issue. When they are publishing or editing an entry with an Assets custom field it displays only a white box. They experience this issue in both their ...
1
vote
0answers
166 views

Moving from EE file manager to Assets inside Matrix

I have been moving from EE file manager to Assets on a few sites without problems. The images turn up in the assets channel fields and all looks good. But now I tried changing a field inside Matrix. ...
2
votes
1answer
98 views

Using Pixel and Tonic Assets 2 for websites with lots of images

Simple question here! I'm using Assets on every site but I found the last version very slow when browsing files, creating folders etc. etc. so what do you use in large siteswith lots of images? (also ...
1
vote
2answers
1k views

Assets Unable to Connect to S3: Access denied by target host

I'm getting an "Access denied by target host" error when attempting to connect to S3 with Assets. In order to troubleshoot further, I've added a var_dump around line 238 in third_party/assets/sources/...
1
vote
1answer
81 views

Assets Unable to Load S3 Buckets; No Error Message

When loading the buckets for a new S3 source, Assets is failing silently (no buckets listed in select box, no error message), despite correct S3 credentials.
2
votes
1answer
74 views

There are some entries in the db that are out of date, please select

EE 2.6.1 Assets 2.2.1 I was doing an index update in Assets when ran into that, someone can help me understand?
1
vote
1answer
814 views

Database Error “Error Number: 1054”

I have a fairly fresh install of ExpressionEngine 2.7.2 and am having tons of problems with either Assets or Matrix upon saving an entry. I'm receiving the following error: A Database Error Occurred ...
1
vote
1answer
260 views

Cannot upload to root images directory in Assets, subdirectories OK

I'm having trouble uploading images using Assets. Assets: v2.1.4 EE: v2.6.1 - Build Date: 20130506 They are uploading. If I refresh the Assets screen, I see them. But when I upload them, I receive ...
0
votes
1answer
564 views

Problem with Assets in Grid “Undefined index: grid_row_id; Filename: assets/ft.assets.php; Line Number: 1310”

EE 2.7.1 and Assets 2.2.1 I have a Grid fieldtype (static-images) with an Assets column named image and a few native text field & dropdown columns. When I have at least one row in the Grid, I get ...
0
votes
1answer
59 views

Only the first upload directory shows in assets when used with wygwam

When using the main assets window, all of the available upload directories are available to choose from in the left hand navigation. (See Screenshot 1) When using the popup generated by wygwam when ...
2
votes
1answer
120 views

Assets field within Playa field + EE 2.7.1 causing template code to display on front end

I just upgraded EE to 2.7.1 and am having problems with my Playa (4.4.5) fields that pull in Assets (2.1.4) data. I have a 'homepage' channel with a Playa field that pulls articles from a 'features' ...
0
votes
1answer
48 views

Assets 2 loses Rackspace thumbnails

The first time I upload via Rackspace, the thumbnails on the backend appear fine. However, if I delete the expressionengine/cache directory and it regenerates the images, the result is 70 byte 'jpgs' ...
1
vote
1answer
59 views

Can you write a conditional which tests against image dimensions in Assets?

Using Assets, can I write a conditional which tests against the dimensions of an image? So as an example if an image height is >= 200px add this class, < 200px add that class.
0
votes
1answer
219 views

Custom asset metadata fields

Is there anyway, or any plans to add the ability to create custom metadata fields for (Pixel & Tonic's) Assets? I can't see any references on the docs, nor any content on the web directly ...
1
vote
0answers
260 views

I'm getting a “Failed to parse time string” PHP error in Assets when trying to open the file information

I'm getting the following PHP error in the console when trying to open up the image information: <h4>A PHP Error was encountered</h4> <p>Severity: Warning</p> <p>Message:...
2
votes
0answers
146 views

Simple HTML file field uploads for an Assets field that appears in a Matrix field in a Safecraker form

I have a Safecracker form that contains a Matrix field, that contains an Assets field. Is there anyway to handcraft the matrix field as per this article: http://themetaq.com/articles/bring-matrix-...
1
vote
0answers
62 views

How deep into a Matrix field type can I go with IF statements?

Bear with me as I explain my setup... I have a channel called Speaker and a channel field called speaker_media that is a matrix field type. Inside the matrix I have a channel field for speaker_audio, ...
3
votes
1answer
158 views

Assets + Low Variables // Limiting and Ordering By “Random”

Trying to do something I feel should be very simple to execute, but I cannot for the life of me seem to get it to work. Here's my template snippet: {exp:low_variables:parse var="...
4
votes
1answer
402 views

Assets and Channel Form upload only

I wondered if it was possible to have a straight-to-upload feature for safecracker (channel form) uploads? On the front end, I'd want to bypass the 'browse' section and only allow users to upload an ...
0
votes
1answer
143 views

Change file field to assets field without losing the selected image

Does Assets keep the same content when changing from a file field? I just wanted to be sure on this. Thanks, Diederik
1
vote
1answer
179 views

Assets UI fails (goes white) on local/dev, but works perfectly on prod

I've got an odd issue where essentially the same Assets on production works fine, but fails on local/dev. Asset's native file manager does not display any images and just spins Inline-file manager ...
0
votes
1answer
68 views

Assets + Safecracker: Preselect folder and/or view type?

I don't use Safecracker very often, but I'm working on an EE 2.6.1 project where {field:assets_field} is magically bringing the Assets file manager (and uploads) to the front end. I see that this ...
1
vote
1answer
184 views

Wygwam, Assets, and Image Manipulations

Is there a way to insert an image's "Image Manipulation" into a Wygwam field? I'm using Assets as the file manager in Wygwam.
1
vote
1answer
185 views

How can I determine Assets' internal folder_id for use in the {exp:assets:files} tag?

The subject says it all, really... Assets apparently uses an internal ID for folders that is different from EE's folder ID. Disregarding the reasoning WHY Assets had to have different folder IDs... ...
0
votes
2answers
306 views

P&T Assets Url Path

Is there a way in P&T Assets to output just the file's relative url path without the filename? For instance, I'm trying to call a file's retina image. This is the normal file output: {...
1
vote
1answer
427 views

Assets uploads Failing, Server requirements

I'm running EE 2.5.5 and Assets 2.1.4 I have massive upload problems on several websites running assets. assets fails to upload certain images. i get a notification «Could not upload the file - ...
0
votes
2answers
463 views

.htaccess for nexcess shared hosting

I have 2 sites running on different shared hosting servers with nexcess.net both with similar setups (same version of EE 2.6.1 and same add-ons) and both experiencing different issues which I'm ...
2
votes
1answer
1k views

How can I get the length (duration) of an audio file?

I'm pulling media files (audio and video) into a template with Assets add-on. It doesn't appear to have the ability to grab the length (duration) of the media being uploaded. Is there a quick and easy ...
3
votes
2answers
920 views

Assets 2.1.4 strange behaviour: “Could not upload the file … ”

Assets is the only thirdparty module/filedtype installed. Native cache folder are 777. File upload directory is working and uploads images correctly. Assets shows no folder at all. But if I upload one ...
1
vote
1answer
193 views

Assets: Unable to Upload Large Files to S3

I'm trying to upload a 43MB .mp4 video file to S3 using Assets. The progress bar will run all the way to the end (it takes about a minute), then I'll get an alert that says "Undefined", and the ...
0
votes
2answers
274 views

Assets thumbs missing when moving EE to a new server

I've seen a few posts here around this issue but none are leading me to a solution. I'm using Assets with an S3 bucket and have moved EE to a new server. The front-end of the site loads right up just ...
1
vote
1answer
97 views

P&T Assets Error Creating Subfolders : Invalid Assets Source Path

I'm pretty sure I'm missing something obvious here. But for some reason, when I try and create a new subfolder, I get the following: "Invalid Assets source path". I checked and the parent folder has ...
0
votes
1answer
88 views

When I add an image to a WYGWAM field, using Assets, from an S3 source, I get a double slash

I chose an image from a regular upload directory and it works fine. I chose one from an S3 source set up in Assets, and it doesn't. For instance: <img alt="" src="http://s3.amazonaws.com/...
1
vote
1answer
85 views

Change sort order of files in Assets 2

In Assets 2, is it possible to change the sort order of files so that it automatically shows the most recently uploaded files first? I was hoping there would be a setting or config override for this, ...

1 2 3
4
5
9