Questions tagged [assets]

Image-management module by Pixel & Tonic.

Filter by
Sorted by
Tagged with
2
votes
0answers
156 views

Assets Upgrade “duplicate” error

I was in the process of trying to upgrade my Assets in the EE 2.5.2 install from version 1.1.5 to 2.1.4. I was able to do the update without issue in our development and staging environments, but when ...
4
votes
0answers
138 views

Assets used in WYGWAM fields don't update when file is moved

I'm using Assets 2.1.4, WYGWAM 2.7.1 and EE 2.5.5. I have a WYGWAM field, and two assets directories, one local and one Amazon S3. In the Assets interface, I can move a file from local to S3 just ...
0
votes
1answer
249 views

Converting standard file field to an Assets field with a remote source [duplicate]

I have about 250 blog entries, each with a standard EE file field that points to a file on the same local server EE is running on. I've installed the Assets add-on and set up an external source (an ...
2
votes
2answers
156 views

Assets and Matrix server error on save with high numbers of Matrix rows

I had an issue on an earlier site build where entries containing a Matrix field with numbers of rows in excess of about 60 wouldn't save. The Matrix field in question contained two Assets fields, a ...
1
vote
1answer
58 views

Members upload photos into their own restricted subdirectory?

Can this be done, including blockage to other (members) sub directories?
0
votes
1answer
190 views

Assets & S3: Output Source Folder + Subfolder + Filename

I have a file on S3 uploaded with Assets. The full URL is: http://s3-us-west-2.amazonaws.com/my-bucket/source-folder/subfolder/file-name.pdf source-folder is the subfolder in the bucket where the ...
3
votes
1answer
68 views

Best Practice for moving a site using Assets

I have a fairly big site with substantial use of Assets2 in development and am wondering what general guidelines / best practices anyone can suggest for when moving this to the production server? Any ...
3
votes
3answers
272 views

When trying to update indexes a get a JS error and it never finished

I go into the Assets add-on, then to "Update Indexes," select my image group and hit the "Update Indexes" button and get an immediate JS error: Uncaught SyntaxError: Unexpected token < assets.min....
1
vote
0answers
86 views

Assets Uploads files but says an error occured

In Assets I can get a response by uploading an image to my 'files' folder, it tells me my thumbs isn't writable but it is. When I go to upload anything else it just keeps spinning like it's doing ...
3
votes
1answer
260 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
2
votes
1answer
53 views

Assets Module only grants Super Admin access

Assets v2.1.4 ExpressionEngine v2.5.5 I'm experiencing issues when trying to access the assets module when logged in as any user other than Super Admin. The other member group's privileges and ...
1
vote
1answer
99 views

P&T Assets - How to show no results?

i was playing around with Assets 2.1.4 and i was wondering if there is any way of checking for no results. My code: {my_assets_field limit="30" offset="80"} <li><a href="{url}" alt="{...
1
vote
1answer
673 views

Getting a file directory tag {filedir_1} out of a query module result

I'm using a query module to get the results of a channel entry. I've retrieved the correct url: {filedir_1}/newimages/img1.png but it does not replace the {filedir_1} with the necessary prefix like ...
1
vote
0answers
48 views

Unable to create Subfolder in Assets

Not quite the issue some others have experienced as far as I can see. I try to create a new Subfolder in an Assets folder (set to (777) but get the message: "Assets could not complete the requested ...
1
vote
1answer
71 views

Does Assets support categories?

I'm looking to create a file repository of PDFs. One way I was thinking to do this is to just use the native file manager with categories to sort the content. But I would prefer to use Assets, but I ...
1
vote
1answer
65 views

Can upload image with Assets, but image does not “stick” to entry

I can upload an image to my Asset field(s) and publish the entry. However, here are the weird issues I'm experiencing: The Asset field is blank when re-editing the published entry, (but...) The ...
1
vote
1answer
72 views

Is there a shortcut/variable tag for an Assets field’s ‘parent’ entry title?

I have an Assets field in a Matrix field. When I'm inside the Assets field's loop, is there a shortcut tag to output the 'parent' entry's Title field (1.1 in the hierarchy below)? Entry Title Matrix ...
1
vote
1answer
177 views

Search on Assets (pixel & tonic) Meta Data

Hi I need help with searching assets image data via the front end of my site. I have a single entry for a page with an assets field powered gallery on it. The multiple images for the gallery are ...
1
vote
2answers
569 views

Does Assets allow you to use the built in Image Manipulations to resize on upload

I really want to use the built in Image Manipulations to allow the images to be resized at the time of upload to help remove some of the extra server stress on load in the templates using CE Image. ...
1
vote
1answer
906 views

Assets plugin not working at all

I have installed the Assets plugin but it is not working at all. It is installed on a linux server with php 5.3.17, Expression Engine 2.6.1 and Assets 2.1.4. I have set the correct upload directories ...
0
votes
1answer
106 views

How to allow access to Assets File Manager but no other modules

I want a member group of "Editors" to be able to use the Assets file manager directly but can't find a permissions combination that allows access to only Assets. You have to give them access to ...
2
votes
1answer
108 views

Assets is outputing strange file paths

When I link a file in a WYGWAM field, the link seems to be created correclty. If I look at the source of the HTML, the link is displayed as, <a href="/uploads/documents/campus_map.pdf">File</...
1
vote
1answer
75 views

Multi word url links bug in WYGWAM field

If I create a hyperlink from multiple words in a WYGWAM field it looks fine if I view the source code but when parsed in the browser it adds stuff to the link address causing it to fail. Example, I ...
1
vote
1answer
721 views

Assets Blank not Updating after migration

Migrated to a new server and my server path has changed. I changed the path in all the file upload preferences etc. but Pixel and Tonic Assets seems to want to hold on to the original path. If I ...
1
vote
0answers
17 views

Is there a way or add-0n to show an image or file is linked from an entry if a user tries to delete it?

A client wants to prevent an editor from renaming or deleting an asset/file/entry that is linked from anywhere on the site. I cannot find an add-on that does this. They are requesting a list that ...
0
votes
0answers
57 views

Sync process new image manipulations in child folders (for use with P&T Assets)

I'm finding CE Image is incredibly slow even with CE Cache and native caching, and so I'm keen to move over to use native image manipulations. However, because I use P&T Assets, my clients have ...
2
votes
1answer
117 views

Assets and Rackspace White screen on save

I am trying to add rackspace cloud files to assets, but when saving I get white screen. Any ideas why? EE 2.5.5 Assets 2.1.3 I have tried with amazon s3 , and private and public repos on both to ...
1
vote
2answers
1k views

Assets thumbnails not showing

Running ExpressionEngine V2.6.1 (20130506) and Assets 2.1.3 and whenever I upload images to Assets or have some already uploaded and try to view them either in Assets or WygWam (which I'm also using ...
1
vote
1answer
68 views

Assets doesn't refresh after deleting folder

When a new subfolder is created and deleted right after, the refresh button keeps spinning and the folder still appears in the list. This only happens when no files are uploaded into it. After a page ...
1
vote
1answer
52 views

Assets panel not loading when static html file is present in root

I have used Assets before and everything worked fine but on a fresh install of EE 2.6.1 and Assets 2.1.3 I have the following problem. I have a static index.html file whilst developing the new site. ...
0
votes
2answers
197 views

How do I access Assets field data within a child relationship in 2.6.1

I have a parent channel of "events" with a relationship field named {cf_event-map} with a singular relationship to an entry in a channel named "maps". This is the simplified code I'm using, the ...
2
votes
1answer
276 views

Parse order fun! Getting a stashed Assets image resized using CE Image inside a plugin parameter

Alright, let's see if I can explain this correctly: I am using Assets to store images to S3 CE Image is being used to manipulate the images and save/serve them from S3 I use stash to try and stay DRY ...
2
votes
1answer
184 views

Private URLs with Assets or Compatibility with Protected Links

Does anyone know if Assets, when used in combination with Amazon S3 to store files can create "signed URLs" when serving up files on the front-end? S3 provides a time limited signed URL option for ...
3
votes
1answer
197 views

Low Variables with Matrix and Assets

We've setup LV with a Matrix field, inside of which is an Assets field. When we submit the changes, these are written to the DB but when the page reloads, the Asset field is blank. It appears this ...
0
votes
0answers
102 views

Assets in Safecracker: File uploads twice

I'm successfully using the technique covered in this question: Simple HTML file field uploads with Assets and Safecracker <fieldset> <label for="event_url">URL</label> <...
0
votes
0answers
188 views

Assets not uploading files or building indexes.

I am working on a site that had assets installed and working. Then one of the other developers installed freeform and added .htaccess rules that removed the index.php and forced us to add www to the ...
0
votes
1answer
219 views

Stash Snippets not rendering within CE Cache for some content

This is a strange one, so I'll have to give a little history. To allow ad-hoc image galleries to be placed within the body content of pages on the site I'm using a matrix that holds "galleries" while ...
1
vote
1answer
323 views

Assets 2 Upgrade - No Images in Manager and No Uploading

I am running EE 2.6.1 and recently updated to Assets 2.1.3. In the EE file manager, all my files are visible and I can upload new ones. But the Assets file manager is blank and gives me an error when ...
0
votes
3answers
384 views

Assets Field within Structure Entries

I'm running into a problem with Assets & Structure Entries 1.3.4 & 1.2.8 — effectively it boils down to the fact that my Assets field only returns the filename, not the entire folder path. ...
1
vote
1answer
245 views

Assets File Upload issue

I have been having issues with the assets plugin in our new server and am having a hard time trying to debug. When using ee file manager I get the below error. ee: 2.6.1, assets: 2.1.3 A Database ...
1
vote
0answers
76 views

On entry save… redirecting tp front-end homepage

Currently have a channel entry that has amongst one of its fields a MATRIX to upload a series of images too. Now this is currently been populated using the MATRIX MULTI UPLOAD and for the most part is ...
3
votes
1answer
150 views

Assets in Wygwam only inserting {assets_X} on first save

So, similar to this question when using Assets in a Wygwam field I am having to re-save an entry to get the image to output on the frontend. When I check what is getting saved to the db I get {...
2
votes
3answers
130 views

Can P&T Assets read/use image EXIF data?

Seems like a no-brainer feature to have, specifically regarding the date and location properties of images. And yes, I know I can use VZ Exif, but for performance reasons, I'd prefer to have that ...
0
votes
1answer
64 views

Reordering Assets

Is there a way to reorder assets using the Assets plugin? I want to allow the client to upload a series of files and then choose which order to display them on the front end.
0
votes
1answer
39 views

P&T Assets field “loses” image when editing from some machines

An image is stored in a P&T Assets field and has been working fine. An editor emailed me saying when she opens an entry to edit it, the image is gone. I tried to edit entries and it worked fine. I ...
2
votes
1answer
556 views

Wygwam problem with Assets as file browser

Running EE 2.1.1 Wygwam 2.7.1 and Assets 2.1.3 In Wygwam modal settings, I select Assets as the File Browser and hit save. Go into a Editor Configuration and the Upload Directory does not have a ...
3
votes
0answers
118 views

Using Assets Wygwam, how can I pull in the caption for an image in the text editor?

I need the basic ability to load the caption from an image (assigned in Assets) into Wygwam. Is this possible?
1
vote
1answer
45 views

P&T Assets + Carthrob

Has anyone ever tried using P&T Assets as a field with Carthrob? More specifically, I'm looking to sell photos that are located on my Amazon S3 account. Do you think this will work?
2
votes
0answers
140 views

Assets throwing PHP error with BetterWorkflow

I'm using EE 2.6.1 Assets 2.1.3 BetterWorkflow 1.6.2.5 Matrix 2.5.5 I'm working with the BWF team too, but since their developer is out for the week, they recommended I also check here. I've ...
1
vote
1answer
139 views

Problems with Assets 2.1.3 when upgrading - throws db error

I'm trying to upgrade to version 2.1.3 of Assets but during the update process it throws the following error: A Database Error Occurred Error Number: 1265 Data truncated for column 'folder_id' at ...

1
3 4
5
6 7
9