Questions tagged [focus-lab-master-config]

These questions are centered around the multi-environment config setup crafted by Focus Lab, LLC.

Filter by
Sorted by
Tagged with
1
vote
1answer
51 views

Using FocusLab MasterConfig Upload Preferences

I'm using FocusLab MasterConfig to set my upload preferences but strangely only the name of the Upload preference gets set by my code. Here is the code in config.master.php $resources_folder = '...
1
vote
1answer
202 views

EE3 --> Multiple Concurrent Database Connections via config files

we converted to 3.3.3 from 2.5.5. a concurrent connection to a secondary database (set up using Focus Lab Master Config in both versions) works in 2.5.5 but i get warnings in 3.3.3 with message ...
1
vote
2answers
428 views

https and Control Panel mixed content error

I've got a site in SSL but when I visit the Control panel it is completely unstyled and looking in the inspector I see a mixed content error and js/css is being blocked. Not sure why this is ...
0
votes
1answer
188 views

Master Config on Mac with AMPPS

I installed EE 2.11.1 on Mac with AMPPS, and am trying to set up the Master Config from FocusLabs. Following the directions from here everything works fine until I copy/paste the contents of system/...
0
votes
1answer
176 views

Will Focus Lab EE Master Config work as-is on EE3?

I have used Focus Lab's EE Master Config on every EE2 site I've built, since I heard about it. Now I am working on a site in EE3, and wondering, will this setup work as-is for EE3, or will it require ...
0
votes
1answer
159 views

Focus Lab Master Config vs System Config

My base template path doesn't appear to be working, and I'm not quite sure what I should have in the system/../config.php file? (I started with a config.php file from another project that doesn't use ...
0
votes
1answer
116 views

Focus Lab's EE Master Config Error with MAMP

I'm getting the following error: Fatal error: Call to undefined method CI_Config::site_prefs() in ...Dev/cms/ee.dev/system/expressionengine/libraries/Core.php on line 122 My setup is as follows: ...
0
votes
0answers
71 views

Issue setting Low Variables file path with Focus Lab EE Master Config

I'm saving my Low Variables as files above web root in a directory named _vars and setting the file path in my Focus Lab EE Master Config file like this: $env_config['low_variables_save_as_files'] = '...
1
vote
0answers
35 views

Solspace User + Focuslab config member password reset link returns 404

EE 2.9.2 Solspace User 3.5.1 I've got a front-end member "forgot password" form on a site that uses Solspace User and Focuslab config and I'm removing index.php with .htaccess. My profile_trigger ...
1
vote
1answer
102 views

File Upload urls have //chroot added to the url

I'm using the FocusLab Master Config set up which may be relevant. I haven't had any issues previously like this however. I'm in the middle of migrating from Dev to a new live server and 90% of ...
1
vote
1answer
68 views

focuslab config - ip address for host not working

I've got the focuslab config set up and everything works fine on localhost. However my staging server it doesn't work. I've determined that it's likely due to using an ipaddress in the host for config....
3
votes
4answers
2k views

PHP Errors after OS X Upgrade

I got to work this morning and, after upgrading to Yosemite and MAMP Pro, I am getting a series of PHP Errors and cannot get access to to CP (returns blank page). The frontend of the site itself is ...
0
votes
2answers
804 views

MSM & Master Config

I'm trying to set up two sites in EE with MSM & Master Config. But I'm failing. Feels like I'm really close but can't get over the last hurdle. I've used this suggested method but it's not quite ...
1
vote
0answers
153 views

Focus Lab Config 403 Forbidden Error. Moving site from production to localhost

I'm very new to EE (coming from a Wordpress background). I'm trying to make changes to an existing site without editing the live site. So I'm trying move the live site to my localhost (I'm running ...
1
vote
1answer
378 views

Can't login to control panel (redirects back to login)

I'm having the same issue described here. I've tried the working solution but it hasn't worked for. In config.local.php I have $env_config['cookie_domain'] = 'buckley.dev'; and I am still unable to ...
0
votes
1answer
391 views

Trying to set up dev / staging environment for EE on Nexcess hosting

So, as a precursor - I'm new to using Git and the FocusLab Master Config and having a few issues getting set up. I'm using a Nexcess shared EEP-100 account. If I follow everyone's advice on ...
0
votes
2answers
86 views

Multi-Evironment config bootstrap above webroot on a single server

I'm working on a project that only has one server to work with. That means the production and development server are the same and development is a sub domain (dev.example.com). In the past when I've ...
2
votes
3answers
121 views

Modifying Focus Labs Config to allow setting site on or off from environment cases

I'm using Focus Labs Config and trying to give the is_system_on setting the same treatment as the debugging preference. So far, in config.master.php I have added; $env_config['is_system_on'] ...
1
vote
2answers
160 views

Focuslab Multi Environment Config upload preferences issue

I'm having an issue with my upload directories. I converted an existing site to use the FocusLab config set up and everything is working fine. However I've just noticed that in the CP thumbnails are ...
0
votes
2answers
176 views

Focuslab Master Config not working with MAMP

I have recently set up an ExpressionEngine 'Sandbox' test site locally via MAMP (On Mac OSX), and have integrated the Focus Lab LLC’s EE Master Config for when I push the local Sandbox site code to a ...
0
votes
2answers
117 views

Focuslab Master Config staging server not working

I'm 100% this is user error on my part. I'm using the focuslab master config set up to run locally, staging and live. The site works correctly on live and locally but staging I keep getting a ...
1
vote
4answers
149 views

Links created with Structure tags point to wrong environment after DB import from another environment

When I export my DB from one environment to another, all links created with {structure:page_url_for:{entry_id}} format try to load the environment URL path from the database I imported from another ...
0
votes
1answer
91 views

Master config produces Blank Screen

Same Issue as Master config – blank screen I've also been having the exact same issues. I'm trying to run the files in a folder such as webaddress.com/staging/site_name. I add this address to the ...
0
votes
1answer
88 views

Can I specify external upload locations in Assets with MSM via configuration file?

I am working on a ExpressionEngine site with a lot of preexisting content in many MSM sites. Due to the need to put upload files into Amazon's S3 storage service, I am migrating all of file fields and ...
4
votes
1answer
354 views

Master config – blank screen

I am using FL master config and works a treat (brilliant) on local (MAMP) but when uploading/accessing the dev server just a blank screen appears and also the same for the system login (so can't turn ...
2
votes
1answer
237 views

File structure for a staging site is different from production

On my current project the production site has the following folder structure: --system --config --public_html -assets -index.php -admin.php -etc. But, the staging site I need to create is ...
7
votes
1answer
1k views

Setting up Git version control for a multi-environment workflow

I've got a live EE site and I need to put it under version control using multi-environment config settings. My goal is to set a git workflow, so these would be the steps I believe are right for my ...
0
votes
1answer
198 views

Focus Labs Master Config $env_global not working

I'm having the same issue as described below, however can't find a solution: Using Focus Lab's Master Config, I've set a test global variable for production, like so: $env_global['...
2
votes
1answer
115 views

path constant works locally, doesn't on dev

Using Focus Lab Master Config, I've defined these constants for my dev environment: define('ENV', 'dev'); define('ENV_FULL', 'Development'); define('ENV_DEBUG', TRUE); define('ENV_BASE_PATH', '/home/...
3
votes
1answer
730 views

Focus Lab's EE Master Config under webroot

What Focus Lab’s EE Master Config modifications are required for /config/config.master.php to work under webroot? The instructions provided on their github page are for placement above webroot, with ...
2
votes
1answer
515 views

git , bitbucket and multi environment (subdomain > same server)

So, this is my actual workflow: With my IDE (Webstorm or Aptana, I'm on windows) I create a project and I synchronize remotely via (s)ftp I then create a git repository and push it on bitbucket ...
1
vote
1answer
398 views

Using Master Config

I am using this Master Config, http://eeinsider.com/articles/multi-server-setup-for-ee-2 Problem is my site now shows a server error. Here is a pastie of my master config file. http://pastebin.com/...
0
votes
1answer
572 views

$system_path for EE setup in subdirectory

I need to move an EE install into a subdirectory. The site currently has the system folder above web root and uses focus lab's dynamic config setup. My desired setup would this: --system --config --...
3
votes
1answer
233 views

Problem with pagination

I'm struggling with an issue with pagination on one of our sites... We are running a multi-language site (English & French). We are using the standard method of having folders at web root (ie. en,...
2
votes
1answer
86 views

Database error when www prefix is used

I am using a version of the Focus Labs Master Config setup and I am getting a database error when using the www. prefix in front of the URL. This is a problem that I haven't run into before. Anyone ...
0
votes
0answers
174 views

Assets: Uploaded File Doesn't Display in File Browser

I'm running Assets 2.0.5 on EE 2.5.5 with MSM and FocusLab Master Config. When I click "Upload", select a file from my computer, and click "OK", the Assets progress bar moves across the screen, but ...
1
vote
1answer
514 views

Using site_id or site_name Inside Master Config Environment Files

I'm engaged in the Herculean task of configuring Focus Lab Master Config with an MSM site. I'm trying to write some conditionals based on the site_id variable, but I keep getting errors. Right now I'...
2
votes
1answer
245 views

Assets 2 on MSM: Tags have no output on second site

I'm branching this off of another question: Assets 2 MSM Cannot Upload or view images I'm not seeing any tag output from Assets in the second site. I'm running EE 2.5.5 with Assets 2.0.5. This is a ...
2
votes
1answer
3k views

Set “site_url” Config Variable in index.php

I'm upgrading a multi-language site from EE1 to EE2, and it's using the technique of duplicating index.php and path.php inside subdirectories named for each language, and defining global language ...
0
votes
1answer
96 views

MasterConfig seems to retain reference to Republic Variables somewhere

I just performed a clean install of EE onto a local virtual host, and having checked the installation by successfully logging into the CP, followed that up by bringing into play the MasterConfig files....
2
votes
2answers
125 views

Focus Lab Bootstrap config for sub directory?

Ok, I have been using the Focus Lab Bootstrap for a while and its awesome. But I have come across a new problem when trying to use a testing URL that isn't a standard domain/sub.domain. How would I ...
1
vote
2answers
233 views

Additional mime types in Focus Lab config - how to add?

Is it possible to add additional mime types to the $mimes array (/system/expressionengine/config/mimes.php) from the config.master.php when using the Focus Lab config setup? I really don't want to ...
0
votes
1answer
189 views

Double up of Assets File Upload preferences within Assets addon

We've just updated to the latest version of Assets v2.0.4 and have noticed that there's two of every upload preference displaying in the side column. We're using the Focus Lab Config for this site and ...
4
votes
1answer
73 views

Accessing Master Config environment names within templates

I'm using Focus Lab's brilliant Master Config https://github.com/focuslabllc/ee-master-config but wondered if it is possible to use the ENV constant in a template? Something like this? {if ENV == '...
2
votes
1answer
472 views

Focus Lab Config (bootstrap) working with MSM - still problems

OK, first question on SE so bear with me. I'm trying to setup an older site (after going through the EE2 upgrade process) on a virtual private server the client has running WHM and cPanel. The sites ...
4
votes
5answers
218 views

Password Protect Development Environment Only?

I'm developing a site with Git and Master Config, and up until yesterday I was forcing users to log-in to view the site on the development server with this code in my document head template: {if ...
7
votes
1answer
593 views

Difference between assign_to_config and config (and or env_config)

I'm using EE Master Config along with Stash. I know in Master Config that all the configs have been changed from $config[''] to $env_config[''] I noticed with Stash that Mark is using this format: $...
4
votes
2answers
526 views

Site and theme URLs not correct in control panel settings

When I load Site > CP Home > General Configuration I see the right values in the field: http://www.example.com for an instant. When the page fully loads it will change to http://dev.example.com. The ...
3
votes
2answers
198 views

Why wouldn't global variable parse correctly with Master Config?

Using Focus Lab's Master Config, I've set a test global variable for production, like so: $env_global['global_test'] = 'test'; Then in an embedded template I've dropped in {global_test}. Also tried ...
4
votes
2answers
2k views

500 internal server error using Master Config

I've been using Focus Lab's Master Config for most of this year and have never run into this issue before. So here's what's happening, going to the domain (example: mysite.com/index.php or mysite....