Questions tagged [focus-lab-master-config]

These questions are centered around the multi-environment config setup crafted by Focus Lab, LLC.

Filter by
Sorted by
Tagged with
11
votes
9answers
2k views

White Screen of Death in CP After Login

I just migrated a site from the development server on MediaTemple (gs) to the production server on EngineHosting (shared). The front-end of the site displays fine (except some random images aren't ...
4
votes
1answer
363 views

Master config – blank screen

I am using FL master config and works a treat (brilliant) on local (MAMP) but when uploading/accessing the dev server just a blank screen appears and also the same for the system login (so can't turn ...
3
votes
2answers
200 views

Why wouldn't global variable parse correctly with Master Config?

Using Focus Lab's Master Config, I've set a test global variable for production, like so: $env_global['global_test'] = 'test'; Then in an embedded template I've dropped in {global_test}. Also tried ...
4
votes
1answer
760 views

Focus Lab's EE Master Config under webroot

What Focus Lab’s EE Master Config modifications are required for /config/config.master.php to work within webroot (eg. public_html or htdocs), if I cannot place it above webroot? The instructions ...
2
votes
1answer
256 views

File structure for a staging site is different from production

On my current project the production site has the following folder structure: --system --config --public_html -assets -index.php -admin.php -etc. But, the staging site I need to create is ...
7
votes
1answer
1k views

Setting up Git version control for a multi-environment workflow

I've got a live EE site and I need to put it under version control using multi-environment config settings. My goal is to set a git workflow, so these would be the steps I believe are right for my ...
3
votes
1answer
236 views

Problem with pagination

I'm struggling with an issue with pagination on one of our sites... We are running a multi-language site (English & French). We are using the standard method of having folders at web root (ie. en,...
2
votes
1answer
249 views

Assets 2 on MSM: Tags have no output on second site

I'm branching this off of another question: Assets 2 MSM Cannot Upload or view images I'm not seeing any tag output from Assets in the second site. I'm running EE 2.5.5 with Assets 2.0.5. This is a ...
1
vote
0answers
158 views

Focus Lab Config 403 Forbidden Error. Moving site from production to localhost

I'm very new to EE (coming from a Wordpress background). I'm trying to make changes to an existing site without editing the live site. So I'm trying move the live site to my localhost (I'm running ...
1
vote
4answers
151 views

Links created with Structure tags point to wrong environment after DB import from another environment

When I export my DB from one environment to another, all links created with {structure:page_url_for:{entry_id}} format try to load the environment URL path from the database I imported from another ...
0
votes
1answer
175 views

Focus Lab Master Config vs System Config

My base template path doesn't appear to be working, and I'm not quite sure what I should have in the system/../config.php file? (I started with a config.php file from another project that doesn't use ...