Questions tagged [iis]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
2answers
164 views

Any concerns running ExpressionEngine on an IIS server?

I want to setup EE on an IIS server what should I be aware of before proceeding? Never having developed a site running on a server using IIS I am hesitant. Based on initial searches I see that I can ...
0
votes
0answers
86 views

500 Error on IIS front end

this is the error page I can see the backend (I mean the Expression Engine control panel works perfect) but the front (the web site show a 500 error). I add this to the web.config and now the 500 ...
0
votes
2answers
580 views

remove index.php on Windows 2012 iis 8 using URL Rewrite

I have the latest version of EE installed on a Windows 2012 Server with the URL Rewrite module installed. I'm migrating over to this server from an older apache installation that used Mod Rewrite ...
0
votes
0answers
435 views

random 404 errors on existing files

this may not be due to EE, but my site runs on EE so I want to ask. We are randomly getting css and js files returning a 404 error. They exist, and a refresh loads them properly but it's hardly a ...
0
votes
1answer
62 views

Issues with EE On IIS with Directories

I moved my IIS site from a hosted server (Apache) to IIS. In doing so I Made the normal IIS install, installed PHp and mysql Copied all the files to wwwroot Added the database. Now what happens is ...
1
vote
1answer
164 views

Admin control panel access behind firewall

The company is extremely concerned with security. There is a lot of sensitive data on the servers and this is understandable. What I struggle with is getting many of the addons to operate properly, as ...
0
votes
1answer
74 views

IIS Errors and Apache Errors with ExpressionEngine

I have been having issues with setups on IIS NOT returning any informative errors what-so-ever. It seems that everything that happens just triggers a 500 Server Error, which is about as helpful as a ...
1
vote
1answer
100 views

MSM delete site 500 error if it has entries

EE v2.7.2 Build Date: 20131008 MSM 2.1.6 When I try to delete a site from MSM, I get a 500 Server error. However, if I manually delete everything, then delete the site, it works. I have tested all ...
1
vote
1answer
363 views

Why am I getting a “duplicate page uri” error when leaving the field blank?

Running EE on windows server and I get the "duplicate page uri" error when editing any entry. I don't want these as pages, but I can't save without creating a unique page url for them...
0
votes
1answer
62 views

Channel Images and IIS paths

I'm trying to use channel images on a Windows server, but channel images uses a '/' for the paths on the actions instead of letting me use ' \'. Anyone have a fix for this?
1
vote
1answer
142 views

Development (Local) with multiple sites using host file and IIS7 - Can't get FCPATH to recognize - Encoded characters

I am stuck again using IIS7 on a windows server. Trying to replicate the production environment for some testing on a Win7 box using IIS7 and host file to point o the sites. I have tried using ...
4
votes
1answer
486 views

Running an EE site on IIS. What are the “gotchas”?

I may be taking on a project for a large EE site that would most likely be running on IIS. Although I have some very minor experience of IIS I have never run PHP on it let alone an EE site. I don't ...