Questions tagged [low-variables]

A commercial add-on providing an alternative to native Snippets and Global variables.

Filter by
Sorted by
Tagged with
30
votes
5answers
2k views

What is parse order and how does it affect how my template is coded/rendered?

What exactly is parse order and how does it impact my template code and whether I should use embedded templates, global variables, snippets, low variables, stash or any other method that I may not ...
4
votes
3answers
595 views

How to use Playa in Low Variables?

Given a Playa field in Low Variables called widgets, how would I output the title of each widget? Below is what I'd expect, but it outputs nothing. {exp:low_variables:parse var="widgets"} ...
3
votes
1answer
171 views

Low variable as channel entry_id parameter across MSM sites

I'm trying to access the entry_id of an entry (one only) selected with Low Variables, to use as a parameter in a channel entries tag. The entries are stored in site A. The template is in site B. ...
3
votes
1answer
246 views

PHP error when using Low Variables with Grid and Assets

I created a Low Variable, using a Grid field. One of the Grid columns is an Assets field. It actually all works as supposed to. Except that I get an annoying PHP notice: Severity: Notice Message: ...
4
votes
1answer
1k views

How do I get the full Assets URL from Low Variables?

I'm having trouble getting the full URL to an image using Low Variables and Assets. Using the short name of the variable just returns the file name without the rest of the path. {lv_my_image} renders ...
4
votes
1answer
570 views

Playa and Low Variables for Featured section of Home page

I am trying to use Low Variables, Playa, and a "Features" channel to allow me to select which (3-4) features will be displayed on the Home page. The intent is that either a News, Project, or (...
3
votes
1answer
382 views

Assets field inside of a grid inside of a low variable — Asset not saving

Having an issue with a low variable of the "Grid" persuasion. I have an assets field inside the grid, and I can upload and add the asset just fine, but when I save the Low Variable, the CP never shows ...
3
votes
1answer
195 views

Low Variables with Matrix and Assets

We've setup LV with a Matrix field, inside of which is an Assets field. When we submit the changes, these are written to the DB but when the page reloads, the Asset field is blank. It appears this ...
3
votes
1answer
259 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
0
votes
1answer
197 views

Playa in a Low Variable and Stash

Ok so I am using a Stash embed / view model approach. I have a custom filed Playa with specific articles for a product. I also have a Low Variable storing a playa of related articles for a category. ...