Questions tagged [parsing]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
42 views

CE Image, variable not parsed inside src image

I tried to insert a custom field variable, Stash here, a simple custom field as a text field works fine (the value is parsed), but when I use a pair tag (as Fluid, Grid or another add-on), or a Stash ...
1
vote
0answers
77 views

Parse template and get content with PHP

I developed an extension for EE2 much earlier for parsing template to send the content to an email address. Now I am porting it for EE3 and facing problem that instead of returning parsed template ...
0
votes
1answer
49 views

{stash:embed name=“test”} vs {exp:stash:embed name=“test”}

I had a parsing problem with: {stash:embed name="test"} It was not parsing. Reading many posts I read about: {exp:stash:embed name="test"} And it's parsing fine. What are the difference between ...
0
votes
2answers
549 views

Undefined Offset error in ExpressionEngine Parser.php line 52

Using EE 3.1.4 Everything worked fine, until I changed the relationship selection to a new one. When I did that, it gave me the error. Now, even if I select the previously related field, I get the ...
1
vote
0answers
56 views

404 not rendering correctly when using template layouts

I'm finding in EE 2.10.1 that if I try to check for the presence of a valid category in a URL using Low Seg2Cat and then perform a redirect on error that when the 404 template is rendered it inherits ...
0
votes
1answer
97 views

Low Variables parsing grid

I'm using Low Variables. This specific variable is of the type 'Grid'. What I'm having in my template is this: <select name="country" id="country" class="form-control"> {exp:low_variables:...
0
votes
2answers
223 views

parsing decoded JSON array to template

I made my first plugin I don't deal allot with variable and parsing. it was a JSON data to pars to a template. the problem is when I decode the JSON to an array Then I use parse the variables to the ...
1
vote
1answer
39 views

NavEE selected_class=“on” becomes class=“yes” - possible to solve w/o updating styling?

I assume due to some bug in the parser, {exp:navee:nav nav_title="header" selected_class="on"} Outputs <ul> <li class="yes"><a href="/foo">Foo</a></li> <li&...
1
vote
0answers
65 views

Playa fields not parsing tags

after moving my site from one production environment to another, Im getting strange results in a Playa field. the tags are not being parsed, but values have been set. what causes this sort of ...
0
votes
2answers
31 views

Parse Order: how to pass a value from PI as an embed variable?

I have a plugin that outputs a value, which I think I need to pass as an embed variable as I need to use that value as a parameter when calling the plugin again from within the embed. Here's the basic ...
0
votes
2answers
66 views

Early Parsing with Low Variables and Member Export

I am using the Add-On ajw_export and Low Variables to export a csv of member details. When the page loads the member data is exported on page load. I would like to use Low Variables for early parsing,...
0
votes
1answer
23 views

Template group parsing index file even when not called

I'm experiencing some strange behavior with one of my template groups. There are two templates in the group, index and award. When loading the award template I am seeing content from the index file ...
0
votes
1answer
689 views

Send email from EE template with file get contents

I’m creating a custom ext. that handles form submission + email sending. When a form or reservation has been made the data is put in EE and 2 emails are being send. One email to the client and one to ...
1
vote
1answer
248 views

Formatting custom date fields within channel entries row hook

In Shortlist the {exp:shortlist:view} tag extends the channel->entries() method for it's parsing needs. This works and allows for full custom tag parsing without much extra effort, but runs into ...
1
vote
1answer
55 views

Parse isue with REST addon

Yet another parse order problem! I'm trying to use http://devot-ee.com/add-ons/rest. This works: {exp:rest url="/api/get-default-profile-image/175/" format="json"} {default_profile_image} {/exp:...
0
votes
1answer
33 views

Trying to use low_replace inside an EE Multi Select field

I have a channel for scholarships with a a Multi Select field with a list of schools. Each scholarship is available to certain schools, so I want to create a div with a class for each school, so I can ...
0
votes
1answer
88 views

channel:entries and segment with Low Variables

This is my Low Variable var="lv_article": {exp:channel:entries limit="1" channel="{segment_1}"} <h1 class="title">{title}</h1> {/exp:channel:entries} When it's ...
2
votes
2answers
122 views

segment begins with?

Is there a way, WITHOUT PHP, to test if a segment begins with a value? We send emails with shortened URLs and want to be able to parse the segments accordingly. i.e. http://www.oursite.com/...
2
votes
2answers
59 views

“{if item == … ” not parsing

{exp:channel:entries channel="games" limit="1" dynamic="yes"} {game_platforms} {if item == "PS3"}test{/if} <span>{item}</span> {/game_platforms} {/exp:channel:entries} I set ...
6
votes
2answers
118 views

Is there a way to disable BBCode parsing in Channel Entries?

I have several articles that contain "[I]" as part of a quote. EE sees this as BBcode and renders the entire remainder of the entry as italic text (because there is no corresponding closing tag). The ...
1
vote
2answers
202 views

CE Image with Low Variables and Lazy Load: What im doing worng?

what im doing wrong? Im trying load a image via Assets, in a Low Variable field. Nothing is rendered, but Low Variables field is with "early parsing" enabled. The Lazy Load JQuery plugin is active. {...
4
votes
1answer
286 views

TMPL->parse_variables_row() not available in model?

I have a model (core_model.php) with lots of functions in there, however having an issue with the following one in specific : Class core_model { function __construct(){ $this->EE =&...
1
vote
1answer
141 views

XMLHttpRequest 200 OK but returning a Snippet instead of the appropriate XML

We've been having some trouble with getting XML from our server. It returns 200 STATUS OK but, like the title notes, it's not returning the XML that we pointed it to but instead is giving back a ...
4
votes
1answer
78 views

Why is the word “random” treated differently in the template parser?

We are experiencing some PHP errors due to a "too large" regular expression that is taking place during template parsing in Template.php. We noticed it was only occurring on templates that load an ...
1
vote
1answer
53 views

Backslashes added to templates, login not working

About a week ago, one of our sites started acting very strangely. For some reason, ExpressionEngine has started adding backslashes to all the quotes in the templates. For example: <section id=\"...
2
votes
1answer
279 views

Process plugins/modules tags inside another module

I'm working on a module function where it will take the tagdata and send it through email. The tagdata can contain anything from simple strings to plugin or module tags. I can't seems to find the ...
0
votes
1answer
87 views

EE1 Site Not Parsing Custom Fields Locally

I've just finished the local setup of a site running EE 1.7.1. I have one issue... custom fields inside the exp:weblog:entries tag are not parsing at all. The title does show correctly. I've check ...
4
votes
2answers
1k views

{filedir_X} tag not parsing in File field

I have a link to an uploaded PDF in my template but some of links seem to output a mystery {filedir_3} instead of the path to the upload folder. So the following template code... {if ...
2
votes
1answer
134 views

Low Variable as email address for Freeform

I'm wanting to use a Freeform across multiple MSM sites, using a low variable to change the admin notifier for each site. Currently the code is as follows:- {exp:freeform:composer inline_errors="yes"...
3
votes
1answer
226 views

How to create module tag output 'sub-loop'

I'm trying to do something like the following: {exp:my_tag my-param2="1" my-param2="2"} <li>{title}</li> <li><ul> {my_fields} <li>{field_label}: {...
5
votes
4answers
748 views

EE Code within channel entries

Is it at all possible to have a text input or area field in which we could enter EE code to be processed by the template. For example, if we could have a text area called "Advanced Functionality" and ...
3
votes
1answer
220 views

How to parse EE tag in Forums template?

EE tag in Forum template What I need is to use my custom EE plugin in to Forum header template: themes/forum_themes/default/forum_global/html_header.html I see that Forum template are processed by ...