Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Pixel & Tonic provide some of the worlds most popular ExpressionEngine Add-ons.

0
votes
0answers
9 views

Boolean for Fieldpack Checkboxes

I’m trying to get some data (it's a catalog of AV equipment in each room we support) out of an EE site that uses a Fieldpack Checkbox. I’d like to output a CSV file with a row for each EE entry that ...
0
votes
0answers
32 views

Assets field inside grid inside fluid

I’m having an issue where I'm using Assets (EEharbor) inside a EE Grid, inside an EE Fluid field. I think I have the tags correctly set up, it’s outputting the correct number of results (files) from ...
1
vote
2answers
45 views

How can I add an ampersand (or similar) following all but the final entry in a Matrix loop?

I have a series of entries coming from a Matrix field on a page. If there is more than one entry I would like a "+" to follow each entry, except for the final entry. I've tried using backspace, but ...
1
vote
2answers
71 views

Playa broken in MySQL > 5.7.4

Since v5.7.5 MySQL returns errors for certain badly formed SQL statements. As such Playa v4.5.2 will throw errors.
0
votes
1answer
27 views

Wygwam - Applying style to Unordered List

How can I apply a style in Wygwam editor so that the following code <ul> <li>Here's bullet point number one</li> </ul> Changes to this <ul data-bullet="ti-arrow-...
4
votes
1answer
350 views

Assets errors with MySQL 5.7.X

I've started having issues with old EE sites on my development machine now that I'm running newer versions of PHP and MySQL. I've been able to sort most of these out except for the following MySQL ...
1
vote
2answers
57 views

Limit S3 Upload Size in P&T Assets?

I'm having a problem where my client keeps uploading 6MB 300PPI images and crashes the server when CE Image tries to process them. So I figured I could just go into Assets and limit the upload size ...
1
vote
1answer
40 views

Display only unique values from a Matrix column

Am trying to display only unique values from a matrix column Is it possible with using the Query module?
0
votes
0answers
38 views

Matrix 2.6.1 not working with EE revisions

We have an older version of EE (2.5.1) and Matrix was not saving standard EE revisions of an entry. The field was upgraded to the latest (2.6.1), but it's still not saving any revised data. This is ...
0
votes
1answer
43 views

Help! Unable to save Assets entries in Grid

Unable to save Assets entries in GridI'm using Assets 2.6 on EE 2.10.2 running with Publisher 1.6.8 I'm able to define Assets fields within Grid fields. The resulting Asset Fields work insofar as ...
0
votes
1answer
149 views

Assets - Strict Standards Error

I have a error on the back-end of my clients site relating with assets which I urgently need to resolve somehow. It is using Assets 2.4 and EE 2.7.1 Strict Standards: Static function ...
0
votes
1answer
89 views

P&T Asset and Google Cloud Storage

I've created a Google Cloud Storage Bucket and enabled what I believe to be the right place for the Secret and Access ID - however, I'm getting the following error whenever I try to save and the ...
0
votes
1answer
146 views

WYGWAM 4 is throwing PHP and Fatal errors on 2.10.3

Today I updated an old site from 2.2.1 to 2.10.3. I attempted to update some Add-Ons but ran into an issue with Wygwam. I downloaded Wygwam 4 from Devotee. Follow the update instructions but ran into ...
0
votes
1answer
155 views

Assets for ExpressionEngine 3.x

Will Assets be updated to work with EE 3.x? We're developing a website for a client that will be load balanced and using S3 for files and would like to use Assets for the S3 integration, however, the ...
2
votes
2answers
171 views

Assets in Grid In Low Variables - multiple files

EE 2.10.1 Lv 2.6.1 Assets 2.6 I've got a Low Variables grid with a once cell Assets and in the assets you can upload multiple images. Using this thread I was able to successfully display a single ...
1
vote
1answer
69 views

Missing thumbnails in Assets

Images were working in EE's native File Manager, but were blank in Assets. I checked all the usual suspects, reindexed them with native EE File Manager and Assets, but the problem persisted. Andris at ...
0
votes
0answers
32 views

WYGWAM. window size click with no scroll

I am using WYGWAM 3.3.3 and EE 2.9.3 I have my WYGWAM set to 400pixels resizable. When I have a long entry when the edit page loads there is a scroll bar in the WYGWAM editor, but as soon as I click ...
3
votes
0answers
45 views

Unable to delete only existing row in Matrix field with required columns in Channel Form

I'm using a channel form with inline errors containing matrix fields in EE 2.10.1 with Matrix 2.6.1 The matrix fields are set to have no rows initially & they have some required columns, but the ...
0
votes
1answer
48 views

Force cache update Wygwam / Change timestamp

I was finally able to update Wygwam to the latest version (3.3.3). One user has contacted me to tell me he only saw gray fields instead of the normal Wygwam fields. I told him to empty his brower's ...
0
votes
1answer
77 views

Can Assets rename files on upload?

I have client who is uploading files with lots of naming issues; Spaces, dots, parenthesis, and other characters in the filenames. Is it possible to strip out the special characters, automatically, ...
0
votes
0answers
68 views

Some Assets images missing from matrix fields after upgrade

Upgraded from 2.5.2 to 2.10.1 and now some of the Assets stored images are missing from Matrix fields in some entries (The rows are blank with just a caption left behind and the 'Add file' button. I ...
0
votes
2answers
162 views

Wygwam / ckeditor errors on upgrade

I upgraded Wygwam 2.7.0 to 3.3.3. I run module update and I cleared my browser's cache. I am getting the next errors: Uncaught SyntaxError: Unexpected token ILLEGAL (ckeditor.js) config.js:10 ...
1
vote
1answer
133 views

Assets: Cannot upload file using “simple file input” method

I have an assets field called "member_thumbnail" on my "members" channel (created by zoo visitor). When I make a channel:form edit form or the equivalent edit form from zoo visitor, I am able to ...
0
votes
1answer
70 views

Wygwam not loading

Updated EE v2.10.1 and using Wygwam v3.3.3 I have it set to initialize on click, and can see the field and all the content correctly. Clicking on the field makes it completely disappear. Doesn't ...
0
votes
1answer
53 views

DB Error after Playa upgrade in EE2.10

I had an error after upgrading and fixed is as suggested in right here. In this thread, the issue seems fixed, but for me, not just yet. Now I've got a similar, but not the same, error: Error Number:...
0
votes
1answer
105 views

Field Pack List in a Channel Form

Using a Field Pack List fieldtype in a channel form fails due to the need to hit enter to add a new line per list item. How does one prevent the entire form from submitting when a user hits enter?
0
votes
0answers
41 views

Assets - Channel Form - Renaming files upon upload throwing error

I am using an Assets field for a single file upload to Amazon S3 in a Channel Form, with the simple form input code: <input type="file" name="comment_attachment"> <input type="hidden" name="...
0
votes
1answer
105 views

Import data into EE database in a module - matrix error

I am importing data from another site via a module i am building. The channel I am importing to has a matrix field. I am doing this like so: ee()->load->library('api'); ee()->api-&...
0
votes
1answer
68 views

Using Low Variables & P&T Pill in a Conditional

Having a bit of a weird problem happening with P&T pill field inside Low Variables. When I used this code: {if "{lv_metasocial_meta_title_display}" == "title_site_name"} | {lv_general_site_name}{...
1
vote
0answers
52 views

Customizing Wygwam & CKEditor to prefill width & height attributes

For the latest version of Wygwam, is there a way to: When an image is added, prevent the image dialog from automatically filling the width/height of the chosen image's dimensions Instead, prefill ...
0
votes
1answer
41 views

Not able to add matrix rows after 99 rows

I am not able to add more than 99 rows in my matrix field though I have already set Maximum rows to 1000, not sure whats happening. Is it a BUG or LIMIT of matrix field type? EE version : 2.6.1 ...
0
votes
2answers
125 views

ExpressionEngine Matrix :total_rows doesn't work when no rows

Matrix 2.5 and 2.6 on ExpressionEngine 2.7.3. The :total_rows property doesn't work when there are no rows. It works fine when there are rows. Below isn't actual code, but it's showing the gist. {...
0
votes
1answer
68 views

Weird URLs for images from Assets

I'm troubleshooting a problem with an older, rarely updated site, so I'm not sure how recently this issue cropped up, though I'm fairly certain it worked when I handed it off. We have a Low Variable ...
1
vote
2answers
65 views

Working with staging server and production server - can they share the same Assets locations?

I have 3 installations of my website: beta, demo, and production. Template and functionality changes are made on beta, content is entered on demo and everything moves to production as it is approved. ...
0
votes
1answer
102 views

Matrix & EE 2.9.2 SQL Error

I am using version 2.9.2 EE and Matrix 2.6.1 (both the latest versions of each software). Each time I try to publish a channel entry that has a Matrix fieldtype I am getting the following error ...
0
votes
2answers
37 views

Matrix and Solspace Importer issue with saving properly

I'm not sure which plugin is at fault here, but here goes. Using the latest version of all plugins, and EE. I have an Importer task to create entries, from a feed of about 20. One field in this feed ...
1
vote
1answer
154 views

Assets and Low Variables not compatible?

When I add an assets field to a Low Variable, it reports that it's added it correctly, however I then get a fatal error whenever I try to load the LV dashboard: Unable to load the requested file: ...
2
votes
1answer
38 views

Pixelandtonic Assets: Set Content-disposition?

Long story short: in Chrome, some PDF files stored in our S3 bucket (uploaded via Assets) hang up on download. Chrome just sits there, never downloading the file. (However, right-clicking the link ...
1
vote
0answers
58 views

Assets + multiple files + file manipulations: offset not working

I've got a grid field (slides) that contains 2 Data Types: Text Input - field name: text Assets (multiple selections allowed.) - field name: img The Assets folder that has been selected has a image ...
0
votes
0answers
30 views

Database Error when upgrading Playa

I've been performing an ExpressionEngine upgrade from v2.5 to 2.9.2. Everything seems to be going well except for the db error I get when upgrading playa. Playa appears to be working, but I get the ...
2
votes
1answer
53 views

{filedir_X} variable for Assets S3?

Is there an Assets variable like {filedir_X} that will output the S3 server path? I'm moving my images to S3 and I have referenced images in several channel entries in a textarea like <img src="{...
0
votes
2answers
36 views

Assets orderby Title

I can't seem to be able to sort Asset files by their title, instead only by their filename through orderby="name". Is it possible to use the Title field for ordering?
2
votes
1answer
98 views

Selective parsing of matrix rows

I am using matrix to pull instagram photos using the pic puller plugin. Sometimes, the picture is not available. I am able to skip these by using an if conditional in the pic puller loop. however an ...
0
votes
1answer
386 views

Channel Form: Why is Wygwam/CKFinder disabling the file browser for security reasons?

EE 2.9.2 - WYGWAM 3.3.3 In a Channel Form, I am getting the error... "The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder ...
0
votes
3answers
140 views

Add an ID to radio button within Channel Form

I need to add an ID attribute to a PT Checkbox within Channel Form so I can target it with JS. Any idea how I can do this? The standard usage for Channel Form is '{field:my_radio_button}' which ...
0
votes
2answers
85 views

P&T Assets not functioning correctly after migrating to new server environment

After moving my site to a staging environment I'm no longer able to view any images within the Assets portion of the CP or upload files to any Assets related fields. I'm also unable to update the ...
1
vote
2answers
82 views

Playa not playing with Zurb Foundation css

I'm getting a conflict when using Playa with Zurb Foundation. I have the playa field in a exp:channel:form tag and it works fine in the current site, which doesn't use foundation, but in the ...
2
votes
1answer
225 views

Bring Matrix Data Editing to the Front-End using Channel Form

I am trying to create a form - FRONT END USER (channel form tag) - that uses a wizard (which is working) and in one panel it allows the user to fill in fields then duplicate the fieldset to add ...
1
vote
2answers
43 views

How do I link 2 css files in 1 wygwam entry? is that possible?

I'm using wygwam as a page building field and have a webpage built on dreamweaver attached to 2 css which are the main css and overlay tab panel css. I saw Wygwam Template links from p&t which I ...
0
votes
2answers
107 views

WYGWAM failing to initialize … one just one entry

I’m running into something that isn’t making sense to me … I have a client that has created this page: http://teamthroughmywindow.org/about-our-project/faqs The questions and answers are all anchor ...