Skip to main content

Questions tagged [pixelandtonic]

Pixel & Tonic provide some of the worlds most popular ExpressionEngine Add-ons.

Filter by
Sorted by
Tagged with
6 votes
1 answer
658 views

Assets in Wygwam not displaying on front end in EE 2.6/Assets 2.1.1/Wygwam 2.7.1

Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively. I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {...
Rob Sanchez's user avatar
  • 4,002
5 votes
2 answers
1k views

Site failing after update to Playa 4.4.2

I'm in the process of updating my local and staging-environments to EE2.6. I've just updated Matrix, Wygwam and Playa to their latest (EE2.6 compatible) versions, and I'm now getting these errors on ...
Steven's user avatar
  • 753
4 votes
2 answers
342 views

Cause of Massive Performance Issues after EE Upgrade 2.5.2 to 2.7.2?

Newest Edit - 27 Feb 2014 - In case some poor soul with the same issue stumbles on this thread, I did not find a solution and ended up removing Matrix and replacing it with Grid. My company would ...
enga's user avatar
  • 236
2 votes
2 answers
324 views

P&T Dropdown and Checkboxes with Channel forms

I have been trying to get P&T's Dropdown as well as Checkboxes to work with Channel Forms but I do not seem to have any success as of yet. I have tried using {my_field_name} <...
tcherokee's user avatar
9 votes
4 answers
2k views

2.7 Update Error with PT Fieldtype

Just upgraded from 2.5.5 to 2.7 Not a smooth upgrade as it whitescreened - when I turned errors on it gave me this: Fatal error: Class PT_Fieldtype contains 1 abstract method and must therefore be ...
John Moylan's user avatar
8 votes
3 answers
1k views

Wygwam - automatically wrap media embed with custom html

I'm using Wygwam on a site, and I'm allowing content administrators to embed media (specifically, videos) within the main, body copy/content area. Is there a way to automatically wrap the embedded ...
ctrlaltdel's user avatar
7 votes
2 answers
301 views

Matrix is killing my load times - How can I speed it up

This just started happening with the latest updates. My product pages went from under a couple of seconds, to 12-16 seconds. All spikes below are from Matrix calls. click to see larger image I am ...
W3bGuy's user avatar
  • 1,610
3 votes
1 answer
513 views

Is it possible to convert an EE File Upload path to Assets S3?

I currently have 31 native EE file upload paths all pointing to a location within /images. I'd like to serve all of my image assets from an S3 bucket, so I've created images.domainname.com. I've also ...
Jon Horton's user avatar
3 votes
1 answer
265 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
Andy Homan's user avatar
3 votes
1 answer
874 views

Assets stopped connecting to Amazon S3, Access denied by target host

Assets has been working well for the past couple of weeks uploading files to Amazon S3. The past few days the customer has started uploading the main bulk of his files Wav files, approx. 10Mb up to ...
Laurence Cope's user avatar
3 votes
2 answers
567 views

Multiple custom matrix field in channel form issue

Working with Channel form, I have encountered some problems when working with multiple Matrix fields in a single edit form. [EE v2.7.3 and Matrix 2.5.10] When I work with "native" channel form ...
Sebastiano's user avatar
2 votes
1 answer
579 views

Problem after upgrading Assets: Underscores in folder-names

I upgraded from assets 1 to assets 2. now my folders which start with an underscore are no more recognized. they exist, the images in those folders are shown in the frontend, but i can no more use ...
BNetz's user avatar
  • 470
2 votes
1 answer
549 views

WYGWAM stripping classes and styles

If I add this code using WYGWAM source <h2 class="section-title">Some<span class="blue-text long-word">Title</span></h2> and publish, it works fine. But if I go back and ...
Peter Eastwood's user avatar
2 votes
1 answer
179 views

Assets: Cannot upload file using "simple file input" method

I have an assets field called "member_thumbnail" on my "members" channel (created by zoo visitor). When I make a channel:form edit form or the equivalent edit form from zoo visitor, I am able to ...
Ty Fujimura's user avatar
2 votes
2 answers
204 views

Assets 2 field not working properly within 2.6 relationship

I've got an assets field within a single relationship, using the new 2.6 tags, and I'm having a couple of problems: The assets tag pair only loops once, regardless of how many assets are in the field ...
Wiggles's user avatar
  • 21
1 vote
0 answers
153 views

Server Migration : New Lines in Playa Tag Pair Breaking Templates

I have an issue where the same template - specifically Playa tag pair - works on one server, but not on another. I just used the Plesk migration manager to move from a Media Temple DV 3.5 to DV 4. ...
Luke Hardiman's user avatar
1 vote
0 answers
108 views

Matrix issues using with Solspace Importer

I'm using Solspace Importer to import data from a JSON data feed, and all is working well. As Grid isn't currently supported, I'm using Matrix for my repeatable entries. All works well on initial run,...
crawf's user avatar
  • 126
1 vote
2 answers
252 views

Custom Matrix Field in Channel Form

Implementing the solution found on Bring Matrix Data Editing to the Front-End I've a matrix field that contains a P&T Dropdown field type <select name="role_level[row_new_0][col_id_46]"> {...
lincolnpixel's user avatar
1 vote
1 answer
84 views

Request: Disabled image size inline css

The last few years we have been working for most of the time on responsive designed websites, and every time we are using ExpressionEngine and Wygwam module, we get complains from our clients ...
Rob Mol's user avatar
  • 31
1 vote
1 answer
88 views

Change sort order of files in Assets 2

In Assets 2, is it possible to change the sort order of files so that it automatically shows the most recently uploaded files first? I was hoping there would be a setting or config override for this, ...
Stephen's user avatar
  • 1,349
0 votes
2 answers
600 views

html structure conditional on matrix row counts

I am using zurb foundation and a pixelandtonic matrix field. I want to do a new html row for every 3 matrix rows i.e {!-- something needs to wrap round this to say for every 3 rows do a new one of ...
JohnWBaxter's user avatar
  • 1,701
0 votes
1 answer
196 views

Fieldpack 2.1 (P&T) EE2.6.1 and Safecracker Dropdown Not Working

I've just upgraded a site to EE2.6 with P&T Fieldpack 2.1 all of my safecracker dropdowns are now giving {option_name} instead of my proper Options. My dropdown template code is using the ...
Micky Kelleher's user avatar
0 votes
2 answers
119 views

P&T Field Pack 2.1.1 on EE2.8.1 Installation Errors Notice and warnings

A PHP Error was encountered Severity: Notice Message: Undefined index: enabled_types Filename: fieldpack/helper.php Line Number: 78 A PHP Error was encountered Severity: Warning Message: Invalid ...
Nevsie - Modeten's user avatar
0 votes
1 answer
209 views

Matrix & Simple Search

I'm trying to search inside 'Matrix' cols with Simple Search module - but it's just not happening. I've ensured that the field is 'Searchable' and that all columns in the Matrix are 'Searchable' also....
Jason Mayo's user avatar
0 votes
2 answers
38 views

Assets orderby Title

I can't seem to be able to sort Asset files by their title, instead only by their filename through orderby="name". Is it possible to use the Title field for ordering?
crawf's user avatar
  • 126