Skip to main content

Questions tagged [pixelandtonic]

Pixel & Tonic provide some of the worlds most popular ExpressionEngine Add-ons.

Filter by
Sorted by
Tagged with
0 votes
1 answer
46 views

Not able to add matrix rows after 99 rows

I am not able to add more than 99 rows in my matrix field though I have already set Maximum rows to 1000, not sure whats happening. Is it a BUG or LIMIT of matrix field type? EE version : 2.6.1 ...
0 votes
2 answers
153 views

ExpressionEngine Matrix :total_rows doesn't work when no rows

Matrix 2.5 and 2.6 on ExpressionEngine 2.7.3. The :total_rows property doesn't work when there are no rows. It works fine when there are rows. Below isn't actual code, but it's showing the gist. {...
2 votes
1 answer
43 views

Pixelandtonic Assets: Set Content-disposition?

Long story short: in Chrome, some PDF files stored in our S3 bucket (uploaded via Assets) hang up on download. Chrome just sits there, never downloading the file. (However, right-clicking the link ...
1 vote
2 answers
70 views

Working with staging server and production server - can they share the same Assets locations?

I have 3 installations of my website: beta, demo, and production. Template and functionality changes are made on beta, content is entered on demo and everything moves to production as it is approved. ...
0 votes
1 answer
120 views

Matrix & EE 2.9.2 SQL Error

I am using version 2.9.2 EE and Matrix 2.6.1 (both the latest versions of each software). Each time I try to publish a channel entry that has a Matrix fieldtype I am getting the following error ...
0 votes
2 answers
44 views

Matrix and Solspace Importer issue with saving properly

I'm not sure which plugin is at fault here, but here goes. Using the latest version of all plugins, and EE. I have an Importer task to create entries, from a feed of about 20. One field in this feed ...
1 vote
0 answers
72 views

Assets + multiple files + file manipulations: offset not working

I've got a grid field (slides) that contains 2 Data Types: Text Input - field name: text Assets (multiple selections allowed.) - field name: img The Assets folder that has been selected has a image ...
0 votes
0 answers
39 views

Database Error when upgrading Playa

I've been performing an ExpressionEngine upgrade from v2.5 to 2.9.2. Everything seems to be going well except for the db error I get when upgrading playa. Playa appears to be working, but I get the ...
1 vote
2 answers
147 views

Database error when updating Assets 1.1.4 to latest (2.2.4)

EE v2.4 but also tried updating first to EE 2.8 with same results as per below. Christiaan When trying to update I receive the following: A Database Error Occurred Error Number: 1265 Data ...
2 votes
1 answer
61 views

{filedir_X} variable for Assets S3?

Is there an Assets variable like {filedir_X} that will output the S3 server path? I'm moving my images to S3 and I have referenced images in several channel entries in a textarea like <img src="{...
0 votes
2 answers
38 views

Assets orderby Title

I can't seem to be able to sort Asset files by their title, instead only by their filename through orderby="name". Is it possible to use the Title field for ordering?
1 vote
2 answers
229 views

Custom Date Format with Channel Form + Matrix + Date Fieldtype

We have a channel form setup and it's all working fine. In the form is a matrix field called "job_timings" and we call on it via {field:job_timings} The matrix has two columns - one a text field and ...
2 votes
2 answers
354 views

Issue with Assets on Client end only

My client is experiencing a really weird issue. When they are publishing or editing an entry with an Assets custom field it displays only a white box. They experience this issue in both their ...
0 votes
2 answers
94 views

P&T Assets not functioning correctly after migrating to new server environment

After moving my site to a staging environment I'm no longer able to view any images within the Assets portion of the CP or upload files to any Assets related fields. I'm also unable to update the ...
1 vote
0 answers
121 views

Assets upload button disabled for members

I'm having a peculiar issue: Assets works just fine when you're logged in as a super-admin, but when you're logged in as a member, the "upload files" button is disabled. I have no idea what's ...
0 votes
2 answers
112 views

WYGWAM failing to initialize ... one just one entry

I’m running into something that isn’t making sense to me … I have a client that has created this page: http://teamthroughmywindow.org/about-our-project/faqs The questions and answers are all anchor ...
1 vote
0 answers
108 views

Matrix issues using with Solspace Importer

I'm using Solspace Importer to import data from a JSON data feed, and all is working well. As Grid isn't currently supported, I'm using Matrix for my repeatable entries. All works well on initial run,...
2 votes
3 answers
1k views

empty thumbnails

I've just installed assets 205 on EE 255 and am having a strange issue. the regular file manager works fine but the assets view shows blank boxes for all of the images. It has file names, sizes, and ...
2 votes
1 answer
194 views

Assets v2.4 producing error when saving an entry after upgrade from EE v2.4 to EE v2.9

I've recently performed an update of both Assets (v1.x to v2.4) and EE (v2.4 to v2.9) and now I'm seeing the following error/s when I try to save an entry in the EE control panel. A PHP Error was ...
1 vote
2 answers
252 views

Custom Matrix Field in Channel Form

Implementing the solution found on Bring Matrix Data Editing to the Front-End I've a matrix field that contains a P&T Dropdown field type <select name="role_level[row_new_0][col_id_46]"> {...
0 votes
2 answers
37 views

Assets window brings up the front-end of the website

I've got a site running on a client's server and when we go to add a file, the Assets modal brings up the front-end of the website. Not sure if this is due to us making index.html the default ...
3 votes
1 answer
320 views

Field Pack - Dropdown does it work with channel:form?

Field Pack - Dropdown does it work with channel:form? I can't make it work! I need to use both "name : label"
2 votes
1 answer
88 views

P&T Playa update from 4.4.5 to 4.5.1 database error

This has been covered elsewhere for earlier versions but the solution doesn't seem to fix this issue. I'm getting the following error when I update from Playa 4.4.5 to 4.5.1, on EE 2.7.2: A Database ...
1 vote
1 answer
84 views

Request: Disabled image size inline css

The last few years we have been working for most of the time on responsive designed websites, and every time we are using ExpressionEngine and Wygwam module, we get complains from our clients ...
0 votes
2 answers
119 views

P&T Field Pack 2.1.1 on EE2.8.1 Installation Errors Notice and warnings

A PHP Error was encountered Severity: Notice Message: Undefined index: enabled_types Filename: fieldpack/helper.php Line Number: 78 A PHP Error was encountered Severity: Warning Message: Invalid ...
2 votes
2 answers
204 views

Assets 2 field not working properly within 2.6 relationship

I've got an assets field within a single relationship, using the new 2.6 tags, and I'm having a couple of problems: The assets tag pair only loops once, regardless of how many assets are in the field ...
1 vote
0 answers
29 views

FieldFrame Causing White Screen of Death

Running an EE 1.7.3 site that has FieldFrame installed. Everything works fine locally, but when I upload the site to GoDaddy's shared hosting (cPanel), the site goes WSoD. Tried updating to the latest ...
1 vote
1 answer
246 views

PHP errors relating to matrix on channel form submission

EE 2.9.0 Matrix 2.6 I have a template with a channel form in it, nothing else (I've stripped it down for testing). {exp:channel:form channel="test_channel_form" return="test-return" } ...
0 votes
0 answers
94 views

playa not returning parents

My site has events. members can apply for an event. I want to prevent them applying more than one time for an event to prevent duplicates. My set up is as follows: channel event 2 channels for ...
0 votes
1 answer
52 views

Matrix/Playa saving issue

Have a problem with using Playa as a field within a Matrix field where the selected entry is not being saved. Oldish version of EE (2.4) but should be supported. Entry appears to save okay but when ...
1 vote
1 answer
58 views

Setting default upload area for Assets

Hopefully a simple answer, but at the moment, I can't figure it out. I'm using an Assets field in a channel entry. When the client clicks on the "Add file" button, it defaults to the "Recent Uploads" ...
2 votes
2 answers
324 views

P&T Dropdown and Checkboxes with Channel forms

I have been trying to get P&T's Dropdown as well as Checkboxes to work with Channel Forms but I do not seem to have any success as of yet. I have tried using {my_field_name} <...
1 vote
1 answer
89 views

Get label from PT Pill field

I have a FieldPack Pill field called companies_type with the following options: physical : Physical Store webshop : Webshop To print the fields value I can just use companies_type but how can I get ...
3 votes
1 answer
387 views

DB error after Matrix update

Have just updated Matrix to 2.5.6. When I go to Add-ons > Fieldtypes > Matrix to trigger the update script I get this error. A Database Error Occurred Error Number: 1060 Duplicate column name ...
2 votes
1 answer
549 views

WYGWAM stripping classes and styles

If I add this code using WYGWAM source <h2 class="section-title">Some<span class="blue-text long-word">Title</span></h2> and publish, it works fine. But if I go back and ...
0 votes
2 answers
90 views

Assets: Log's me out of the cp

I have just installed Assets. But it keeps logging me out of the CP. This error occurs (console): POST http://centiv.local/admin/ 500 (Internal Server Error) It contains: {"error":"This form has ...
0 votes
1 answer
66 views

How do you use HTML5 elements in WYGWAM?

I see that WYGWAM added support for HTML5 elements (section, figure, etc.) in their changelog, but I cannot figure out how to enable or use them. Can someone enlighten me?
3 votes
1 answer
363 views

How to return P&T Dropdown option label within Channel Form

I'm having trouble returning the option label within a Channel:form tag. The selected option value returns correctly using {my_drowpdown_field_name}. However, the option label is not returned using ...
0 votes
2 answers
88 views

Assets 2.3.2 Lib file - Causes PHP error

After updating to the latest versions of the Assets extension for Expression Engine. When I am logged in as a Super Admin I get the following PHP error, I don't get this error when logged in as a ...
2 votes
0 answers
97 views

WYGWAM and IE11 issues on Publish

I am running a site that uses the following EE 2.7.3, MSM 2.1.6, Better Workflow 1.6.4.2 and WYGWAM 3.3. When a page is edited in IE11, when I go to save the page from any tab apart from the '...
1 vote
3 answers
226 views

Assets 2.2.2 / 2.3.2 chequerboard / empty thumbnails

I have the chequerboard / empty thumbnails showing up in Assets, for all images. Everything is working fine on the live site. So far I've tried: Checking / applying 777 to all images and the cache/...
1 vote
2 answers
208 views

Cloning Entries With Matrix Fields

I need help with cloning an entry that has matrix fields for photos. Entries are made/edited using Channel Forms. The clone is generated using an extension to the channel_form_submit_entry_end hook ...
0 votes
1 answer
139 views

Show playa parents of child items listed via {exp:low_alphabet:entries} (not a single entry page)

Each discography entry has a playa field for each disc that contains all the songs that appear on that record, creating a tracklisting. What I'd like to do is create a reverse navigation system, so ...
2 votes
3 answers
278 views

Conditional on Playa field with var_prefix

Is there any reason this conditional wouldn't work? {standard_page_events var_prefix="cat"} {cat:event_category_description} {exp:playa:coparents var_prefix="event" channel="events" child_id="...
0 votes
1 answer
66 views

Error message when I try to edit custom fields

I just upgraded my ExpressionEngine to the latest version (2.8.1) along with the latest FieldPack (2.1.1). All my pages load fine, but when I try to click on an existing Custom Field within my ...
0 votes
1 answer
185 views

exp_channel_data matrix field contains YTowOnt9

EE 2.6.1, Matrix 2.5.10, Structure 3.3.13, Wygwam 3.2.2 Matrix field data outputs on the frontend, but matrix rows disappear when editing a specific entry. The matrix data still appears on the front-...
0 votes
1 answer
82 views

Display ALL latest related entries using Playa

I'm using Pixel & Tonics Playa which is working great however I am wondering if there is a way to display ALL related entries without the user having to manually select them? The example I have ...
3 votes
2 answers
567 views

Multiple custom matrix field in channel form issue

Working with Channel form, I have encountered some problems when working with multiple Matrix fields in a single edit form. [EE v2.7.3 and Matrix 2.5.10] When I work with "native" channel form ...
1 vote
0 answers
115 views

500 error when attempting to upload images using pixel and tonic assets module on localhost

I have set up a vhost in mamp (http://az-cms:8887/) - and installed expression engine as well as the assets module. I have a directory set up on my local hard drive within the expression engine ...
1 vote
1 answer
98 views

NGen File Image to Assets within Matrix table

I'm currently in the process of transferring channel entry data from an EEv1 site into a fresh new EEv2 site. My method is to populate XML files with channel data and then, using Importer (or DataGrab)...