Skip to main content

Questions tagged [sagepay]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
105 views

Cartthrob Subscriptions 5017 Rebill Sage Pay Error

Have an installation of Cartthrob Subscriptions 2.6 installed and semi working with a SagePay Offsite test account which has token and repeat enabled and a continuous authority merchant number ...
0 votes
1 answer
40 views

{field:payment_method} doesn't output anything

I'm struggling to get a payment method to be output in the checkout tag. I'm using this code: <div class="field"> {field:payment_method} {error:payment_method} </div> I just get ...
0 votes
0 answers
62 views

Cartthrob 2.7 SagePay failing with Security Signature is not valid

On returning from a successful transaction on SagePay (server), I am getting the following error: Security Signature is not valid In cartthrob>payment_gateways>cartthrob_sage_s.php the check ...
0 votes
1 answer
104 views

Sage Pay (Server) throwing error at checkout

I've set up CartThrob and using Sage Pay (server) to process payments. Using the {exp:cartthrob:checkout_form} tags once billing address details are added and the form is submitted I get the following ...
0 votes
1 answer
189 views

CartThrob / SagePay sudden error 5006 after server move?

After a recent server move and a new dedicated IP address configuration the site no longer works with SagePay (offsite server), we now get the following error(s) after entering payment details at ...
0 votes
1 answer
72 views

Cartthrob with SagePay suddenly stopped working; error 4020

An existing site running CT 2.5 and EE 2.7.3 with SagePay (server) has suddenly stopped working on the LIVE server. Initially I thought it might be due to the recent SagePay API update to v3.0, so I ...
1 vote
1 answer
423 views

Sagepay Protocol 3.00 - upgrading cartthrob gateway

I've been trying (without success) to upgrade the Cartthrob_sage_s.php gateway on Cartthrob for SagePay Europe Offsite, in order to utilise the 3.00 protocol (upgrading from 2.23. I'm running latest ...
0 votes
1 answer
88 views

Cartthrob no longer sending email notifications after EE/CT upgrade

I've recently upgraded EE from version 2.7.3 to the latest 2.9.2, and CartThrob similarly from 2.3.6 to the latest 2.6.1. All functionality seemed to be fine, aside from my SagePay checkout, which ...
1 vote
2 answers
467 views

CartThrob Sage Pay error

Working with CartThrob and SagePay on a site and get the following error at checkout (after submitting card details): HTTP Status Code: 500 HTTP Status Message: The request was unsuccessful ...
0 votes
1 answer
106 views

Adding a product code to cart items

Wondering if anyone can help me out with this issue I've got. Apologies if my terminology is wrong with any of this - It's landed in my lap and I'm trying to get the issues solved without any prior ...
1 vote
0 answers
58 views

Payment to Sagepay not submitting

We have a multi-step checkout, with SagePay Europe Direct as the default payment gateway. When it comes to inputting your card details on the site and submitting, you get redirected back to the ...
3 votes
2 answers
215 views

404 when Sagepay attempts to contact Cartthrob notification URL in Nginx

https://xxx.xxx.xxx/themes/third_party/cartthrob/lib/extload.php works fine, but https://xxx.xxx.xxx/themes/third_party/cartthrob/lib/extload.php/sage_s returns a 404. My nginx server config is ...
2 votes
1 answer
862 views

SagePay Direct: Error: Sorry, there was an unexpected error communicating with the payment gateway

We're getting a communication error response when submitting card details using the SagePay Direct payment method: Error: Sorry, there was an unexpected error communicating with the payment ...
0 votes
2 answers
100 views

SagePay (server) error message

In a Catch-22 situation where SagePay won't approve a merchant account for client unless we have a working dev site for them to test a transaction on which is set up to integrate with … SagePay. ...
1 vote
1 answer
134 views

Cartthrob MSM Sagepay 5006 error

I have a Cartthrob MSM installation (2 stores) that use sagepay (europe offsite) for processing payments. Every time I try to make a payment through the sites, I get all the way through the payment ...
1 vote
1 answer
129 views

cartthrob_on_authorize

I am having an issue with the cartthrob_on_authorize developer hook. I use the hook to carry out some additional processing to the customer order. One such process is to set an order status based on ...
1 vote
2 answers
254 views

How can I tell if Cartthrob's extload.php is being invoked (and what it outputs)?

I'm having terrible trouble getting an updated EE2.7.2 / CartThrob 2.4 MSM site to integrate with Sagepay (Europe Offsite). Every time I try to go out to sagepay from the checkout page, I'm returned ...
1 vote
1 answer
597 views

Cartthrob Sagepay (offsite) 3037 notification URL error for MSM sites

I've taken on two ee cartthrob sites running off an msm installation. I just moved them to a Nexcess server and updated EE from 2.2.1 to 2.7.2 (and CT from 2.051 to 2.4). Everything is working fine ...
1 vote
1 answer
144 views

Expresso-store sagepay errors [closed]

Using sagepay_server gateway in test mode can get to payment page fine but on submit I get sagepay errors: HTTP Status Code: 500 HTTP Status Message: The request was unsuccessful due to an unexpected ...
1 vote
1 answer
145 views

Cartthrob not returning after transaction with SagePay

I am having an issue with sage. Transactions are going through and money is being taken no problem, but it isn't returning to the desired return= param. I have tested with PayPal and all works fine. ...