Skip to main content
The 2024 Developer Survey results are live! See the results

Questions tagged [ssl]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
368 views

Unable to send emails, handshake times out

EE 6.2.7 I'm trying to connect to office365 exchange server using SMTP via STARTTLS. When stream_socket_enable_crypto() attempts to establish a secure connection, it says SSL: Handshake timed out. I ...
Shayne's user avatar
  • 317
1 vote
2 answers
38 views

Force Stash to output https

I've inherited an old EE site. I'm trying to get everything running on https. I can get EE to serve up most images via https but it seems like when stash is used, it doesn't use https. Is there a ...
SilenceKit's user avatar
0 votes
4 answers
375 views

ExpressionEngine Control Panel SSL HTTPS Issue

I have an issue with the HTTPS header for the ExpressionEngine control panel where the JS is being disabled. It keeps generating error messages where HTTP is being loaded over HTTPS (see below): ...
friday_james's user avatar
0 votes
1 answer
124 views

SSL Certificate Breaking the Site Style Sheets - Looking for a fix

I've inherited an old version of an expression engine website using version 2.10.1. The site is not displaying on https:// and when I am testing the stylesheets are broken. I've been informed that the ...
Naomi Walker's user avatar
0 votes
2 answers
152 views

HTTPS url just redirects back to HTTP

I have a site that's running EE 3.3 and I'm trying to change it to include the SSL certificate that's just been installed on the server. I normally can change the config or the URL settings to ...
James Cottis's user avatar
0 votes
1 answer
130 views

Expresso Store SSL Error with Authorize.net

I have had an ExpressionEngine site with Store running well for a while now, then out of the blue customers started getting errors when trying to complete checkout and pay. I looked into it and found ...
mediapimp's user avatar
  • 741
0 votes
1 answer
233 views

The right place to force SSL on entire domain

I'm not all that familiar with htaccess and in attempting to do this myself I'm getting a too many redirects error so I thought I would go to the experts. I'm just looking for the right place within ...
Jean St-Amand's user avatar
1 vote
2 answers
204 views

When installing an SSL certificate the control panel css breaks

I've installed an SSL certificate on a domain and that has the lovely green padlock. However when I log into the control panel, all of the CSS is broken. Any ideas on what I should be doing? CHeers
TTK's user avatar
  • 11
0 votes
1 answer
40 views

Stash content depending on SSL / https

How can i stash content globally depending on https or http scheme? One way is to store it under a context, but then i have to change all stash set and get tags site-wide to work with a context ...
GDmac's user avatar
  • 2,157
1 vote
2 answers
565 views

https and Control Panel mixed content error

I've got a site in SSL but when I visit the Control panel it is completely unstyled and looking in the inspector I see a mixed content error and js/css is being blocked. Not sure why this is ...
CreateSean's user avatar
  • 4,747
0 votes
2 answers
1k views

How to - configure EE to play nice with https...?

Does anyone know about any resources that explain how to get EE2 to play nicely with SSL certificates please? Thanks!
JCOGS Design's user avatar
  • 3,585
0 votes
1 answer
93 views

Channel form not submitting

I have an issue with submitting on my channel form , the form doesn't work under https but it is ok under http. Its a form to edit user profiles. I have added secure_action="yes" secure_return="yes" ...
bhackett's user avatar
  • 346
0 votes
1 answer
56 views

Secure Https Channel form login

I have a section of my site where users login and can create and edit profiles. Theses profiles are edited through a channel form and are behind a login. I have moved this section of the site over to ...
bhackett's user avatar
  • 346
0 votes
2 answers
151 views

Https problem with channel form

I have a problem with a channel form working over https.My form allows users edit their profiles for a staff directory and has a lot of fields including some assets , wygwam and matrix fields.When i ...
bhackett's user avatar
  • 346
0 votes
1 answer
1k views

SSL Subdomain Staging Site in Subfolder is Resolving Webroot Instead

I'm trying to set up a staging subdomain in a subfolder under the webroot of the main production site for testing and deploying changes for a EE e-commerce website. I hope one or two of the more ...
oliverb's user avatar
  • 170
1 vote
1 answer
156 views

Does CartThrob 2 use SSLv3 in it's Authorize.net payment gateway?

Due to the POODLE vulnerability in SSLv3, Authorize.net is shutting down their support for SSLv3 on Nov 4, 2014. Here's a excerpt from the notice: To that end, on November 4, 2014, we will be ...
Alex Roper's user avatar
  • 1,156
0 votes
1 answer
84 views

Secure Comment Form Action?

I'm trying to add comments as reviews to a store using the Devdemon Ratings module. The store runs over SSL and that's all fine, however when I add a comment:form to the mix, the form action isn't ...
Raf's user avatar
  • 1
0 votes
2 answers
188 views

Simple Search Form Tag over SSL

The simple search form tag is breaking SSL. How do I go about making the simple search form tag secure over SSL.
MaplePixel's user avatar
3 votes
2 answers
137 views

Any way to output a relative URL in exp:channel_files:files?

Our live environment is over SSL, but our local sandboxes aren't. This requires us to use {file:secure_url} in our exp:channel_files:files tag pair. Is there a way to output this URL that will inherit ...
Ryan Masuga's user avatar
  • 1,402
0 votes
1 answer
153 views

Submitting a form in an https page

I have a form in a HTTPS page. The action that was generated use the HTTPs too https://foo.com/?ACT=140&... However, when I tried testing submitting the form, it did not work. I tried testing ...
developarvin's user avatar
  • 2,347
3 votes
2 answers
442 views

Variable SSL and Cookies

Let's say I have a membership site, and my login page & form are served with SSL: https://mysite.com/member/login. <form action='https://mysite.com' method='post' class='login'> <!-- ...
kmgdev's user avatar
  • 2,724
1 vote
1 answer
148 views

SSL Certificate Breaking User Login - ExpressionEngine

I have recently installed an SSL certificate on a website. Unfortunately when enabled, members can not stay logged in. After the initial login, it logs you out every time the page refreshes. Any ...
Edd Aslin's user avatar
  • 431
0 votes
3 answers
10k views

Too many redirects when forcing https on a template group

I'm having some trouble with forcing https on a given template group. If I use the following, I get the "too many redirects" error. If I comment out my "force SSL" conditions, everything else works ...
Jean St-Amand's user avatar
2 votes
1 answer
224 views

SSL and Insecure Content

I finally set up my first EE site with SSL. Everything seems to be working ok, but I discovered that some of the pages are "delivering unencrypted elements". What I've found so far: Images added ...
Todd's user avatar
  • 752
1 vote
2 answers
1k views

Unable to use Assets in in HTTPS

Changed my Control Panel to https, but assets doesn't show images nor let me load. In http it works fine, but when i change the address to https, according to firebug, the address https://myurl.com/...
Vitor's user avatar
  • 77
2 votes
0 answers
53 views

SSL and Wygwam not loading tool bar

Any one know if there is a setting in Expression engine for the WYGWAM editor for https? When I access through https my tool bar disappears? Any ideas? Thanks, Dan
Dan Kelly's user avatar
2 votes
2 answers
646 views

Forcing SSL on /admin.php only

Trying to force SSL on the admin area only (/admin.php) but running into some issues. I've installed the http support add-on (http://devot-ee.com/add-ons/https-support) and the SSL certificate is up ...
Nick's user avatar
  • 693
0 votes
1 answer
443 views

Unknown column 't.dst_enabled' in 'field list' after EE 2.7.2 Upgrade

Okay this one is totally nuts, I've spent all day trying to nail this one. I've attempting to go from EE 2.5.5 to 2.7.2, but after the upgrade, I'm getting the following error on some pages: ...
neekster's user avatar
  • 428
2 votes
2 answers
62 views

DM Force SSL based on Stash not_empty variable

Somehow I can't seem to get this right. I have a Stash variable that I'm setting if certain pages need to be redirected to their HTTPS version. Tried it a number of ways, but very similar to this: {...
jpea's user avatar
  • 234
2 votes
1 answer
321 views

"Unable to Load Site Preferences; No Preferences Found" error with HTTPS

I set "Force HTTPS connection for checkout and order tags" to "yes" in the Exp:resso Store settings and was met with this error when viewing my store pages using https: Unable to Load Site ...
Anna_MediaGirl's user avatar
  • 12.6k
2 votes
2 answers
72 views

Editing for SSL - EE1

I am trying to force the EE1 control panel to my secure cert, with a bit of difficulty. The problem is that not everything is delivered by a relative link, so some stuff, specifically custom ...
Aaron's user avatar
  • 1,162
2 votes
1 answer
61 views

Expresion Engine 1.X jquery

I hoping someone has some experience with EE 1. I recently had to apply a secure cert to secure a site, front end and back end. Everything's fine, but EE is loading 2 jQuery files over http. The ...
Mark's user avatar
  • 493
2 votes
2 answers
3k views

Trying to redirect a page to HTTPS using .htaccess, getting "too many redirects" error

Ugh, seems like I'm having a lot of htaccess issues lately. Recently moved a client site to new hosting from the cient's internal server. Their IT had setup SSL and updated the .htaccess to redirect ...
Mike Lohrman's user avatar
1 vote
3 answers
214 views

How to return to http when on https page?

When on a https section of an EE page (e.g. https://domain.com/account) and having a link back to the homepage somewhere in the header, how do I set up the links so that https is not automatically ...
Marc's user avatar
  • 502
1 vote
1 answer
905 views

SSL on Direct Admin

I have a regular Expression Engine install on an server that uses Direct Admin (DA) system -- codeignitter -- expressionengine logs pivate_html public_ftp public_html -- .htaccesss -- index.php -- ...
Robbie Post's user avatar
3 votes
2 answers
522 views

htaccess, https, MSM, and Expresso Store

I'm running EE multi-site manager (MSM). My default site's domain (say, www.default.com) is where the /themes folder is housed. So, for my second site (say, www.site-two.com), all of the EE and third-...
Stephen Callender's user avatar
2 votes
2 answers
290 views

Secure Login Forms

At present there doesn't seem to be an easy way to login securely using the Member module. Safecraker provides useful parameters in secure_action="yes" and secure_return="yes" to ensure encrypted ...
Ian Young's user avatar
  • 5,407
5 votes
1 answer
949 views

SSL certificate on https://secure.domainname.com

my problem: If I attempt to access a https template through expression engine, I get a blank screen: https://secure.domainname.com/anyTemplateGroup/anyTemplate Solved by host (finally found this on ...
Lloyd Hill's user avatar
3 votes
1 answer
4k views

Adding a .htaccess redirect to https that plays nicely with existing EE .htaccess rules

I've got an extranet (mywebsite.com/extranet) and would like to make sure that just this section is always under https, even if the user types the URL without https in it. Likewise (as a bonus, if ...
Stephen's user avatar
  • 1,349
1 vote
1 answer
302 views

EE, MSM, SSL and Multiple Domains

So I have a challenge, here's the setup: 3 Sites, each with it's own domain, managed by MSM. Each site has a small e-commerce implementation requiring SSL Multi-Domain SSL certs are prohibitively ...
Jacob Russell's user avatar
1 vote
1 answer
141 views

SSL on multi-language site

I'm trying to get the checkout template working with SSL. When I set the Require SSL parameter to YES in CP / Store / General. loading the checkout template (https://www.mydomain.com/nl/store) fails ...
Robbie Post's user avatar
2 votes
2 answers
172 views

Is there an alternative to using file manager for this scenario?

Here is the scenario: I want to store files (PDFs, DOCX, etc.) using Amazon S3 or similar I want members to login to my site and download these files via a url The link needs to be scrambled ie. www....
gelviis's user avatar
  • 141
3 votes
2 answers
141 views

SSL Redirect (no idea where it's coming from)

I recently had to do some emergency-work on my client's live server, and wanted to sync those changes back into my repository and staging environment. Now that I've synced them back (copied new files ...
Steven's user avatar
  • 753
4 votes
1 answer
544 views

Securing the control panel with SSL

I'm in the process of securing my control panel with SSL using the following rewrite rules RewriteEngine On RewriteCond %{HTTPS} off RewriteCond $1 ^(member|system) [NC] RewriteRule (.*) https://%{...
Dylan's user avatar
  • 1,074
5 votes
3 answers
18k views

Force SSL on some URLs but non-SSL on others with .htaccess

I'd like to redirect requests for certain urls to secure https with .htaccess rules. I found this excellent tutorial: https://exp-resso.com/blog/post/2011/08/securing-your-expressionengine-website-...
Alex Roper's user avatar
  • 1,156
2 votes
3 answers
530 views

Expresso Store: "Card details must be submitted over a secure connection" error

I am trying to checkout with the Dummy Payment Gateway in Store. It will not let me do this. The error message says "Card details must be submitted over a secure connection." I have Expression ...
Shannon Cathey's user avatar
2 votes
3 answers
525 views

ExpressionEngine over SSL - HTACCESS ISSUE

I have a problem with my EE installation. When I try to browse any page (other than the homepage) over SSL i get a 404 error. The whole site works fine over HTTP. Its only when accessing via HTTPS ...
Tomtids's user avatar
  • 783
1 vote
1 answer
185 views

Can a freemember login form be sent securely?

Say I force SSL on my public login page (with DM Force SSL), and I'm using a fairly standard freemember login form: {exp:freemember:login return="PREVIOUS_URL" error_handling="inline" ...
James Muspratt's user avatar
2 votes
1 answer
154 views

Playa Filters failing with Force SSL module in place

We are experiencing the same issue as: https://getsatisfaction.com/pixelandtonic/topics/https_and_playa_in_cp We're wanting to use the playa module along with force-ssl(http://devot-ee.com/add-ons/dm-...
Gray Race's user avatar
  • 123
3 votes
3 answers
111 views

Update User-Added Resources to SSL-Friendly URLs?

I have a field in my publish form where users can add embed code for a video, and they can also embed videos using Wygwam. The entire site has SSL enabled, but the video embed codes use the insecure "...
kmgdev's user avatar
  • 2,724