Questions tagged [templates]

Questions related to the ExpressionEngine "templating" system.

7
votes
1answer
343 views

Site “forgot” what the default template was

I've had the same problem happen a few times, on several different EE sites, but I can't determine the cause so I'm turning to y'all. Symptom: The site's main index page will fail to load and will ...
1
vote
1answer
133 views

Expression Engine returns 404 on Javascript template

I have a bit of an issue with a project I recently took over using Expression Engine running v2.92 (I think). I'm pretty new to EE so maybe I'm missing something obvious. The javascript template ...
1
vote
1answer
52 views

Code-driven way to enable PHP parsing on a template

Still a bit new with EE2, but I'm looking to be able to construct a way we can push changes up in environments, without having to sync up database-level stuff. Right now I have several templates that ...
1
vote
1answer
923 views

URL and Routing Issues, anything other than index gives 404

Hi I am fairly new to ExpressionEngine, but I am having an issue navigating from the Index Page. When ever I click on a link to view an entry it always gives me a 404 error. I think it might be a ...
1
vote
1answer
38 views

NavEE selected_class=“on” becomes class=“yes” - possible to solve w/o updating styling?

I assume due to some bug in the parser, {exp:navee:nav nav_title="header" selected_class="on"} Outputs <ul> <li class="yes"><a href="/foo">Foo</a></li> <li&...
0
votes
1answer
37 views

Issue with saving templates after upgrade

I have upgraded an EE 1.6.8 website all the way to the latest EE 5, but now I have a problem with saving templates. When I try to save a template after editing, the homepage shows up and the template ...
0
votes
1answer
21 views

Template class error in CP

Recently I upgraded an EE2 website to EE5. After upgrade, everything working very well except I am getting error while trying to edit/create a template from CP or from Template Manager -> Template ...
0
votes
1answer
46 views

EE4 Module Tab on Template Editor Page

Is there a way to add a tab on the publish form within the Template Manager like it is with the Channels? For example, the Template Manager has the default Edit, Notes, Settings and Access form tabs. ...
0
votes
1answer
31 views

How do you stop the “category path” being put in URL's generated by {path=}

ExpressionEngine 3.5.10. I am outputting a specific list of categories (category_group="1") from a channel of training courses (channel="training"). Followed by the list of courses assigned to that ...
0
votes
1answer
86 views

How to upload/embed a MP3 file into expression engine?

Good afternoon. I am new to EE, and am trying to upload an MP3 audio file to our webpage. I am able to upload pics, PDF, etc..., but for some reason cannot figure out what to do for an MP3. Can ...
0
votes
1answer
58 views

Pull dynamic entries using Ajax template on multiple Structure entries with Relationships

I've created two separate Structure entries, both using the Page template below with Relationship entries. It works fine if I only want one page, but I've made a second page to pull different ...
0
votes
1answer
22 views

Can templates be filtered for text content?

One of our templates requires the word 'update' in the text copy, but whenever we edit it to add the word, on save we get "Error. The page you requested was not found." The same error happens when ...
0
votes
1answer
41 views

404 page going to listing entry template only in first segment

I can only trigger the 404 template for anything more than two segments, for example, if this is bad link I see 404 page: site.com/wrong/link When just accessing one segment like this for example, ...
0
votes
1answer
84 views

remove second segment in url for entry listings

Currently using {url_title_path='blog/blog-entry} for listing entries, but URL outputs /blog/blog-entry/listing-title. I'd like the URL to be /blog/listing-title. Can I do this using routes? What's ...
0
votes
1answer
69 views

Using a Channel Entry as an Embed Template

Is it possible to have Channel Entry as a text input be used dynamically to include a design template? In other words, something like: {exp:channel:entries channel="mychannel" limit="1"} {embed="...
0
votes
1answer
25 views

Stashing Entry Ids not working with get tag

I've got a stash set like this: {!-- retrieved at line 173--} {exp:stash:set name="st_featured_ids" type="snippet" parse_tags="yes"} {director_featured_spots backspace="1"}{...
0
votes
1answer
48 views

Want to display all but 1 category in channel entries loop

I would like to display all but 1 category in my channel entries loop. I tried doing category="not .." but it doesn't work. Here is my code {exp:channel:entries channel="lm_edit" sort="desc" category=...
0
votes
1answer
227 views

MSM Path Trouble in EE3

In EE2 there was the "Server path to site's templates" for each site in MSM. So it was possible to have two separated folder structures similar to: domain-A.tld (with whole ee system) /system /...
2
votes
0answers
194 views

PHP Error from relationship field: Undefined offset: 95, Filename: relationship_parser/Tree_builder.php

I have a template that is pulling in the parents of a relationship field with the {parents} tag. I'm seeing a notice when I load the page for each of the {parents}. The child's data is just a text ...
1
vote
0answers
26 views

PHP in Template Forbidden - Can't even save

On EE 2.11.7, I've enabled PHP on a template and set it to output and even a simple echo of some text between PHP opening and closing tags results in a Forbidden error page when I try to save the ...
1
vote
0answers
65 views

Changes to Templates not saved as files

I have a EE 3.5.6 project. "Save templates as files" is enabled. When a change is made to a template in the Template Manager and saved, I get the notice that the template has been saved, however the ...
1
vote
0answers
65 views

Parse template and get content with PHP

I developed an extension for EE2 much earlier for parsing template to send the content to an email address. Now I am porting it for EE3 and facing problem that instead of returning parsed template ...
1
vote
0answers
162 views

getting a EE template to function as a php file

Is there a secret to getting a EE template to function as a PHP file? I have a map that is loading the data from a php file. I want to load the data from an EE template instead. I have set the ...
1
vote
0answers
106 views

Unable to create Template group within template manager

I'm currently in the midst of developing a new EE site and it has been going relatively well. Up until now when I've run into a peculiar problem which I have never encountered previously. (at least 6 ...
1
vote
0answers
38 views

Embeding a playa in matrix using tabs

I am trying to build tabs using a matrix with a playa inside of it my basic code looks something like this. I did something like this inside before and works. does anyopne know what I am missing? ...
1
vote
0answers
193 views

Can I use MySQL session variables within a query in my template?

I'm trying to execute a query similar to this: SET @last_date = NULL; SELECT IF(dates.first_entry = 1, DATE_FORMAT(FROM_UNIXTIME(col_id_122), '%W, %M %d'), NULL) start_date, DATE_FORMAT(...
1
vote
0answers
156 views

Problem parsing deep arrays with parse_variables()

I have a problem with the parse_variables() method once my data contains an array at a certain depth: foreach ($cvs->result_array() as $id => $row) { $variables[] = array( 'id' =>...
1
vote
0answers
32 views

Get the current entry/template fieldtypes in a plug-in

I'm working on my first, more complex add-on and had a question on gathering field properties. If I create a tag pair, which wraps a field inside a template, what would it take to get the tag ...
1
vote
0answers
222 views

Using EE Templates in Custom Controllers Etc

I've gotten a custom controller set up in my EE install and I'm trying to use an EE template with the custom functions etc I need to use. <?php if (!defined('BASEPATH')) exit('This cannot be ...
1
vote
0answers
202 views

Template debugger not outputting information about add-ons

I have Template Debugging and Output Profiler turned on for my site, but i'm not seeing any debug information about my add-ons being used on the site. On any other site it would show what's happening ...
1
vote
0answers
67 views

Integrating forums into site templates?

Ive read the EE documentation, and utilized other "solutions" for getting the forum to work at segment 2, but nothing seems to work - all result in a server error 500 page. When set to default (...
1
vote
0answers
294 views

Channel field not showing on page with embedded template using Multi-Site Manager

I am using ExpressionEngine 2.5.2 with Multisite Manager. I have one template embedded within another. The parent template is pulling data from 2 sites, and I would like certain information to show up ...
0
votes
0answers
7 views

How to delete template variables, template partials, templates completely in EE5?

Templates, partials and template variables are automatically stored as files since EE4. But they are also stored in the database (in the tables exp_global_variables, exp_templates, exp_snippets - note ...
0
votes
0answers
10 views

Using stash:cache to set last-modified header

We're looking to start using CloudFront's updated method for determining cache expiration that relies on the response having an accurate last-modified header. We use stash:cache tags around the entire ...
0
votes
0answers
15 views

Wyvern for EE2 stripping images inexplicably

I'm working on an older EE 2.11.9 site with Wyvern 1.8.0 uploading an image via the publish page works fine and you can see it in the editor. However on the front end the image tag is stripped out ...
0
votes
0answers
25 views

Module Settings Column

I am creating a competition website. For the competition I am creating a custom module. The module has a cp backend where I want to be able to add some details about the competition. For example, ...
0
votes
0answers
41 views

In EE3 can I query the Model service for template info in my template's PHP?

I want to do something like: $templates = ee( "Model" )->get( "Template" )->all(); //Loop through them foreach( $templates as $template ) ... But when I try this, it hangs the page/server. Is ...
0
votes
0answers
52 views

embed template showing erorr

When embedding a template gets error message described in the image attached.. need an immediate help.. thank you {html-head} {global-stylesheets} {js-header} {main-nav} {main-nav-2} {html-head-end} &...
0
votes
0answers
26 views

Fiedtype to allow selection of layout using thumbnail images?

I'm looking for a field type that could let my client choose a certain template for the single page of an entry. I'm thinking a radio button field type but i'd like to show the option as an image.. ...
0
votes
0answers
319 views

“The page you requested was not found” for member templates

After update to 2.9.2 I have "The page you requested was not found" for all member pages(registration, profile and so on). Can't understand what's wrong. I've checked .htaccess rules - ok, templates ...
0
votes
0answers
176 views

Email Notification Templates {entry_url}

I've set up an automatic response when a new entry is posted, I've included the template below. It's working fine, but the {entry_url} is wrong, it's sending an older URL from the dev version of the ...
0
votes
0answers
199 views

Google Maps for ExpressionEngine Multiple Markers - incorrect display

ExpressionEngine 2.9.2 Google Maps for ExpressionEngine 3.3.8 Geocoder 1.2.0 I have a channel for branches and on the single entry page the map correctly displays the branches location using this ...
0
votes
0answers
353 views

expressionengine 2.5.2 - Parse error: syntax error, unexpected T_STRING in

I am new in expressionengine, and getting the following error Parse error: syntax error, unexpected T_STRING in /var/www/system/expressionengine/libraries/Functions.php(680) : eval()'d code on line ...
0
votes
0answers
231 views

Channel entry not showing up on homepage

For some reason my channel entry stopped working on homepage (index.html) template. I am calling the same channel entries in the header and footer and I am completely stumped as to why it stopped ...
0
votes
0answers
18 views

weird behaviour when saving template

i just had fresh installation EE 2.4 and i worked with this copy on other hosting and its working charm now when i go to Template Manager trying to update Template in Template group it redirect me to ...
0
votes
0answers
68 views

How to use pagination?

I don't know how to get pagination to work, seems like it should be simple but I just don't know. I am new to this particular aspect of expression engine. Can anyone help. Here was what I did put in ...
0
votes
0answers
90 views

Template routing stopped working after server migration

We migrated a site we've been working on to a new server with the same host, the server spec is technically greater but from a software perspective it's running the same flavour of Apache, PHP and ...
0
votes
0answers
145 views

404 Page is Appending Home Page

We have created a template called /site/404. The site is working correctly as far as pulling articles, and content properly for all of our different URLs. When we go to either a template that does ...
0
votes
0answers
34 views

Lag in Data Returned

I have a pretty simple template set up that has one image and a block of text, but for some reason the page takes 3 seconds to load at 37 queries. I have tag caching set so subsequent loads of the ...
0
votes
0answers
206 views

Low Variables with Switchee - parse order issue

Hi I'm having a parse order issue that I can't seem to figure out. I have a template that looks like this: some code here <div class="content-line"> {exp:low_variables:parse var="lv-...