Last call to make your voice heard! Our 2022 Developer Survey closes in less than a week. Take survey.

Questions tagged [text-formatting]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
45 views

ckeditor for expressionengine version 1?

i am using version 1.6.7 , and i need to install a CK-editor to ability format the text in the entry process , and all the documentation said that i should be using at least a version 2 and larger, so ...
user avatar
0 votes
1 answer
55 views

Avoid <p> in output of channel fields

I created a channel "project" with several channel fields. For my question I am using the example of a field called "White Header", the short name is white_header and is is of Type Text Input. When I ...
user avatar
  • 127
0 votes
1 answer
67 views

Attempting to use plugin to addslashes in a template not working

I am fairly new to EE so please bare with me. I have an issue where I want to use addslashes() on a template tag that is in an array. $product_array["{ProductEntryID}"][] = array( '...
user avatar
0 votes
0 answers
92 views

Text field with formatting "None" being wrapped in <p> tags EE2.9.2

ExpressionEngine (pre 2.7.2) used to have an issue where it would start outputting p tags around normal text fields that have default formatting set to "None". The very-temporary fix (which still ...
user avatar
  • 185
0 votes
1 answer
87 views

Disable automatic link creation from Matrix text field

I have Matrix field that has a file cell and text cell with the formatting set to none. If there is a url in the text cell when I access it a template it automatically creates a link. I can't seem to ...
user avatar
0 votes
1 answer
47 views

Leading Zeros in Text Input Fieldtype

Is there any way to preserve leading zeros when using the text input field type? This is getting truncated. :( 0010250107 -> 10250107
user avatar
2 votes
1 answer
129 views

Custom Fields adding <p> Tags

This is an old issue that has resurfaced. I am creating entries using Profile:Edit and Relationships, that have address information and for some reason the first of the series displays all the address ...
user avatar
  • 1,068
0 votes
1 answer
61 views

Text Input Field Being Wrapped in <p> tags only for first entry

I'm running 2.7.2 and I have a text input field called article summary that is set to format none. However on the front end the input is getting wrapped in p tags but weirdly enough it's only ...
user avatar
0 votes
2 answers
3k views

How does one get a ‘soft’ carriage return in a Rich Text field?

When entering text in a Rich Text field it is sometimes desirable to have a soft return — ie. a simple line break within the paragraph rather than starting a new paragraph. In many situations (...
user avatar
  • 603
0 votes
1 answer
170 views

absolute path URL in text field causing problems

i've got a text field that i'm using to include an optional url in entries which are used for homepage announcements. if a url is included, the homepage will link to that url. if not, it will link to ...
user avatar
1 vote
0 answers
27 views

Text format disappears after moving Matrix field in IE9

We are using Matrix version 2.5.10 (Expression Engine v2.5.5) and, when the field is moved up or down, all the formatting in the text disappears (happens only in the IE versions 9 or earlier). Any ...
user avatar
  • 11
3 votes
2 answers
1k views

Unformatted Field Data Wrapped in <p> Tags on Output

I have a text field with formatting set to "none". In the database, the data for that field is stored exactly as it should be: as plain text with no html tags. When I drop the field tag into my ...
user avatar
  • 2,724
1 vote
1 answer
295 views

Weird Rich Text Issue

So I inherited another build and the content editor is the stock Rich Text field type. The content has paragraph and strong html tags in place when you View the Source in the edit entry section, but ...
user avatar
1 vote
2 answers
245 views

Why is Text Formatting: None wrapping <p> tags around my text?

I recently upgraded a site I'm working on to 2.7.1. And now I have some text being output with <p> tags around it, despite having the text formatting set to "none". Is this a bug, or is there a ...
user avatar
  • 21
0 votes
0 answers
94 views

Weird text-formatting after upgrade to 2.7.0

I upgraded a site today from 2.5.5 to 2.7.0. Everything went well except from one ting: When outputting textareas with text formatting none EE will insert paragraphs and whitespaces - expected ...
user avatar
3 votes
2 answers
353 views

WYGWAM - text align center?

I just updated to Wygwams latest version and I don't see the "text align" option anymore. How do I restore it?
user avatar
1 vote
1 answer
264 views

How can I convert special chars into html entities

One of my matrix cells for the caption/description is set to NONE formatting. Sometimes, editors will put in quote marks which confuses my html code. How do I convert any special chars like the qoute ...
user avatar
  • 465
1 vote
2 answers
907 views

Textarea seems to be converting plain text to html entities

I have a textarea field (which i'm using to paste some custom CSS for a page) that has no formatting set on it. However, when I paste the following in; h2 {background-color: #03c7e1;} ...
user avatar
2 votes
1 answer
332 views

Allow EE Code w/ XHTML auto formatting?

Is it possible to use the Allow EE Code plugin and textarea formatting option and also have formatting as XHTML? I have an existing field (textarea with XHTML formatting) with lots of content in many ...
user avatar
3 votes
3 answers
495 views

how can I safely change the empty lines /n in the database to </p><p> so they will be rendered correctly when I change the field type?

On a website with many many entries i've recently changed a textarea field to an expresso field. I now have 2 types of entries, entries with formatting, and without formatting. My idea so far: ...
user avatar
  • 565